1Password only sync's from iPhone to computer, not the other way around

I use 1Password with 3 devices - iPhone 6+ with latest iOS, iPad 3 using iOS 7.12 and MacBook Pro using OS 10.9.5. I sync through DropBox. So, if I enter new passwords on my iPhone the new entry syncs properly. However, if I have a new entry using either the MacBook or the iPad, those 2 devices sync properly, but the new entries won't show up on the iPhone. I go and sync the iPhone and still nothing. I have had to manually enter new information to the iPhone in order to have the same information on the new devices. Interestingly, when I enter the information on the Iphone if it is the exact same information as the information on the other devices, it does not generate a separate entry in those.

  • Is this an issue due to iOS8?


  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Pluto6,

    No, it's not an issue with iOS

    Can you disable the Dropbox sync in 1Password on your iPhone and then re-enable it, does it now work?

  • No, but digging in a bit further - the MacBook Pro and iPad are syncing to Dropbox/1password/1password.agilekeychain and the iPhone is syncing to Dropbox/1password.agilekeychain. When I disable the sync, then re-sync I am given 2 choices - 1 blue that is the Dropbox/1password.agilekeychain. Another is grey and is the /1password/1password.agilekeychain. When I choose the latter grey one, I am informed this vault already exists on the iPhone and the only one I can sync to is the former /1password.agilekeychain. Do I need to change the primary vault?

  • Tried to change the Primary Vault - I touched the primary vault tab and got prompted to start syncing then I get the same result - Vault Exists This vault already exists on your iPhone.

  • WinnieWinnie 1Password Alumni

    Hi @Pluto6‌

    sorry for the troubles you are having. I get the impression you have several vaults on iOS. Could you please check that none of your other vaults is syncing with Dropbox/1password/1password.agilekeychain? If another vault within the app is syncing to that location then you can't use this location again.

  • Nope, no other vaults - just the primary one. Should I delete the app from the iPhone and just download it again and set it up again?

  • Hi @Pluto6,

    Just to confirm: when you go to Settings > Vaults - you do not have more than one vault installed? If so, that's a bit odd. But your suggestion of starting fresh on your iPhone is likely the best way to go. Before we proceed, please be sure that there is no data in your 1Password database on your iPhone that is not stored on your Mac and iPad.

    Here's what we'll do:

    • On your iPad, open 1Password for iOS, tap Settings > Sync > Sync Service and choose 'Disable Sync’.
    • On your iPhone, delete 1Password for iOS.

    • On the Mac, open 1Password for Mac, and click the 1Password menu, then Preferences. Click Sync, and click Change syncing.

    • Check the box to remove the data from Dropbox and confirm that you want to disable sync.

    • Restart the Mac and iOS devices.

    • Check your Dropbox folder and delete any other 1Password folders or files that the remove data checkbox did not take care of.

    • On the Mac, go back to the Sync preferences, and click Dropbox. Click Choose vault, then navigate to your Dropbox folder and select Open. This will regenerate a 1Password folder in Dropbox, and that will contain a new 1Password.agilekeychain file.

    • Allow Dropbox to fully sync.

    • Go back into the iOS app and re-enable Dropbox sync. That should get everything on the same page for sure.

    This should get you all sorted, but if you have any further questions, we're here to help!

  • Thanks, That fixed it. Although it was a little strange that I did the sync with the iPad it gave me a message that the vaults were not the same and recommended that I not merge the vaults. It looked like there was only 1 minor discrepancy and so I did a Merge Anyway. Hopefully that won't mess things up. But the iPhone is now synced to the same vault as the other 2. Thanks for your help and let me know if I may have messed things up with the merge vaults.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @Pluto6,

    I'm really happy to hear @Megan's steps helped you solve the problem! :smiley:

    Don't worry, you didn't mess anything up by choosing to merge vaults. The Vault Mismatch message you saw appears if the vaults in 1Password and Dropbox are at all different from each other (even 1 minor discrepancy). That warning happens just in case you use multiple vaults, so you don't accidentally merge two completely different vaults together. If you're curious, we have more information about that message here.

    As long as your 1Password data is syncing correctly now between your devices, everything is fine and merging was the correct option - so no worries there! ;) If you need anything else, we're here for you.

This discussion has been closed.