iPad only - edit login entry, Delete website doesn't actually delete it

Happy New Year guys

On the latest iPad beta I've got 2 website entries under a login - choose Edit, tap the red minus icon, choose delete, it disappears....
When you tap Done the website hasn't been deleted :(

Same actions on iPhone it remains deleted after hitting Done.

Can someone confirm this bug please?



  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Fedorov,

    Are they duplicates? We have extra code in the app to remove website duplicates automatically as they've caused by sync conflicts. I wonder if that's causing this issue.

    I'm not able to reproduce the issue with two different website fields.

    Also, are you syncing the data and if yes, which sync method are you using?

  • Hi @MikeT‌

    Using Dropbox for sync.

    Wish I could remember exactly which entry I had this issue on yesterday... think it was an old Yahoo login and it had 3 website entries:

    Each time I deleted the 3rd website it would not disappear but when I opened this same 1password beta on my iPhone and deleted and pressed Done it would disappear.
    I was then replicating the issue on my iPad by adding a 2nd website to ANY of my login entries, saving it then going back, editing, deleting it, pressing Done and it would reappear every time!!!

    Couldn't reproduce this on my iPhone, only on iPad.

    I've just tried adding & deleting websites to various existing entries and even tried creating new logins and doing the same - cannot reproduce the issue now! Grrrrrr :smile:

    I have around 150 login items and just randomly viewing each one on my iPad just now, all my Twitter entries have www.twitter.com in TWICE so I've deleted the duplicate entry, same occurs with a lot of other logins, I believe they are the common ones that you now recognise in the new login creation list.

    So I've checked all my logins and tidied them up by removing all these duplicate website entries which I don't believe I've added all of those myself.

    Also noticed while editing some entries that there is a "Conflicts" section further down which I've gone through and removed, the sections were either empty or had an older username & password.

    Is this expected to have all these conflict sections at random on various login entries?

    Also had 1 unexpected crash on iPad so I submitted the report when I launched it again.

    Hope this helps

  • RadRad 1Password Alumni

    Hi @Fedorov‌,

    We recently fixed a lot of sync related bugs in 1Password for both iOS and Mac and it is recommended that you update 1Password on all your syncing devices.

    Can you please tell us which version of 1Password are you using on your iPad?

    Are you using the latest TestFlight beta (5.2.BETA-13 as of today)?

    How about on your iPhone, are you using the same version of 1Password?

    Looking forward to your reply :smiley:


  • Hi @Rad‌

    Yes I'm using the latest 5.2 beta 13 on both iPhone and iPad.

    Also running latest Windows beta of 1Password too. Maybe some issues occurred before you moved to Testflight when I was still able to have the older appstore version on my device as well as the Hockeyapp betas?
    With Testflight I can only ever run the latest beta which is probably a lot better

  • MikeTMikeT Agile Samurai

    Team Member
    edited January 2015

    Hi @Fedorov,

    I was able to reproduce this, it's directly related to Dropbox sync. The logs I was able to capture confirms some weird logic issue with the sync and I've filed a bug report for our team to investigate sooner.

    Thanks for your help!

    Bug ID #: OPI-2184

  • Great news @MikeT‌ that you've been able to reproduce this, certainly had me confused what was going on deleting but not actually deleting! :smile:

  • MikeTMikeT Agile Samurai

    Team Member
    edited January 2015

    Hi @Fedorov,

    It was actually deleted but it was merged back in as the result of a sync conflict. In this case, we've very aggressive here with trying to protect your data as much as possible and not realizing you did in fact delete that field.

This discussion has been closed.