Chrome extension not working for 1Password 5

Hi there,

My chrome extension is not working for 1Password 5 on Yosemite. It is working for Safari (which I rarely used) and Firefox (which I only use for development).

OSX 10.10.1 (14B25)
Chrome Version 40.0.2214.91 (64-bit)
1Pass Chrome Extension Version 4.2.5.90
1Pass 5.0.2 (502006) (Mac Store)

The version of the Chrome Extension being installed is exactly the page from 1Pass 5's "Install Browser Extension Page"

Whenever I hit the 1pass Chrome extension button from inside Chrome, it would attempt to find the mini app. The mini-app will pop up with a, "Use Google Chrome?" Dialog. I hit the button to confirm. The extension then waits for something, and then reports that it cannot be found.

I have previously reported this directly to Agile Bit support through email, however, all I had ever gotten were automated responses.

There was exactly once when the extension started working, likely because Chrome updated something. I was entering a new password and the extension offered to save the password. However, when I tried using the mini-app to go directly to a bookmark, it reports that it cannot do so. It say that maybe Chrome is in the middle of the update. I restarted Chrome, and afterwards, the extension failed to find the mini app.

I found a Jan 6 thread for problems with the Chrome extension on the 1Pass 3. I tried restarting Chrome, reinstalling the Chrome extension, restarting the mini-app, none of which works.

I'm a bit frustrated by this. I got 1Pass in order to better manage the app. It works great on Safari, except that Safari sucks. I'm also frustrated by the lack of response from the direct email. Apparently, I have to post this on the forum to get some attention on the problem.

Please help,
Thanks.

Comments

  • Hi @hosh‌

    I apologise for all the delays you've experienced in trying to get assistance.

    So just to understand better, you use all three of the main browsers; Safari, Firefox & Chrome and have attempted to install the 1Password extension in all three. In Safari and Firefox the extension is working as expected but the Chrome browser is behaving like the browser extension cannot communicate with 1Password mini.

    Normally we'd suspect a firewall or anti-virus program was blocking the two from communicating via a web socket but that seems unlikely given you have two browsers working. Can I ask, does the problem exhibit itself in a fresh Chrome profile? I also wonder if daring to trash the Google Chrome app and reinstall it would make any difference but I do hesitate there as I don't know what that does to your existing Chrome profile (which we don't want to harm). I may need to find somebody more comfortable with Chrome to see if they can think of anything.

  • hoshhosh
    edited January 2015

    @littlebobbytables‌ thanks for the reply!

    I have not tried it with a fresh Chrome profile. I might give it a try later today, however, that doesn't necessarily solve things since I'd want to use this on my current profile.

    By "trashing the Google Chrome app" I take it you mean deleting the app on OSX and reinstalling it. I can give it a try, but, I had tried this on a freshly installed Google Chrome after the upgrade to Yosemite. By "upgrade", I mean that I manually backed up my dev files, documents, and such (using tar and ssh), wiping the disk, installing Yosemite, and then hand copying over things like my bash profile, ssh keys, etc. I did not use TimeMachine, and I did not port over the old Chrome app or settings. I did, however, backup to the Chrome profile and once installing Chrome, logged into that profile. As you know, the cookies and everything has been reset.

    Also note, both Chrome and Safari uses the system proxy settings, Firefox does not. My system proxy setting is set to route things through a personal server, not sure if that will affects websock connection. I'll try shutting off that proxy later today and see if it finds that app.

  • Hi @hosh‌

    The fresh profile suggestion is merely a troubleshooting step and certainly not intended as a solution. The goal here is to try and eliminate different possibilities. If it works in a fresh profile then we've managed to ascertain it's something specific in your existing profile e.g. an extension conflict.

    If it is we can work at establishing the precise issue, if it doesn't work we've at least eliminated it being anything to do with your profile.

    Proxies can mess things up just like firewalls and anti-virus programs so it's worth checking that localhost is allowed although I'd be a little perplexed given Safari is working. Just in case it applies (given you've set up your own proxy) one of our other users found that if you use Auto Proxy Discovery then you must set the ignored ranges on the proxy and not the client machine, see this thread for better details.

    Let us know how you get along.

  • hoshhosh
    edited January 2015

    @littlebobbytables‌ I was able to resolve this issue with Google Chrome by adding localhost to the exceptions list for the proxy.

    Thanks for help out!

  • Well now I am confused, Safari was working with the same proxy settings but Chrome wasn't? Good to know so thank you for reporting back @hosh‌

  • I am new to 1password. Bought it yesterday. Im using it on yosemite on my new laptop and imac. I use Chrome, but the plugin wouldnt work. I reinstalled, restarted and fiddled around for hours. Then I tried it on safari and it worked a dream right away. Then I returned to Chrome without a restart or anything and chrome worked. This was the same on both my computers! Worth a try if you are having similar problem, it might work for you too?

  • Thank you for posting your findings @Alex77. Certainly it shouldn't be required so it's odd that you have to go through those steps. Was there anything you did between attempting to make the extension work in Chrome in the first steps and shifting to Safari? did you open 1Password or anything like that at all?

  • @littlebobbytables hiya, no it really was simply installing the plugin in safari. then clicking back to the chrome window and it worked? could of been a coincidence but seems weird that it happened on both machines?

  • sjksjk oversoul

    Team Member

    Hi @Alex77,

    Thanks for follow-up. I'm not quite sure what might have caused what you've reported, but on Yosemite I've sometimes had Safari mysteriously stop opening pages on a web site, then mysteriously be able to open them again after they've been opened with Chrome.

    Please let us know if the 1Password extension starts misbehaving again and maybe we'll be able to determine what's happening after some troubleshooting. Thanks!

  • My Chrome extension stopped working... exactly as describe above. Fine in Safari. I think the Chrome extension is looking for version 4 rather than 5. No idea what changed.. unless it was a background update of Chrome. OS X 10.10.4

  • littlebobbytableslittlebobbytables

    Team Member
    edited August 2015

    Hi @dbrack,

    What version of Chrome are you running? If you're running the developer branch, AKA Canary then you're running version 46 and our extension is broken there. For more on this check out this post [edit: and also this one]. If you're not running Canary please let us know what version you are running as it probably isn't that issue.

  • it was 46... I've removed it and reinstalled Chrome. Thanks.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @dbrack,

    Did you reinstall Chrome version 44? If so, did that take care of the problem? If you're still having any trouble with that, just let us know and we'll be glad to continue helping you with that. Thanks! :)

  • I'm having this same problem. Noticed the comments about proxy servers, and I am on a proxy at work. Sure enough, when I get on the open WiFi here and out from behind the proxy then the 1Password Mac Chrome extension starts working again. I can then reconnect to the network and proxy and the extension keeps working. But as soon as I quit and restart Chrome it's non-functional again. Like others, it works fine for me within Safari behind the proxy. Any guidance on how to adjust my settings to get it to work with the proxy? (Mac OS 10.10.3, Chrome 44.0.2403.155, 1Password 5.3.2)

  • MeganMegan 1Password Alumni

    Hi @davidbf,

    We've got an article in our support pages that discusses how to Configure proxies on your Mac. Does changing these settings help at all?

  • Hi Megan,
    Unfortunately that didn't help. FWIW, our Mac user-end proxy setup calls for using the Automatic Proxy Configuration with a proxy.pac file as wells as individual lines enabled under that for Web Proxy and Secure Web Proxy. Per the article you sent I added 127.0.0.1 to the bypass list (twice actually, per the document though that seems wrong) but that didn't seem to help.

  • Greetings @davidbf,

    A while ago we had a very clever person bring to our attention some wisdom they'd gained regarding proxies. You can read what they found in the thread 1Password 4.4.3 and Mavericks 10.9.5 Proxy WPAD Settings. The gist is that it may be the proxy config on the server needs to be adapted to allow localhost communication. Could this be (sadly) the required action in your situation? If you have a helpful and responsive IT team then remove the sadly from that last sentence :smile:

This discussion has been closed.