Mac OSX to iPhone IOS over Wi-Fi fails

Hi

I haven't been able to sync 1Password from my Mac to my iPhone for the last couple of weeks.

I'm running the following OS:
OSX: 10.10.2
IOS: 8.1.3

All units are connected to the same AP
Ruckus R700, firmware: 100.0.0.0.127 (No client separation)

When trying to sync I will get the following error after one or two minutes "Error Domain=NSPOSIXErrorDomain Code=57"

To be sure that there is a connection I have changed the password, an the error message on the iPhone is "incorrect secret" which means that there is a connection. Setting the correct PSK on the iPhone will result in the previous message.

I have now testet the setup on my iPad, and 1Password ask for my Mac password!! I have newer seen that before.
When not providing a password I get ErrorDomain Code=7013 (My password does nok work) :-)

I have done the following:

  • Restarted my Mac and iPhone
  • Created new PSK in 1Password
  • Added 1Password to the firewall
  • Disabled the firewall on my Mac (when testing)

Can you help with this issue. The iPhone issue is the important one.

Best regards
Henrik

Comments

  • byakkobyakko
    edited February 2015

    Same issue for me, and Wifi Sync was working fine 3 weeks ago.
    At first I thought that the last upgrade of 1Password was the problem... Sorry about that Agilebits ;) So I get back to the previous 5.0 version, but sync is still not working.
    I guess the last upgrades of OS X or/and IOS are the origin of this trouble... and I'm stuck with no idea how to solve this !

  • Hi @hawj and @byakko

    Lets start with a quick troubleshooting step. Does Wi-Fi Sync work if you Create an ad hoc network?

    It isn't meant as a solution, merely it will help establish if it's network issue with your setup. Let us know the results.

  • byakkobyakko
    edited February 2015

    Hi @littlebobbytables,
    I've tried the ad hoc network, tried to turn off OS X firewall and Little Snitch accept everything, checked my hostname, changed the secret... and some other things found in this forum. Nothing worked, and the sad thing is it was working perfectly fine some weeks ago.
    I've tried to switch off other network services (dropbox, evernote and some others) to avoid any conflict, but no change.
    Bonjour doesn't look like a problem as my computer shows up on wifi sync on the iPhone.
    And the sync from my iPhone is able to detect my vault on my mac as it asks me to unlock it when needed. But no sync occurs...

    I'm stuck on a "Sync started", ending by "Error Domain=NSPOSIXErrorDomain Code=57" like @hawj.

  • Hi @byakko,

    All my readings on Code=57 say it's a web socket issue after entering background or sleep. If that is correct though rebooting should rectify it.

    I know hawj said they'd tried rebooting but I would like you to confirm that the following sequence doesn't work please.

    1. Quit 1Password on both devices. Don't just send it to the background on iOS but completely quit it.
    2. Power down both the Mac and the iOS device completely. For sake of thoroughness turn off the router as well.
    3. Turn them all on again.

    When you try to Wi-Fi Sync again does it make any difference? Please do let us know the results.

  • Hi @littlebobbytables , thanks for your help.
    Unfortunately I tried the sequence but it didn't work.

    Then I saw an answer on another post yesterday with probably the same issue, so like @jsherman I finally gave up and deleted my iOS 1Password app.
    I tried to check before deleting if I could identify updates since the last sync, but I didn't see any way to do so on the iOS app, so I hope there was no loss...

    Now with the reinstalled iOS app the wifi Sync is working again, hourra ! (meaning by the way that the 1Password 5.2 update on iOS is probably the origin of our trouble... but the fresh install is ok).

  • So whatever the issue was, a complete reboot didn't purge it but completely deleting the app did. If you ever see this again @byakko please do let us know. Next time I'd like to grab some logs before you go through the steps to correct it. At least you're now up and running again.

    There is a way to create a backup of your iOS vault so again, if it ever happens we can at least ensure you keep any possible un-synced changes there may be.

  • Now I realize : master password on the iOS vault was different of master password on mac. As I understand since the 5.2 update the master password is now synced. Maybe this was part of the problem?

  • That's a very odd error to throw if the issue was the Master Password. It's hard to say and possibly tricky to reproduce. We may have to just take the now working Wi-Fi syncing devices as a win.

  • Hi

    I also had to remove 1Password from the iPhone. I did that when I discoverd that the problem was only related to one of my iOS units connecting to my Mac Air, and the iPhone could sync with Mac at work. Maybe 1Password contain some cached information related to the connection that have been corrupted.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @hawj,

    Do you mean that you deleted 1Password from your iPhone, and then reinstalled it, and now Wi-Fi sync is working? Or are you still having trouble with Wi-Fi sync after reinstalling 1Password? I hope everything is working correctly now, but we're more than happy to help if you're still having a problem with that.

This discussion has been closed.