Auto-Type

Does not work
Hello!

I'm using Windows XP sp3.
Auto-type does not work for me!

I tried 1Password versions 1.0.3.165 and 1.0.4.172, but with both of them 1Password does not do auto-type.
My test-case is the following:
1. Launch an application, notepad for example
2. Launch or open 1Password
3. Select a login record
4. Click on Auto-Type button in 1Password menu
5. The previous application (notepad) gets activated, 1Password becomes inactive
6. Nothing gets typed into the application (notepad).

I tried with the following applications without any luck:
1. Notepad
2. Internet explorer
3. Mozilla
4. Opera
5. MS Word

At the same time, with the same application Password Safe performs Auto-Type without any problems so for me it looks like an issue with 1Password.

Crazily enough, 1Password types into cmd window! Yes, into console window of c:\winnt\system32\cmd.exe

My default and mostly used browser is Opera, so for me working Auto-Type feature is crucial.
Please, fix it!

If you need further info about my OS, please let me know.

Thanks
Stas

Comments

  • DBrownDBrown 1Password Alumni
    edited February 2011
    Welcome to the forum, Stas!

    I just tested the Auto-Type tool in every one of those programs, except Opera (I don't own it), including the DOS prompt.

    In all of them, 1Password typed the username, a tab, and the password where I had placed the insertion point.

    Here's a screen capture of it working in Notepad: http://screencast.com/t/G4UhHD5D

    Please see the instructions for using the auto-type feature: http://help.agile.ws/1Password_Windows/auto-type.html
    (Those screen shots were taken by allowing the feature to work in the AIM login window.)

    Note that you do have to place the insertion point where you want the auto-type feature to "type" the first string (or the selected string, if you click either of the single-field auto-type icons).
  • Hello, David!

    Thank you for reply.
    I trust, that it works for you, but here is the proof that it does not for me :(

    http://www.screencast.com/t/OXyum38AZ

    I'm really willing to help sort this issue out, so i did some investigation.
    I found out that if i boot my Windows XP in safe mode, 1Password Auto-Type feature starts working, but in safe-mode only.
    This gives me a hint that a problem may be in some application/service or driver.
    I spent some time stopping all non-default windows services, removing video drivers and uninstalling software, which came pre-installed with my Lenovo ThinkPad laptop. However none of that helped: Auto-Type still does not work.

    I will be very grateful if you give me an idea what it could be that stops Auto-Type feature from working. Or if you could ask 1Password for Windows developers.

    Regards.
    Stas
  • David,

    luckily i found the reason why Auto-Type in 1Password did not work.
    That's because i have several input languages configured: russian and english.
    See my screen cast.

    http://www.screencast.com/t/jmszzmIwTm

    Could you please report this issue to the 1Password for Windows development team, so that they can fix it.

    Could you please let me know when it has been fixed?
    I'll purchase the license for 1P on that very day :)

    Regards.
    Stas.
  • DBrownDBrown 1Password Alumni
    Thanks so much for that information and video, Stas!

    I will, indeed, pass them along to the developers immediately.
  • DBrownDBrown 1Password Alumni
    edited March 2011
    Stas, I apologize for the delay!

    Neither the developer nor I have been able to reproduce the reported behavior...

    Can you think of anything different in your setup that might help us reproduce your test case?

    Thanks for your patience!
  • I cannot seem to reproduce this problem either.
  • Hello, David and Stefan!

    Excuse me for delay: i was really overloaded recent months.
    But now i have one more idea about what is going on with my 1Password.

    Take a look at the capture
    http://www.screencast.com/t/2JF1VrKxMm

    It seems to me that the problem lies in the "Advanced Text Services" of MS Windows XP.
    In the capture i did i simply kill ctfmon.exe process, which does the ATS job.
    Alternatively i can go to
    Control Panel -> Regional and Language options ---> Languages --> Details --> Advanced
    and select "Turn off advanced text services"

    After that 1Password will start do auto-typing, but i will not be able to switch between English and Russian, so it is not a solution for me :(

    I did some quick google search on the matter and here is what i found of interesting

    http://www.bigsoft.co.uk/blog/index.php/2010/08/10/switch-off-advanced-text-services-ctfmon-exe
    http://support.microsoft.com/kb/282599

    Seems like ATS is also affected by MS Office. I have Office 2003 installed on my laptop.
    I tested with the latest 1.0.5.189 1Password version.

    Looking forward to hear news from you.
    Stas
This discussion has been closed.