1P.34 Fill not working at macworld

Chris1234Chris1234 Junior Member
edited February 2011 in 1Password 3 – 6 for Mac
Here 1Password v 3.5.4 Fill on the Macworld page is not working. I tried several time and then realized it is perhaps completing the Google Custom Search box instead.

So it seems to be completing the first box on the screen, without checking to ensure that this is the correct box! And Go and Fill Login also doesn't work.

This happens on some other sites too... I have latest MacOSX Snow Leopard 10.6.6 in 64 bit mode on my 2 Ghz Intel Core 2 Duo with 8 gigs memory.

Any and all help would be much appreciated. Thanks.

Comments

  • khadkhad Social Choreographer

    Team Member
    Hi Chris,

    I'm sorry that you're having this problem. Please update to the latest version of 1Password (3.5.7), and then try saving the login manually like this:

    1. Enter your username and password, but DO NOT submit the form.
    2. Click the 1Password button in your browser's toolbar, and choose Save Login.
    3. Set the Action field to Create New Login (or to Replace <login-name>, to update an existing Login item).
    4. Click the Save button.

    Using the above technique I was able to save and fill a sample login from 1Password 3.5.7 in Safari at:

    http://www.macworld.com/logon

    Manually saving a login can be useful for logins that are either problematic to begin with or were once working but have since stopped. Doing this allows 1Password to refresh everything it "knows" about the page. Login pages often change as websites are updated and this can be a necessary but very useful tip. :-)

    If you are still having trouble, please take a look at our "Website Login Issues" guide:

    http://help.agile.ws/1Password3/login_issues.html

    Note especially that editing the login to change the Submit value from "If Autosubmit is ON" to "Never" works on a lot of sites which modify the form before submitting it or are looking for a literal key press or mouse click. This will give you the chance to actually give them what they are looking for by submitting the form yourself rather than allowing 1Password to do it on your behalf.

    I hope that helps. Please let me know.

    Thanks!
  • Chris1234Chris1234 Junior Member
    Thanks, khad, I had auto update set to once a month, and that's obviously not frequently enough...

    Here 1Password v 3.5.7 Fill on the Macworld page was still not working. So I changed the brand-new Login to Submit > Never, and now it works.

    But 1P is reporting the Submit > Never incorrectly, I saved this in Edit mode, see first png. But in regular mode, the item still reports it as Login Submit! see the second png taken a few seconds later. see:

    http://www.reducestressnow.net/filez/1P.34b-Login-Submit-reported-incorrectly.png

    So this problem is another, a different bug. Yet it's good that we can now see the Submit status without editing the item, thanks for fixing this issue.

    Appreciate your help, Cris
  • khadkhad Social Choreographer

    Team Member
    Cris,

    Please try deleting your existing Macworld login(s) and then save one manually as described above. I am not able to reproduce any problems with my Macworld login in Safari. My Macworld login fills and autosubmits perfectly. :S

    Are you perhaps using a different browser?
  • Chris1234Chris1234 Junior Member
    khad wrote:

    Cris,

    Please try deleting your existing Macworld login(s) and then save one manually as described above. I am not able to reproduce any problems with my Macworld login in Safari. My Macworld login fills and autosubmits perfectly.


    Now I'm worried, khad, I tell you thanks, my brand-new MacWorld login (saved manually exactly as you instructed) is now working, and you tell me to delete it and save it manually again! But I've just already done that - exactly as instructed!

    I use both Firefox and 64 bit Safari. But shouldn't manually Saving a Login work on both? I know the 1P forum has issues with using Safari, so I only use Firefox for this forum, but does manual Save also have issues with Safari?

    Finally, I report a different bug - for which I provide both visual evidence and a writeup - and you ignore it... What's up?
  • khadkhad Social Choreographer

    Team Member
    I think I am having a hard time understanding your posts, Cris. I apologize.

    I read the bit where you said, "…1Password v 3.5.7 Fill on the Macworld page was still not working," but missed the bit about it working. However, you mentioned something about changing the Submit value which would indicate to me that there was a problem with autosubmit for you. This should not be the case, so I was concerned there may be another issue at hand.

    The screenshot you posted does not show a bug that I can see. The word "Submit" under the "All Fields" section of the login details is one of the form fields on the Macworld login page and is unrelated to the "Submit" value you can change in 1Password via the dropdown menu. The "Submit" value (which you can set to "Never" if you are having a problem with autosubmit) is not displayed without editing a login.

    You should be able to log in to the Macworld site regardless of the browser you are using with the Submit value still set to the default value of "If Autosubmit is ON" and autosubmit enabled in your browser.

    Manually saving a login should be identical in both Safari and Firefox. Is this not your experience?

    Also, I only use Safari when working in the forums. Could you be a bit more specific about what sort of "issues" you are having using Safari in the forums?

    Please let me know. Thanks!
This discussion has been closed.