1Password4 extension won't open with Google Chrome

With the extension, I can log into it, but after the first time I use it, it will no longer open. I can open the desktop version, but I'd like the extension to work.

Comments

  • DBrownDBrown 1Password Alumni

    I'm sorry you're having that problem, @dlg5.

    Have you tried any of the tips in the Troubleshooting > The browser extensions article in the 1Password 4 for Windows knowledgebase?

  • edited February 2015

    I think I might be having the same issue with chrome. The toolbar button appears but when I click on it nothing happens, the button is just dead. Nothing has really changed, been working for months. If I had to guess the recent update is the issue...

  • svondutchsvondutch

    Team Member

    The toolbar button appears but when I click on it nothing happens, the button is just dead.

    @freeskier93 Please turn OFF this setting: Help > Advanced > Verify web browser code signature

  • Thanks for the tip about going to chrome settings/help/advanced/turn off Verify web browser code signature. the chrome extension went from being dead to performing perfectly.

  • Turning off verify web browser code signature doesn't do anything for me. I can kill the helper process in task manager, then when I click the toolbar button in Chrome it pops a tab up searching for the helper then the "Welcome to the 1Password Extension!" dialog. So connecting to the helper doesn't seem to be the issue.

  • DBrownDBrown 1Password Alumni

    Thanks, @Bernfrin. Full instructions are available in this article in the 1Password 4 for Windows knowledgebase.

  • DBrownDBrown 1Password Alumni

    @freeskier93, that "searching...welcome" message appears if you invoke the extension when the helper isn't running (after you terminate it in Task Manager, for example), so that aspect is working as expected.

    Can you describe the behavior that leads you to believe the 1Password extension isn't working in Chrome?

  • It's not working in the sense that when I click the toolbar button literally nothing happens. The drop down just doesn't appear.

  • svondutchsvondutch

    Team Member

    when I click the toolbar button literally nothing happens.

    @freeskier93 Please turn OFF this setting: Help > Advanced > Verify web browser code signature

    Then follow ALL the steps in this article: https://guides.agilebits.com/1password-windows-kb/4/en/topic/troubleshooting-extensions-win

    Thanks!

  • @freeskier93 Which anti-malware software are you using?

  • edited March 2015

    Well it started working again. Recently I've been having issues with the Plex server, so I wiped every trace of Plex off and re installed the server and now 1Password extension is magically working again...

  • brentybrenty

    Team Member
    edited March 2015

    @freeskier93: I'm glad to hear you were able to get it working! That's a new one for me, but it seems that a lot of apps these days are causing some trouble when it comes to 1Password communicating with the browser extensions. That's a strange issue, but I am glad reinstalling Plex resolved it!

    Code verification is a failsafe to ensure that the connection between 1Password and the browser extension is secure, to keep your 1Password data safe. However, whether it's some unwanted software on your computer or something you installed yourself, if it is intercepting communications from 1Password, it will not, be able to authenticate as 1Password. Whether malicious or not, 1Password simply disables the extension, rather than sending your data to an unknown entity.

    You can always check out the knowledge base for more info, but it sounds like you should be all set. Cheers! :)

  • MikeTMikeT Agile Samurai

    Team Member
    edited March 2015

    Hi @freeskier93,

    I think what @brenty is trying to point out is that if you've disabled code signature as part of svonduch's suggestion, please turn it back on, and see if 1Password still works.

This discussion has been closed.