Samsung 4G phone

My wife and I have purchased I Password for our computers and it works fine. My wife and I have the same Samsung 4G phones, probably about 3 years old.
My phone has firmware version 2.2.1. My wife's Phone has firmware version 2.3.6.
Two years ago I successfully installed the 1 Password app from the Google Play Store on to my phone. However, recently when I try to download the same app on to my wife's phone, the Play Store App tells me that her "device is not compatible with this version."
Please help.
Thank you.

Comments

  • Two years ago you'd have been installing the old 1Password Reader app. This does not appear to be available any longer. The current version is completely new and much more capable.

    You say "firmware" version. Do you mean the Android version, or something else? If it is the Android version then v2 then I hate to say it, but you're horribly out of date:
    http://en.wikipedia.org/wiki/Android_version_history

  • On my wife's phone, under settings, when i click on "about phone" it simply says "Firmware version 2.2.6" I assume it is an Android firmware.
    When I read the requirements of the new app, it says it requires a minimum 2.2 firmware - which she has. So, I am still confused. Please stay with me on this. Thanks.

  • Can you confirm where you're seeing that?
    GooglePlay doesn't mention Firmware as far as I can see:
    https://play.google.com/store/apps/details?id=com.agilebits.onepassword

    It just states Android v4.0 or above as a requirement.

  • Oh, and you can find your devices Android version like this:
    http://www.wikihow.com/Check-What-Android-Version-You-Have

    As far as I'm aware, it's never been listed as "Firmware".

  • periperi

    Team Member
    edited February 2015

    Hi Dr. Ted. Can you confirm the Android version your Samsung phones are running based on the guides Richard provided? It sounds like you're using Froyo (2.2) and your wife is using Gingerbread (2.3), correct?

    If that is indeed the case, then unfortunately you won't be able to install 1Password 4 for Android without upgrading your software. 1Password 4 requires Android 4.0 or later.

    For users that are running a device that's not compatible with 1Password 4, we recommend continuing to use 1Password Reader. You can download 1Password Reader by following this link below:

    http://cdn.agilebits.com/sm/downloads/1Password_Reader.apk

    To install 1Password Reader, please ensure installation from Unknown Source is enabled. To enable this option, please follow these instructions below:

    1. Go into Settings > Security on your Android device
    2. Check the box beside "Unknown Sources" to allow installations from apps outside of the Google Play Store

    Please let me know if that clarifies things a bit, or if you have further questions. Thanks! :)

  • Peri,
    I downloaded 1Password Reader, but it doesn't recognize the file in Dropbox or the SD card where I put 1Password file.
    Thanks,
    Ted

  • periperi

    Team Member

    Hi Ted. Thanks for the update!

    Is it only 1Password on your wife's phone that isn't syncing properly, or are you having trouble with your phone and computers as well?

    Also, can you verify that you've transferred the entire .agilekeychain folder onto the SD card?

  • Peri,
    My tech friend today transferred the entire .agilekeychain folder to my wife's dropbox and to my SD card. I can verify the dropbox.I can see it in my wife's dropbox, but when i try to synch 1Password, it says: cannot locate 1Paswword file inside of dropbox
    I see a 1Password file on my wife's sd card, but when i try to open it, it says: no subfolders underneath.

  • periperi

    Team Member

    Thanks for the update. It sounds like things are syncing and working properly on your device, correct? Are you both sharing a 1Password vault, or do you have separate vaults?

    The reason I ask is because if you and your wife are sharing the same vault, and if you've verified that the vault is intact and syncing properly from your Dropbox account, you could share that folder with your wife. To do that, open your Dropbox account and locate the 1Password folder and click Share. This will allow your wife to use the same vault.

    If your wife prefers the SD card approach, I recommend re-transferring the .agilekeychain. The .agilekeychain folder has several files inside, which can be tricky to transfer.

    Please let me know if you're able to successfully share or re-transfer the vault!

  • What exactly is the file that needs to be in Dropbox or on my SD card? Is it the 1Password backup file - the zip file? My phone won't recognize this backup zip file in either location.

  • The entire .agilekeychain folder.

  • I have the entire keychain folder 1Password.agilekeychain in my dropbox and on my SD card but neither is recognized when I sync.

  • When I try and sync with SD card my phone doesn't see the 1Password.agilekeychain folder.
    When I try and sync with Dropbox it fails "Cannot locate 1Password data file inside of Dropbox."

  • saadsaad

    Team Member

    Hey @mbromak. Sorry to hear you're not able to configure your data folder with 1Password on Android. Let's figure out what's going on. I'd like to ask you to try to log into 1PasswordAnywhere and see if you are able to view your items there. To do so, log into https://www.dropbox.com in a web browser and open the 1Password.html file in the 1Password.agilekeychain you're syncing to in Dropbox.

  • Hi Saad - thanks for your help. Yes the html works fine.

  • saadsaad

    Team Member

    Great to hear that. Have you selected the same data folder (1Password.agilekeychain) during sync configuration? If you are unable to sync using the same data folder, tap on the "Send sync report" button below the master password field. Let me know when you have sent it and I will review the sync report with the error message.

  • Still need help on getting my phone to sync.

  • Okay Saad - I've emailed the sync report.

  • saadsaad

    Team Member

    Thanks for sending us the sync report. The report tells us that you are using a very old version of 1Password (1Password Reader) and I would like you to upgrade to 1Password 4 on your Android device by downloading it from the Play Store. After upgrading, select I've used 1Password Before > Sync using Local Storage and let me know if you are able to sync properly on this version. Thanks.

  • I finally got my phone to sync with dropbox. It appears that all of the keychain files didn't copy to dropbox and that's why it wouldn't sync. I had to manually create all of the subfolders under the main keychain folder and manually drag and drop the files into each folder.

  • saadsaad

    Team Member

    It's really odd you had to do that..but I am happy that did the trick! :) Did you also update to the newer version of 1Password? We improved a lot behind how sync works and our latest version will make sure you get the best experience with syncing.

This discussion has been closed.