Firefox extension issue

Hello, I am having an issue both on my work computer and home computer where the prompt to enter the master password for 1password does not come up when I click the button. This happens frequently but not every time, and seems to work ok sometimes. If this happens there will be no action/menu from the button until I close firefox, at which point the small window with the prompt for the master password will come up (and keeps coming up, once for each time that I had clicked it while firefox was open. If I restart firefox it will tend to work again, at least for a while. Thoughts? Firefox 35.0.1.

Comments

  • brentybrenty

    Team Member
    edited February 2015

    Heya, buddha34! That certainly sounds curious.

    I've seen similar issues with corrupt Firefox installs, but a good place to start might be just removing and reinstalling the extension. Also, make sure the 1Password app is up-to-date (the extension will be once you reinstall it, of course), and let me know if that helps. :)

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @buddha34,

    In addition to brenty's suggestion, do you have other extensions in Firefox that could interfere with how sites are loaded? Like a filtering extension or cookie management?

  • Thanks for the suggestions guys. I do have adblock plus on both machines, and have tried disabling temporarily to see if it helps but couldn't detect a correlation. Will try to leave it disabled for a while and see if that helps, and if that doesn't work will remove it and reinstall.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @buddha34,

    Can you tell me which version of 1Password you're using? You can find out by opening the main 1Password application and go to the Help Menu > About 1Password... Also, what's the Windows version you're using? You might want to update Firefox as well, it is at 36 right now.

    You might also find this guide useful: https://guides.agilebits.com/1password-windows-kb/4/en/topic/av-am-fw-programs

  • Firefox automatically updated last night, coincidentally, to 36. 1password is 4.1.0.538.

  • Did it make a difference or does the problem still exist?

  • I'm having this issue on Windows 8.1 with FF 36. It's a new computer that only has a few addons/extensions. If I login to the app and do "ctrl + \" I can get the extension menu to come up so that I can use it, but no matter what I try I cannot get the extension to prompt for PW.

  • brentybrenty

    Team Member
    edited February 2015

    @aadadams: Yikes! Sorry for the trouble. I tested this on my own 8.1 machine with FF36 and didn't run into this issue, though. :(

    I had to restart Firefox a few times to get it up to date since I hadn't used it in a while. Initially the extension could not connect to the 1Password Helper, but updating solved that issue. From your description, it sounds like it may be a communication issue between 1Password Helper and the extension, since it seems to work in one direction but not the other.

    Close Firefox, open 1Password, and try Help > Restart 1Password Helper. Give it a minute to restart/update, and then reopen Firefox. It might also be helpful to check the knowledge base to see if it may be related to some other configuration or software on your machine.

    And just to make sure we're on the same page here, if Universal Unlock is enabled (File > Preferences > Browsers), the browser extension will unlock when the 1Password app does. You can always turn that off if you want each to unlock separately. I hope this helps! :)

  • My issue did not happen yesterday, after the firefox update to 36, however I was not at my desk much so did not give it a solid test. I did not have to disable adblocker. Will update in a few days, as the issue was happening only sporadically.

  • aadadamsaadadams
    edited February 2015

    @brenty Unfortunately, the extension is still not working for me natively. The only third party plugin that i have is adblock plus. I initially disabled it and 1password didnt work. I later removed it and 1password still didnt work. The only way that i have been able to get the extension to work is with code verification disabled. Is there any other possible fix that I may try as I am leery about turning that safety feature off.

  • brentybrenty

    Team Member
    edited March 2015

    @buddha34: That's good to hear, but as you point out it was only a sporadic problem...so ultimately only time will tell. Keep us posted!

    @aadadams: I am glad to hear that workaround at least is effective. Do you have AV software running that might be interfering with the 1Password-Helper communication?

    Essentially, code verification is a failsafe to ensure that the connection between 1Password and the browser extension is secure -- which we definitely want since we want our 1Password data safe!

    However, whether it's some unwanted rogue software on your computer or security software you installed yourself, if it is intercepting communications from 1Password, it will not, of course, be able to authenticate as 1Password on either end. This is a Man-in-the-Middle, whether malicious or not, and for your security, 1Password simply disables the extension, rather than sending your data to an unknown -- and therefore untrusted -- entity.

    Definitely check out the knowledge base, as the information there may help you track down the culprit and find a more tenable solution (e.g. creating a firewall exception) than turning off code verification. I hope this helps! :)

  • Assuming this is related to my windows firewall and/or McAfee Enterprise Edition AV any idea how to adjust the loopback parameters?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @aadadams,

    Windows Firewall usually isn't an issue. If it is McAfee, do you have the power to whitelist a specific address or an app? McAfee Enterprise Edition is usually used on work computers that are locked down by IT departments.

  • Have had no issues so far this week after Firefox update. Crossing fingers. Thanks again.

  • brentybrenty

    Team Member

    @buddha34: Thanks for the update. I'm glad to hear all is well! :)

    @MikeT: Seconded! Microsoft has made a number of concessions in Windows 8 for AV software to better integrate with Windows...but not all of us can (or want to) use Windows 8. And ultimately software vendors go much further than that. If Windows itself is locked down in a corporate environment, there's a good chance access to security settings will be too, unfortunately. :(

This discussion has been closed.