Sync lost all old items

Just synced on phone & now only the 4 new updates are showing. All existing data is gone including logins, identities, etc. 1Password looks fine on Windows 7 application & in Windows Chrome browser plug-in. Tried to resync & got "No updates found". Reconfirmed DropBox for sync location. Cache was at 5 MB, reset to 10 MB (think I have around 300 items). Still no luck ;-(

Samsung S4 mini
Android 4.4.2
1Password 1.8.5.2 (Play store says I'm up to date)

Comments

  • periperi

    Team Member

    Hi @archymcn. I'm sorry to hear about your syncing troubles, and I'll be glad to help you get back on track. :)

    It sounds like you've verified that all of your data is safe on your Windows devices. I'd like you to also verify that your data is intact in Dropbox using 1PasswordAnywhere. To do so, log into https://www.dropbox.com in a web browser and open the 1Password.html file in the 1Password.agilekeychain you're syncing to in Dropbox. Do all of your logins look okay there?

    It looks like you're using an outdated version of 1Password for Android--1Password Reader. The current version is 1Password 4, which is available in the Play Store. If you've verified that your data is safe in Dropbox, I recommend upgrading to 1Password 4 through the Play Store. Then reconfigure sync with Dropbox.

    Please let me know how that goes!

  • Thanks for the help peri. No, the dropbox html file is incorrect. It only shows the 4 logins that are on my phone. So the problem is syncing between my laptop and Dropbox I would assume. How do I fix that? When I try to open the same html file on my computer form c:/Users/(me)/Dropbox I get "encryptionsKeys.js file" had a load problem - or is that html file not loadable w/ !PasswordAnywhere? I appear to be on Dropbox 3.2.6 for Windows.

    btw, how come Play Store did not upgrade automatically to version 4? Do I have delete my current version from the phone before reinstalling?

  • Peri. Interestingly, I just checked my work computer and there are NO problems there. In fact the 1Password file on that Windows XP machine appear to be accurate & current (including a password update I made after the sync problem on the phone that is NOT showing on the phone). Can I assume that this html file is used to feed the android version of 1Password? And if so, how come it's wrong when the underlying data files appear to be correct?

  • periperi

    Team Member

    Thanks for the update! The reason that the Play Store did not automatically upgrade you to 1Password 4 is because our licenses are version specific. This means that 1Password will automatically update point upgrades (like 4.1.5-4.1.6) but the upgrade from 1Password 4 to 1Password 5 will need to be manually activated.

    That said, it sounds like you are indeed correct that the problem is occurring on your laptop. Can you please verify the following facts?
    1. You are trying to sync 3 devices; Android, laptop (Windows), and work desktop (Windows).
    2. Your work desktop's 1Password vault is up-to-date.
    3. Your laptop's 1Password vault is up-to-date.

    Please let me know if I've gotten any of that wrong. For now, I'd like you to open 1Password on either your laptop or desktop and choose File > Repair 1Password Vault. A dialogue box will appear with the message that your vault is healthy and no errors were repaired, or that it was able to repair some files.

    If it was able to repair files, please check your vault in Dropbox once again with 1PasswordAnywhere. Does all of your data show up there now?

  • That did the trick Peri - THANKS! Obviously the repair said something like "File repaired" not healthy. Then Dropbox re-synced & the 1Password Anywhere showed all my correct data. And then my Android phone was re-synced & again everything was back in place. Took a new good backup of 1Password files on laptop and good to go. I'll update to Android version 4 next when I get a minute & let you know how that goes.

    Thanks so much again. Didn't know about file repair function. Should have been able to find that myself, but your help is sincerely appreciated (& timesaving!)

  • upgrade to Android ver 4 went fine - think I'll hold off on upgrading to 4 on Windows as long as 1 is still supported & working (& since XP isn't supported) - thanks again for all your help!

  • periperi

    Team Member

    That's great news, @archymcn! I'm so glad to hear you were able to repair your vault, and get your devices syncing properly again. :) Please let us know if you need anything else!

This discussion has been closed.