1Password Keyboard Issues

I'm trying to use the 1Password keyboard to autofill. Whenever I open the click the autofill button on the keyboard, I'm prompted to enter my PIN. After entering my pin, the screen flickers and it prompts me to enter my PIN again without any errors or other messages. I've tried entering my PIN multiple times and in different apps to the same effect.

Ever since the keyboard was introduced I had to go back to copy and pasting passwords, so any help would be greatly appreciated.

Comments

  • periperi

    Team Member

    Hi @Panopticon, I'm sorry to hear you're having trouble with in-app filling.

    Can you confirm that you're using the latest beta version (4.2b11)? Can you let us know what device you're using and what OS version it has?

    Also, I'd like you to go into your device accessibility settings and toggle the 1Password service off and back on. Are you still having the problem afterward?

  • Hi! Yes, I'm running 4.2b11. I'm running on an HTC One M8 with Android 5.0.1.

    I've already tried toggling the accessibility and keyboard settings to no avail.

  • periperi

    Team Member

    Thanks for the info, @Panopticon. Unfortunately, I'm still unable to reproduce this issue. I'd like to leave the thread open to find out if anyone else is experiencing the same issue.

    I forgot to ask is whether you're using stock Android or a custom ROM, and if you have developer options enabled. Also, I'd like to get a look under the hood. Could you to create a Diagnostics Report from your Android device?
    https://guides.agilebits.com/kb/1password4/en/topic/diagnostics-report#and4

    Then attach the entire file to an email to us: [email protected]

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    A short note here once you've sent the Report in will help us to keep an eye out for it. :) Thanks in advance!

  • Yes, I am using a custom ROM (SkyDragon v3.4.0). That should all be in the diagnostics report I just sent.

  • periperi

    Team Member

    Thanks for the Diagnostics Report. Custom ROMs usually alter the core behavior of the Android OS. Because of that, it is quite difficult for 1Password to remain consistent among devices with custom ROMs.

    Since we have not seen this issue crop up on Android's stock OS, I believe the custom ROM may be the reason for the problem. I'll pass this info regarding the SkyDragon custom ROM (along with your Diagnostics Report) to our developers. We would very much appreciate it if you would also report this issue to the Cataclysm ROM team as it's possible the issue is on the OS level. Thanks!

  • I also notice that my ROM is rather old. Maybe an update will help. If that doesn't work then I'll get in contact with their team.

  • periperi

    Team Member

    That sounds like a good idea. Please let us know if updating the ROM helps with the problem!

This discussion has been closed.