Chrome in Windows doesn't recognize website, but Mac Safari does?

Hi, I have a bit of an odd problem. I'm currently using 1Password across my iMac (using Safari) and my Windows laptop (running Chrome) and sync'ing via Dropbox. Most things work great, but I have an issue where there are some websites that work fine in Safari on my Mac, but not in Chrome on my Windows PC. For example, with Mint.com, when I click the 1Password button in Safari, it recognizes that I'm on Mint.com and I see the Mint.com login information pop up automatically, but when I go to the same website in Chrome, the login info does not come up and I have to search for it manually. I've entered the website info properly into 1Password. Any ideas on how to fix this? Thanks!

Comments

  • brentybrenty

    Team Member

    @maronis: Sorry for the trouble! I'm afraid I wasn't able to reproduce this though. Using the latest versions of Safari and Chrome on Windows 7 I was able to bring up the 1Password menu to log into Mint without searching for it.

    Could you tell me which version of Windows, 1Password, and the extensions (listed in 1Password File > Preferences > Browsers) you're using? Also check the URL you have saved for Mint. Please let me know what you find. We will get this sorted out for you! :)

  • Sure. I'm running Windows 7 SP 1, 1Password 4.3.0.556, Chrome 41.0.2272.101 and Extension 4.3.0.90.

    I have www.mint.com, mint.com, https://wwws.mint.com saved as URLs - I thought that being thorough with all the different permutations might help, but no luck.

    There are other websites where this is an issue, I just used Mint.com as an example. Thanks for your help!

  • brentybrenty

    Team Member

    @maronis: Thanks for that! I actually have the same setup here. If you're using any other browsers on Windows, are you having the same issue with those as well, or just Chrome? First, just open 1Password for Windows and go to Help > Restart 1Password Helper. It may just be a communication problem there, especially since you mentioned that mint.com is not the only site where you are seeing this issue.

    The 1Password extension should be giving you the same choices in both browsers when you click on the 1Password button, so it may be that the Chrome extension has become damaged. Please try removing the 1Password extension from Chrome, and then reinstall it.

    It sounds like you must be using Dropbox to sync your 1Password data between the two computers, so also check to make sure that is working properly, and that changes made to items on one computer are showing up on the other. I hope this helps! :)

  • edited March 2015

    @maronis Can you answer these questions, please?

    1. What exact URL are you on in Chrome?
    2. What URLs are associated with your mint.com Login item, and in what order?

    If you feel comfortable sharing your mint.com Login item with us, then I would appreciate it:

    1. Start 1Password
    2. Locate your mint.com Login item
    3. Click on: File > Export > 1PIF
    4. Click on: Selected Items
    5. Click on: OK
    6. Save your 1PIF to your Desktop
    7. IMPORTANT Open your 1PIF in notepad.exe and then blank out your password
    8. Please send your 1PIF to: stefan AT agilebits DOT com

    Thanks!

    P.S. Should you need a PGP public key, then here's mine (fingerprint: 4978 0088 FF9F 3627).

  • I just tried restarting 1Password Helper and reinstalled the extension - still have the problem. Dropbox sync is also working properly.

    Here's the exact URL that I use to log in to mint.com: https://www.mint.com/
    Here are the URLs I have associated with my mint.com account:
    accounts.intuit.com
    www.mint.com
    mint.com
    https://wwws.mint.com

    Intuit and Mint just combined their logins, which is why I the Intuit URL is there.

    I'll send you the 1PIF file separately with the password info blanked out. Thanks!

  • edited March 2015

    @maronis Please turn ON this setting: File > Preferences (Ctrl+P) > Logins > Lenient URL matching

    It is a long story but it comes down to this: multiple URLs need this setting turned on (otherwise, the 1Password extension in your web browsers "sees" the 1st URL only).

  • That worked - thank you!

  • LauraRLauraR

    Team Member

    @maronis - Thanks for letting us know that the Lenient URL matching setting helped.

This discussion has been closed.