Search does not work on IP

If the domain is using an IP address instead of the domain name, the search does not work

screenshot: http://habrastorage.org/files/b35/7aa/f2e/b357aaf2e7934641a079c271b80b1eaa.png

Comments

  • Works fine for me, searching for both "1C" and "217".

    What versions are you running? Windows, Browser, 1Password and 1Password Browser Extension.

  • Yes, sometimes works and sometimes not - from renovation to upgrade :)

    release:
    OS: Windows 10 TP
    Firefox: 36.0.4
    1Password: 4.3.0.556
    1Password for Firefox: 4.4.0.b1

  • Although I doubt it is the cause of the issue here, Windows 10 is not yet supported as it is basically an alpha release.
    Other than that the versions seem good.

    If it's an intermittent issue then its going to be tough to track down. @svondutch any thoughts?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    @Borz, this might be related to a Firefox bug we found here for our extension. It has to do with the specific Login fields, the extension doesn't see the actual login form and for some reason tells Helper not to show the Login. This is incorrect and we are trying to figure out why it is only happening in Firefox but not the rest of the browsers.

    Is it possible for you to grab the HTML source code of your website and email it to us or can you send me the full IP address in a private message here and I can grab the source code?

    The IP address isn't the reason for this, we've seen it on domain names as well. I also tested to make sure it works:

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Borz,

    Thanks for the PM, I got the source code and tested it live as well. I was able to pinpoint the issue, which is that Firefox is passing on a malformed URL to us. I've filed a bug report and our extension team will investigate it to see if they can work around it and/or file a bug report with Mozilla. It works fine in IE and Chrome.

    Since we're getting a malformed address, it won't match anything in your 1Password database, thus nothing is returned. You can work around this by using 1Password's Auto-Type to type it in for you or use IE if you can.

    Bug ID #: OPX-909

This discussion has been closed.