1Password gets stuck on Enter Master Password button [Resolved]

I am on Mac OS X (10.6.8) with 1Password Version 3.6.5 (build 31075). I had to reset my safari, which cleared Cache, Cookies and the rest. now when I try to access 1password from my safari icon I am stuck with the connecting button and nothing happens. SOS. See the attached screen shot. How do I get my 1Password to work in safari again.

Comments

  • @DaveVasudevan I have moved your post from the 1Password for Mac forum to the 1P3 forum where you will get more help.

    Stephen

  • Hi @DaveVasudevan,

    The first thing to try is to completely reboot your Mac and see if that makes any difference. I once fought with Google Chrome for ages to discover a reboot was needed between installing the extension and trying to get the damned thing to work. I'm confident this wasn't always the case and might be one of those quirks you start to see with older software interacting with newer ones. This is a nice safe thing to try as you can't do any harm in doing so.

    Now if that doesn't work...

    My hunch is you've done a pretty deep purge of Safari and I suspect you've wiped the extension's local database. I assume you still use the main 1Password 3 application, you don't just use the extension and you have no reason to believe the two haven't been in sync. If that assumption is correct here is what I would suggest.

    I would recommend uninstalling the 1Password 3 Safari extension, rebooting your machine and then installing the 1Password 3 extension once again. You can do this by using the 1Password > Install Browser Extensions drop down menu option. Hopefully a fresh copy of the extension will be able to connect to your existing copy of 1Password 3.

    If my assumption isn't correct then I think we'd be best off looking at a diagnostic report.

    I would like you to create the following Diagnostic Report.

    Then attach everything to an email to us: support+ [email protected]

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once you've sent the Report a post here with the ticket ID will help us to keep an eye out for it. :)

    Once we see the report we should be able to better assist you. Thanks in advance!

  • Hello, finally, I found a workaround and have my issue solved. Reason for the issue: I emptied my safari browser cache, and Reset Safari, did not realize this removed some important components of 1Password.
    Solution: I uninstalled the Safari Extension of 1Password, and launched my 1Password and installed the extension from here, Now everything is working fine.

  • MeganMegan 1Password Alumni

    Hi @DaveVasudevan ,

    I'm so glad to hear you're all sorted out, thanks for letting us know!

    Since this particular issue is resolved, I'll close this thread, but if you have any further questions or concerns, please don't hesitate to open a new thread, or email us directly at [email protected] - we're here for you. :)

This discussion has been closed.