Localized string not found

When I try clicking the button for 1password in Safari, nothing happens. I tried redownloading the extension and it does not work. After clicking on File>>Preferences>>Extensions I see that it says "localized string not found". Can you please assist? I'm using Safari 7.1.5 and Mac OSX 10.9.5

Comments

  • What version of 1P are you using and what is your OS X language and region (System Preferences > Language & Region)?

    Stephen

  • 3.8.19 for iP - and English

  • English - US

  • @erindunn because you say you're using 1P3 I've moved your post to the 1P3 forum, where you'll get more help.

    Stephen

  • Hi @erindunn,

    I think the first tactic we should try would be to uninstall the 1Password 3 Safari Extension completely, reboot your Mac and then try installing it again from a hopefully clean state.

    Now that might not work but it's worth trying. Please do let us know how you get along and if you experience no joy we'll think of something else :smile:

    What I can say is there is no reason it shouldn't work. I have the old 1Password 3 extension installed in Safari right now on my Yosemite machine and with this sort of thing you'd expect more issues with the newer versions of Safari, not the older ones. Keep us informed!

  • Thank you for your reply. This issue started after I did a system update, which might have included an update to Safari.

    1. How do I uninstall 1 password for Safari? Just remove the button from my browser?
    2. If I do that, won't I have to start from the very beginning again, which would mean I lose my existing passwords. I would prefer at all costs not to do that!!!!
  • MeganMegan 1Password Alumni

    Hi @erindunn,

    Here are the steps to re-install the Safari extension:

    • Open Safari and select the Preferences.
    • In the 'Extensions' tab, find the 1Password extension, and click the 'uninstall' button.
    • Quit Safari.
    • Restart your Mac.
    • Open Safari and go to our extension download page.
    • Install a fresh copy of the extension by pushing the big green button.

    Does this help?

  • This is the problem - in the Extension tab, I do not see an uninstall button. The only thing that appears are messages saying "localized string not found" This appears across the top of the page as well as other places. There's nothing I can click or do on this page.

    If I were to uninstall the extension, will I have to start from the very beginning with 1password and lose all of my saved passwords? I really don't want to do that.

  • Would really appreciate your help - I'm in agony without access to my passwords!!! :)

  • Hi @erindunn,

    The 1Password 3 extension is a more complicated affair than what followed it in 1Password 4. Still, the extension routinely tries to sync with the 1Password 3 application so anything that was available in the extension should be in visible in your vault when viewed in 1Password 3. In your first post you mentioned having already re-downloaded the extension so I'm working on the belief that the extension is already in a clean state.

    If you're at all concerned though we can look into this further but we will need a diagnostic report to do so. If this is something you'd like for peace of mind then can you create the following Diagnostic Report please.

    Then attach everything to an email to us: support+ [email protected]

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once you've sent the Report a post here with the ticket ID will help us to keep an eye out for it. :)

    If everything is in 1Password 3 and you're happy to continue then it's back to removing the broken extension.

    The first thing we can try is to remove the actual extension file - see if that helps.

    1. Quit Safari if it is running.
    2. Open a Finder window and use the keyboard shortcut ⇧⌘G to open a Go to the folder window.
    3. Use the following location ~/Library/Safari/Extensions/ and click the Go button.
    4. Remove any files in that folder that start with 1Password

    When you launch Safari and look in the Extensions tab has the 1Password extension been removed? If it has throw in a reboot of your Mac for good measure and see what happens if you try to install the extension again.

    Now if doesn't work we'll have to use the sledgehammer approach. This will remove all of your extensions but due to the Keychain entry I'm not aware of a more selective approach.

    Wiping Safari's extensions

    To start make sure Safari is not opened.

    Preference plist

    Open a Finder window and use the keyboard shortcut ⇧⌘G to open a Go to the folder window. Use the following location

    ~/Library/Preferences/com.apple.Safari.Extensions.plist and click the Go button.

    Drag the highlighted file to your Trash.

    Extension files

    Like above, open a Finder window and use the keyboard shortcut ⇧⌘G to open a Go to the folder window. Use the following location

    ~/Library/Safari/Extensions/ and click the Go button.

    Drag the highlighted folder to your Trash.

    Safari Extensions List

    Launch Keychain Access which you can find in /Applications/Utilities/. Search on the word safari and you should have 3 entries in the results. You want to right click on Safari Extensions List and select the Delete "Safari Extensions List" option.

    After those two, reboot your Mac and you'll need to go through the steps of installing your extensions again. With a little luck whatever got messed up was in there and the 1Password extension will now properly load

    Let us know how you get along.

This discussion has been closed.