Chrome Extension won't launch [Caused by anti-malware solutions]

1Password v 4.3.1.90
Chrome v 42.0.2311.90
Windows 8.1 Pro 64-bit

When I check for updates from the 1Password program and Error message comes up.
_**"https://app-updates.agilebits.com/check/1/6.2.9200/OPW...
is currently unavailable.

The web site might be experiencing technical difficulties, or you may need to adjust your internet
connection settings."
**_
(Also, I'm an idiot and may not even be asking in the right forum).

Comments

  • LauraRLauraR

    Team Member
    edited April 2015

    @gogunners can you download the latest version from here -

    https://agilebits.com/downloads

    Please let me know if this helps. Thanks!

  • Yes, I was able to get the newest version of the program. The Chrome extension still doesn't open, but got the "code signature" warning. IT will check my security software. Do you know which port number they need to open?

  • LauraRLauraR

    Team Member

    @gogunners - This guide provides specific steps for configuring programs that have been seen to block 1Password’s secure WebSocket connections. Please let us know if this helps.

  • edited April 2015

    @LauraR This doesn't sound like something is blocking the WebSocket connection. Sounds like something is blocking code signature verification.

    @gogunners Please turn OFF this setting: Help > Advanced > Verify web browser code signature

    Thanks!

  • @svondutch I did that workaround and am operational, but I was hoping there was a better solution. Thank you both so much for your help!

  • AlexHoffmannAlexHoffmann

    Team Member

    Which anti-malware solution are you using?

  • Sophos and Malware Bytes

  • brentybrenty

    Team Member
    edited April 2015

    @gogunners: Thanks for getting back to us! Indeed, Sophos in particular is known to cause some of these issues. I don't believe that Malware Bytes actively blocks Windows API calls or local websocket communications.

    You can find more detailed information in our knowledgebase, but here are the parts that pertain to your particular situation:

    Some antivirus and similar security products prevent any process (in this case, the helper) from opening another process by blocking Win32 API calls to the OpenProcess procedure (documented here). When the helper cannot open the other process (in this case, your web browser), then it cannot verify that process’ code signature, so, as an intentional security measure, the helper is designed to disable the 1Password icon in the browser’s tool bar. The same thing would happen if a rogue process tried to connect to the helper.

    After all, we don't want 1Password interacting with malware masquerading as a your browser, so we do the verification check by default, as a legitimate, unmodified web browser will have a valid code signature.

    It can certainly be frustrating when security software prevents other apps you've explicitly installed to use from functioning! :dizzy:

  • ;) Thanks for the explanation. This has been a great learning experience for me!

  • AlexHoffmannAlexHoffmann

    Team Member

    Did it fix the problem, too? :chuffed:

This discussion has been closed.