1Password Unlock in Secure Desktop Unstable

I noticed the "Unlock on Secure Desktop" button, and thought it will work as that it will identify my windows PC as secure desktop and I don't need to unlock 1Password so frequently. And in the Preference, Browsers tab, I tick the "Unlock on Secure Desktop" tick box. Next time I try to unlock 1Password, the unlock screen goes to full screen. But then the problem comes - I cannot unlock. The full screen disappears when I'm still entering password. I haven't fully entered my master password and it quit. Then I cannot open my 1Password at all. I click on the 1Password icon and the menu won't appear. Also my Firefox browser 1Password icon won't react when I click. I have to go to Windows Task Manager to kill 1Password processes, then restart. It will bring me to full screen again, and it enters a vicious loop. Until one time, I enter my master password very fast and the full screen didn't quit yet, then I unlock my 1Password. And I untick the "Unlock on Secure Desktop" tick box in Preference, then I don't have this problem any more.

Attached is my diagnosis report. This definitely looks like to be a stability bug to me. It just didn't work well. Hope it can be fixed soon(though I might not use this function any more, didn't find what's the point of using it yet).

I have sent the diagnosis report to AgileBits support. But thought posting on the forum will help ppl who might meet similar situation as me.

Cheers!

Comments

  • brentybrenty

    Team Member
    edited April 2015

    @huangqiyx: Sorry for the confusion. "Secure Desktop" is a Windows security feature.

    When you choose Secure Desktop, you can always press Escape or click Cancel to back out of it and unlock normally. The Secure Desktop feature has the benefit of blocking all other processes but 1Password, to ensure that no keylogger or malware can try to capture your Master Password as you unlock. But if Windows is failing to provide Secure Desktop reliably on your system it may be best not to use it until you can pinpoint the problem. Please note that in Preferences > Browsers you can also disable Always Unlock on Secure Desktop to prevent the 1Password browser extension from using the Windows Secure Desktop as well.

    It is best not to post diagnostic information on the forums, but I see that we have received your email. Thanks for sending the diagnostics report. Our support team will take a look at it and get back to you shortly, so we will continue the conversation there! :)

    ref: VGA-36343-334

This discussion has been closed.