Mini position / Keyboard shortcut doesn't always work

Drew_AGDrew_AG 1Password Alumni 1Password Alumni
This discussion was created from comments split from: 1Password 5 extension usability.

Comments

  • thibautthibaut
    edited April 2015

    Hi. I have a two new issues with 1P Mini:

    1. It looks like 1P Mini is randomly positioned in the middle of the screen or in the top-right corner of the screen below the toolbar (1P Mini icon is not enabled). I don't know what makes the position change.
    2. My fill-in shortcut doesn't always work at first. I often have to repeat it a few times before Mini shows up.
  • Drew_AGDrew_AG 1Password Alumni 1Password Alumni

    Hi @thibaut,

    I hope you don't mind, but since these are new issues that are separate from those in the previous discussion, I moved your message to this new thread.

    In regards to both issues you mentioned: Normally there are two 1Password mini icons - one in the menu bar of the Mac (which you said you turned off), and one in the toolbar of the browser (i.e. the browser extension). Do you open 1Password mini by clicking on the browser extension icon, or do you use a keyboard shortcut? If you use a keyboard shortcut, do you use ⌘\ or ⌥⌘\ ? Also, are you trying to use 1Password mini while using a web browser, or another app on your Mac?

    Please also check the 1Password mini settings:

    • Open the main 1Password app and go to the menu for 1Password > Preferences.
    • Select the General tab.
    • Make sure the option for Always keep 1Password Mini running is enabled.
    • If you don't want to see the 1Password mini icon in your Mac's menu bar, the option for Show mini app icon in the menu bar should be disabled.

    Was the option for Always keep 1Password Mini running enabled or disabled?

  • Hi,

    No problem!

    The option to always have Mini running is enabled. I do not have the icon in the toolbar and I don't use the icon in the browser. I only use keyboard shortcuts, and it happens when using other apps than the web browser.

    I hope it helps!

  • PlatoPlato

    @Drew_AG

    FWIW, I've had essentially the same issue ever since I started using 1P some six months back. First, I've always had Always keep 1Password Mini running enabled. I use CMD-backslash to call up my logins and, occasionally, CMD-backslash does absolutely nothing. The occurrences appear to be completely random. With computers, nothing is truly random but I'm unable to determine any pattern whatever. It can happen when I'm expecting the "enter master password" screen and it can happen when I'm expecting web site login info. It is not restricted to specific web sites.

    These occurrences take place maybe once every hundred times that I attempt to use 1P. Almost every time, I can quickly fix the problem by clicking on the desktop and then clicking back on the Safari window. On occasion, I have to repeat those steps perhaps two or three times. Very rarely, it's necessary to quit and reopen Safari and that always fixes the problem.

    I haven't complained about it because the issue does not occur often and, when it does, the resolution is easy.

  • Drew_AGDrew_AG 1Password Alumni 1Password Alumni

    @Plato, one possible explanation for that could be that the page hasn't finished loading yet (1Password doesn't fill until the page is done loading). Sometimes it appears to be fully loaded, but something else might be loading in the background, like Google Analytics (the status bar should indicate when something like that is happening), and that can prevent the extension from appearing. Is it possible that might explain the problem you've noticed? If switching to another app and then then back to Safari seems to help, that could be a coincidence - maybe the page finishes loading while you're doing that? It's hard to tell for sure of course, but might be something to look for if/when you run into this again.

    @thibaut, if the problem is happening for you when trying to open 1Password mini from other, non-browser apps (using the ⌥⌘\ keyboard shortcut), that could be a different issue from the one Plato described. Does this happen only in non-browser apps, or have you also had this problem trying to fill Login info on websites?

    Out of curiosity, if you enable the option to Show mini app icon in the menu bar, does that seem to make any difference when using the ⌥⌘\ keyboard shortcut? Also, when that icon is set to be shown, do you have any problems clicking on it? (I'm trying to determine if this problem is specifically related to the keyboard shortcut, or opening mini in general.)

    You can try this to see if it helps: Open the main 1Password app and go to the menu for Help > Troubleshooting > Restart 1Password mini. Depending on how often the problem happens, it might be hard to tell if this helps or not, but please let us know if you notice a difference. You can also try restarting your Mac, if you haven't already done that.

    As far as the position of 1Password mini on the screen, I did some digging and found that we have an open bug report for that, so it's a known issue our developers are working on. I'll let them know you're also seeing that happen.

    ref: OPM-2562

  • PlatoPlato

    @Drew_AG

    Your theory may well be correct. If I remember, the next time that it happens, I'll go get a coffee and see if that resolves the issue. Don't lose sight of the fact that it happens very seldom and I'm not particularly concerned.

  • thibautthibaut
    edited April 2015

    Hi there,

    AFAIKT, it happens in the browsers (both Safari and Chrome) and also in non-brower apps. I didn't find a way to replicate the issue consistently, though.

    Ha, the problem is happening right now, and I captured it! http://shrrr.it/fqtn0prrn6_video.mp4 :smile:
    I enabled then disabled the toolbar icon but it doesn't make any difference. 1P Mini sticks to the position where the 1P icon should be in the toolbar. If I switch between apps, it doesn't change.

  • Drew_AGDrew_AG 1Password Alumni 1Password Alumni

    Thanks @Plato, I'm glad this isn't a big problem for you! If it starts to become more of a concern, please do let us know.


    @thibaut, just to clarify, your video is related to the first problem you mentioned, about mini sometimes appearing in the middle of the screen and sometimes appearing in the top right corner, correct? If so, I think I'm a bit confused about the video, because it looks like mini is always appearing in exactly the same place. I think that's different than the problem you originally described, or perhaps I misunderstood. Can you please elaborate on that? Thanks!

  • It's a matter of luck (or not) because I doesn't always behave like that. And as soon as I restart my Mac, 1P Mini is back in the center of the screen. But it will occasionally go back to the top-right corner, even if the icon is not shown.

  • Drew_AGDrew_AG 1Password Alumni 1Password Alumni

    Thanks @thibaut, I see what you mean. That's definitely part of the bug I mentioned earlier. Hopefully we'll be able to squash that soon, although I don't have a timeframe for that. I'm sorry for the inconvenience!

    ref: OPM-2562

  • thibautthibaut
    edited May 2015

    I don't know if it can help but here are the Console messages I have about 1Password since I started my Mac (and 1P Mini is appearing in the top right corner at this time).

    6/05/15 07:48:47,305 2BUA8C4S2C.com.agilebits.onepassword-osx-helper[284]: 530029 [HELPER:0x7fe341708e80:<OPHelperAppDelegate: 0x7fe341500700>] M applicationWillFinishLaunching: | Starting 1Password mini 5.3 #530029 built Mar 27 2015 20:48:09
    6/05/15 07:48:47,325 2BUA8C4S2C.com.agilebits.onepassword-osx-helper[284]: 530029 [HELPER:0x7fe341708e80:<OPHelperAppDelegate: 0x7fe341500700>] M applicationDidFinishLaunching: | Starting 1Password mini 5.3 #530029 built Mar 27 2015 20:48:09
    6/05/15 07:52:19,136 1Password[416]: 530029 [APP:0x60000007ee80:<OPAppDelegate: 0x6080001ad900>] M applicationDidFinishLaunching: | Starting 1Password (AppStore) 5.3 #530029 built Mar 27 2015 20:48:57
    6/05/15 07:52:20,233 1Password[416]: Unable to load string table file: CFBundle 0x7fbfd3c004c0 </Applications/1Password.app> (executable, loaded) / MainWindow: Impossible de lire les données car le format n’est pas correct.
    

    The last sentence in French means something like "unable to read the data because the format is not correct".

  • Drew_AGDrew_AG 1Password Alumni 1Password Alumni

    Thanks @thibaut! I'll forward that to our developers in case it helps them. We appreciate it! :)

    ref: OPM-2562

  • thibautthibaut

    Hi,

    Just checking, any news about the 1P Mini position issue? :smile:

  • Drew_AGDrew_AG 1Password Alumni 1Password Alumni

    Thanks for checking in about this @thibaut! I'm afraid I don't have any news about this issue, but our developers haven't forgotten about it. I'll let them know you asked.

    Sorry, I wish I had something new to share with you about that! It's definitely something they've been looking into, though.

This discussion has been closed.