Report issue with website option missing.

kurtdkurtd Junior Member

As mention on the blog and in this screen shot, there's a new option to report a form filling issue with specific websites. I have the latest 1password and plugin for windows and firefox installed but the option is not there.

Here's my screenshot.

1pw.jpg 47.6K

Comments

  • brentybrenty

    Team Member
    edited May 2015

    @kurtd: Sorry for the confusion. The 'Report issue with ...' option is content-sensitive and will only be available at a login page.

    If you're having trouble with it not showing up at a particular URL, however, it may be helpful if you could share it so we can test it ourselves and see what's going on. Also include the OS, 1Password, extension, and browser versions you're using so we can test with a similar setup. I hope this helps! :)

  • kurtdkurtd Junior Member

    I checked a bunch of login pages and none have the option to report an issue.

    Windows 8.1
    1PW 4.5.0.572
    FireFox 38.0.1
    Extension 4.3.1

  • Hi @kurtd,

    The menu option is only visible after you've attempted to fill a Login, Credit Card or Identity item. Could that be a possible reason why you're not seeing it? It seems to be different in Windows compared to Mac. On the Mac the menu option is always visible but if I try to report a Login page without filling first I'm greeted with the following message.

    Oops, something went wrong.

    Please make sure that you:

    • attempt to fill an item first and then report the issue second.
    • use the Report Website Issue option in the 1Password extension or in 1Password mini.
    • update to the most recent version of 1Password for Mac or 1Password for Windows Beta.

    On Windows we seem to take it a little further and simply don't present it as an option until you've filled first. The reason for this is we need to understand what filling did so when you tell us what it didn't do we can understand :smile:

    Does that help at all?

  • kurtdkurtd Junior Member
    edited May 2015

    Still doesn't work. Tested 4 sites including this forum. Report option is not there before or after filling. The only mac I had was from McDonald's and even that one I didn't like. I'll stick with quarter pounders.

  • I'm confused. I visit our forums in Firefox (same version) and I click on the 1Password browser extension icon and in the Settings menu I see this.

    Our versions of Firefox, 1Password for Windows and the extension are all the same, the only difference is I'm running Windows 7.

    I would try uninstalling the 1Password Firefox extension, rebooting (it's never a bad step to throw in there) and then download a fresh copy of the extension.

    If that doesn't work can you double check that you're running version 4.5.0.572 of 1Password for Windows and that you don't have another copy on your system at all. Your menu is different so I can only assume something isn't the most current version.

    Hopefully we find the cause :smile:

  • kurtdkurtd Junior Member

    I tested it on a Windows 7 PC and it wasn't working there either. Double checked and yes I'm on 4.5.0.572. Did you check your extension version? Mine is 4.3.1. I attempted to reinstall the plugin but it won't install.

  • kurtdkurtd Junior Member

    I think avast was blocking the extension install. Finally got it reinstalled and it still doesn't work.

  • brentybrenty

    Team Member
    edited May 2015

    @kurtd: Aha! That makes sense. I know others have reported similar issues. I wonder if that isn't the end of it though. If you disable Avast temporarily, does the extension behave as expected?

    Be sure to try restarting the Helper as I suggested above, and if you're still not seeing any change restart the computer completely. Since the Helper manages this, it's possible that Windows needed to be restarted after the installation to update it and you simply delayed it and forgot (as I tend to do!)

    The only mac I had was from McDonald's and even that one I didn't like.

    For a minute I didn't get the joke and almost asked you how I can get a free computer with my Happy Meal. Well done. :lol:

    Incidentally, I'm having the same issue under Windows 7 and 8.1, but not Windows 10. We're trying to track this down. Please let me know what you find.

    /cc @svondutch

  • I think I've discovered it @kurtd and no wonder it had us all confused.

    If you were somebody that upgraded from the last beta to 1Password for Windows 4.5.0.572 you have the Report issue with website menu option. If you upgraded from the last stable version to this new one then you don't have the menu option and this seems to be reproducible for me so far. I'm not saying you have to (obviously we need to get this fixed), but I believe if you were to follow these steps you would be reporting that you now have the Report issue with website menu option.

    1. Completely uninstall the 1Password for Windows application. You don't have to uninstall the browse extension.
    2. Install 1Password for Windows 4.3.2.BETA-571. It will expire in a day or two as it's a beta but it will work for now.
    3. Let it update to 4.5.0.572
    4. Reboot if required.
    5. Make sure Auto-Submit Logins is temporarily disabled in 1Password (Logins tab of preferences) for testing purposes.
    6. Attempt to fill in at our forums login page.
    7. Check for the existence of the Report issue with website menu option.

    I believe if you follow these steps you will have the menu option. To me it suggests something is missing from 4.5.0.572 but the beta version of the file remains. A clean install of 4.5.0.572 never has this so it doesn't have the option. Now I could be off-track completely but if I cleanly install the stable version from our site the menu option is missing while each time I install the beta and then update to the stable it has the menu option. It would also explain why I couldn't understand why I had the option and you couldn't understand why I did.

    I'll be honest with you, there was a lot of installing/uninstalling and rebooting to figure that one out.

  • kurtdkurtd Junior Member
    edited May 2015

    It sounds like you've sorted out the problem so unless you want me to test it, I'll probably wait until the next version is out rather than go through the uninstall > install beta > upgrade option. I've seen this happen before with other software where an upgrade works fine but fresh install doesn't so I think you might be right in saying that some files are probably missing from the installer. Thanks

  • brentybrenty

    Team Member

    @kurtd: Indeed! lil bobby did some great sleuthing and discovered that the option is only showing up if you'd had the beta installed previously.

    In the mean time, you can get this to work by installing the previous beta (4.3.571) and then updating to the latest stable version. We've reported the issue to the development team so we can get this fixed in an update. Thanks again for bringing this to our attention! :)

    ref: OPW-435

  • kurtdkurtd Junior Member

    It looks like the issue is resolved with 4.5.0.573 and I just reported my first issue with a login page. Just and FYI, I did notice that it'll submit the response page instead of the login page for users that have the auto submit logins option selected.

  • brentybrenty

    Team Member
    edited May 2015

    @kurtd: Indeed! I was actually just looking for this thread to update you, and was fortunate enough to get a notification for your reply to help me. ;)

    I did notice that it'll submit the response page instead of the login page for users that have the auto submit logins option selected.

    Correct. It will submit whichever URL is loaded at the time. I'm not sure if there's a way to infer the originating page (the one with the actual login form), but we will certainly look into it. Cheers! :)

    ref: OPX-999

This discussion has been closed.