Wifi Sync Confirm Password dialog exposes Master Password

drwhodrwho
edited June 2015 in Android Beta

1Password (mobile): Version: 4.5b1 (20150602)
1Password (Windows): Version: 4.5.0.575
Device: Samsung Galaxy Note 3
OS: 4.4.2

As the title says, when syncing with the desktop app, 1Password asks to confirm Master Password for which the keyboard is not masked to hide the text. In fact, the password is then added to the auto-fill db of the keyboard (very bad).

Not sure if the next item should be broken out in a separate report:
After updating to latest version, I cleared the 1Password data to initialise it so I could sync it using wifi. After the sync was complete, all of the entries were missing the name of the entry and now all of the entries are showing the URL not the name.


1Password Version: 4.5.0.575
Extension Version: 4.5b1
OS Version: Windows 7 Pro
Sync Type: Wifi

Comments

  • J.MJ.M
    edited June 2015

    Confirmed here, I've got all my entries sorted as '#' because they have no title. In the case of Software licenses, license keys were visible instead of the software names.

    I also noticed the problem about the master password confirmation not masking characters.

    Before trying the Wi-Fi sync, i cleared all the app data.

    1Password Version: 4.5.0.575
    Extension Version: 4.3.1
    OS Version: Windows 8.1 Pro with latest updates /Android 4.4.4 (CyanogenMod 11)
    Sync Type: Wi-Fi

    EDIT : interresting thing. Editing an entry on Windows while not changing anything, clicking on OK and re-syncing via Wi-Fi propagates the entry title correctly.

  • I ended up reverting back to folder sync and deleting my personalized data for the keyboard input. I hope the keyboard issue is resolved with priority. Getting wifi sync is a big relief. I'd like to get back to it soon!

  • periperi

    Team Member

    Hey there! Thanks for reporting these errors! We were able to replicate both issues on our end, and have filed bug reports regarding both.

    We are definitely prioritizing the master password issue due to the fact that it concerns security. We hope to be able to have both of these issues resolved soon.

    @drwho, I recommend opening your device's applications settings and clearing the app data for your keyboard. While this will unfortunately delete all of your keyboard's memory based on what you've typed, it will delete the master password from its memory as well. Sorry for the inconvenience!

    Let us know if you have any other feedback regarding WiFi sync! :)

  • periperi

    Team Member

    Hey @drwho and @J.M. We've just released 4.5b2 which has fixes for these issues.

    Please go ahead and update, and let us know if you notice any persisting problems. Thanks!

  • That was fast!

    Thanks will check it out.

  • periperi

    Team Member

    Great! Let us know how it goes! :)

  • Installed and tested on my side, looks like everything is okay, master password was obscured this time and items synced with their names.

    Thanks for the quick update :) .

  • periperi

    Team Member

    Thanks for testing and confirming the fix! I'm so glad to hear that it's working properly for you now. :)

  • I can also confirm that both issues are resolved.

    Thanks!

  • saadsaad

    Team Member

    Thank you for the confirmation @drwho. Glad to hear this is now resolved. :)

  • Version 4.5b3 has re-introduced the bug for the Master Password dialog. However, this time it masks the entry but it exposes the values to predictive text/dictionary.

  • saadsaad

    Team Member

    Thanks for the update, @drwho. We are looking into this now!

This discussion has been closed.