URGENT help needed - Safari extension quitting - can't re-install - App can't find iCloud file + iOS

On Friday I started getting regular (i.e. EVERY 10 seconds) warnings that 1P extension had an error. I can't remember the error - I had to disable the extension.
Today I needed a password so went to log into my iPhone 1P - but it didn't have the login I needed? Like it wasn't synced. So I tried to log in into 1P on OSX but I got a 'welcome' screen with 'create a new file' or find an existing file'. When I try to find the existing - it doesn't seem to be in iCloud drive.
I enable 1P in Safari to try to get the details - I can see the login I need but the error comes up too quickly to access the password. I read that to fix the error I need to uninstall and re-install 1P extension.

I do that BUT I get another error - there is no app associated with the link that AgileBits gives on the extension website. I get another error - but when I go back to the extension site I see 'installed' in the 1P extension. Sure enough there is a key in the toolbar - great...except when I press it nothing happens!

It seems this is a conglomeration of a number of errors - from iCloud drive to the extension. Put simply I have purchase 1P for iOS and OS X and have the extension - but I can not get my information. I had the file in iCloud, but it's like it has suddenly disappeared.

It would be appreciated if anyone could help - but as we use 1P for business use I am needing some confirmation that this software is safe and major issues like this are not regular?

1Password Version: 3.8.22
Extension Version: Not sure which - then Latest
OS Version: 10.10.3
Sync Type: iCloud


  • Hi @what_is_ploth,

    This question is important, do you use Time Machine or another backup system that maintains incremental backups?

    Here is why I ask. You're running one of our older versions of 1Password. In 1Password 3 there was the main application and you created your vault in there which would live either in local storage or in Dropbox - 1Password 3 did not support iCloud as iCloud didn't exist (if memory serves me correctly). Now with the 1Password 3 Browser extension it would first link to the 1Password 3 application and maintain it's own encrypted database which it would attempt to keep synchronised with your true vault, the 1Password.agilekeychain. Now it was possible for the communication between the extension and main application to break down. When this happened, if tended to rely on just the extension then new or modified items only existed in this browser database. Removal of the extension would delete the browser database and all the modifications or additions would be lost. It sounds like your error message was the extension complaining that it could not communicate with the helper, especially if launching 1Password 3 has it behave as if it hasn't run before.

    My hope is we can revert to a backup of your Safari folder and resurrect your extension database. For this we require something like Time Machine or equivalent.

    As to the error in the screenshot you helpfully supplied, 1Password 4 was a complete overhaul of the code that existed in 1Password 3. We drastically changed how the extension worked so the 1Password 4/5 browser extension cannot communicate with 1Password 3. Even installing the correct version of the 1Password 3 browser extension won't help as we need the old database back.

    So let us know if Time Machine is an option. If it is we can revert to a time before you deleted the extension and then work on pulling the vault out of the extension. That we can cover once we know if it's an option.

    While I wasn't part of the team at the time, I'm confident that the fact that the extension could become disconnected is one of the reasons we changed how the extension now works. In 1Password 4/5 it merely acts as a conduit to the actual application meaning this sort of thing cannot happen. Once we hear back from you we'll have a better idea of how we can proceed.

  • Hi - thank you for your reply. It is competing to have someone who understands the issue & the way 1P works :)

    I have had Time Machine backing up before this error occurred - so it MAY be an option. I say 'may' because the 8TB Raid drive it is on (Western Digital) has started to only show on Yosemite with the WD helper utility running - since the last Yosemite update. SO it is very unreliable and I can't seem to figure whether it is Yosemite, the drive or my computer (my 30" Cinema display stopped working at the same time - but it won't work on any of the machines at the Apple store either - they are saying it is dead, I am still hoping it is OS X).

    Anyway - what folder am I looking for in ™? I would prefer to know as much as possible before I plug the ™ back up in just in case I only get one chance!

    Also how will I know that the folder in Safari is not corrupt - do I need to just keep trying older & older versions until one works?

    Thanks again!

  • Hi @what_is_ploth,

    Here is what I recommend what you do.

     Preparation before plugging in the backup drive

    1. Launch Safari and uninstall the 1Password Browser Extension.
    2. Visit https://agilebits.com/extensions/mac/index.html and install the 1Password Safari Extension from there.
    3. If you were to click on the Safari Extension icon and attempt to unlock your vault I would expect to see something like this where the counter just keeps ticking upwards.
    4. Quit Safari and open a Finder window.
    5. Use the keyboard shortcut ⇧⌘F to open a Go to Folder window.
    6. Paste the following path in and click the Go button. The path is ~/Library/Safari/Databases.
    7. In that folder you should see a folder titled safari-extension_com.agilebits.onepassword-safari-2bua8c4s2c_0 and inside there a file titled 0000000000000001.db. That is the important file. You want to pull a copy of this file from the newest backup but for a point in time prior to uninstalling the 1Password Safari Extension. The file size will likely be a good indicator as an non-existent or empty vault will be around the 50KB mark while my small test vest results in a file size of 524KB.
    8. With the file restored, launch Safari and try to unlock your vault. If the backup hasn't been corrupted and the right version of the file has been restored you should be able to once again access your vault (but for the moment only from Safari).

    It's just my opinion, but I'd like you to see if you can do this before we start the next stage. All of that will at least allow you access to your vault again but only from Safari so this is only the first stage. The next thing we need to do is extract that vault from the extension which, because you're using Safari, is possible (phew). Then we need to take this extracted version and get it back into 1Password. The steps above will at least allow access to your vault in a limited way though so I suggest we get that done first before worrying about the next steps.

    Hopefully that sounds like a plan to you as well :smile:

  • edited June 2015

    When I do your steps - I re-install from that link (even though it does not say it supports Yosemite) the extension seems to install. I put my password in and the counter starts going up - then i get the original error:

    This error comes up every 10 seconds and stops Safari from working at all. Should I keep going with your instructions regardless or does this indicate a problem outside what you have diagnosed?

    Thank you!

  • Hi @what_is_ploth,

    So the 1PasswordAgent error we should be able to address.

    Using the Finder trick I mentioned earlier, you want to visit ~/Library/LaunchAgents/. In there you should see a file titled ws.agile.1PasswordAgent.plist. If you move that file to your Trash and reboot your Mac you shouldn't receive that error message any more. The plist file is a config file that instructs OS X to keep 1PasswordAgent loaded and that if it terminates to restart it. We can worry about why it's quitting later if needed - this will simply stop it from being loaded at all.

    Now that screenshot that you've supplied raises a question. The 1Password visible in that screenshot is of 1Password 5 but in your first post you mentioned that you were running 1Password 3.8.22. Now everything I've been talking about so far is based on the belief that your passwords were all locked up in the 1Password 3 Safari Extension. A lot of this breaks down if that isn't the case. Can I just confirm I'm not sending you in the wrong direction? Is it that you installed 1Password 5 recently in an attempt to get everything working again?

    If this is the case then you should be free to continue the steps I covered above. The 1Password 3 Safari extension is probably causing the 1PasswordAgent error message because it's trying to communicate with it but the extension can survive without it which is how it was possible for the two to become disconnected. It should mean you can still proceed with the rest of the steps though.

    Just to let you know, I'm being notified of any post you make to this thread so you should receive responses as long as I'm sitting at my machine :smile:

  • I'm sorry - I tried to edit my post with that screenshot as I noticed it would be confusing after I saw it later though I was in a meeting and never hit 'save'.
    The 1P5 you can see is the background of a webpage NOT my actual desktop!

    I do not have 1P5 - I bought it as part of a bundle years ago and only started using it the same month the new version came out so didn't trust it enough to fork out to upgrade...

    Ok I am deleted the 1P plist then quitting safari, then restoring the db file that I have recovered form 4 weeks ago that is 600+kb). It's a shame as the log in I need I think happened within that time - but due to the Thunderbolt error I've had not consistent backups :(

    Again thank you for the help.

  • I have restored the DB file - restarted Safari - re-enabled 1Password - the same behaviour - the syncing starts and the numbers start rising - then the helper quits.

  • littlebobbytableslittlebobbytables

    Team Member
    edited June 2015

    Hi @what_is_ploth,

    Thank you for clarifying about 1Password 5, you did catch me with that one :tongue:

    It's a shame if the newest backup of the db file is from four weeks ago but at least that should recover a good number of items.

    Now let's see if we can get it back into action.

    **Let's start with a quick sanity check. **

    1. Reboot your Mac.
    2. Open Finder, and using ⇧⌘G go to ~/Library/LaunchAgents/.
    3. Make sure ws.agile.1PasswordAgent.plist doesn't exist any more.

    Regarding Safari

    It sounds like you disabled the 1Password 3 extension before replacing the .db file given you mentioned re-enabling 1Password, where I assume you mean the extension. Now I didn't test that but I've gone back and tried both leaving the extension enabled when replacing the file and disabling it first. It turns out the results are the same.

    What I'm going to do is I'm going to email you from our system as I'd like to send you a test .db file. If the test file works, we know you've got the process right and that it might hint that the backup file is somehow damaged. I'll email you in the next few minutes.

    ref: BQS-34118-332

This discussion has been closed.