1Password not working properly

All of a sudden the 1Password "key" icon on my toolbar, when clicked, shows nothing. There used to be a pop-up box for the site I was logging into that would allow me to fill a log-in if, for example, the site had multiple pages for login. I am running v6.1.6 of Safari, and v3.8.22 of 1Password. For most sites, I can enter using the 1Password application, and the login works very well. For those sites that don't automatically fill in, I now have to type the login and password manually to get into them. I've tried to download extensions for Safari and Chrome, and have been unsuccessful. In my Safari Preferences, in the Extension Tab it says "localized string not found", and no extensions appear there.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Hi @JoBatz26,

    Now the relationship between the 1Password 3 Browser Extension and the main 1Password 3 application can be a complicated one at times. So before we proceed can you confirm that, to the best of your knowledge, the vault visible in the main 1Password 3 application seems to be complete?

    That question is important because the 1Password Browser Extension could become disconnected from the main application and have add instances where we need to ensure that there isn't anything stuck only in the extension.

    It might also turn out to be important to know what version of OS X you're running. If you're running Safari 6.1.6 you're definitely not current and it's just in case we need to account for a different approach in some part of OS X or not.

    Once we have a better idea we'll maybe have to try purging parts of your Safari preferences and see if we can get it to behave again. We'll start once we know a little more about your system and you've confirmed your vault is safe and accessible from the main application.

  • I am definitely running v6.1.6 of Safari, and with this MacBook I won't be able to move to a higher version (too old, not enough memory or RAM).

    When you talk about the "vault" do you mean the main 1Password application that holds all of my logins? If so, yes, they appear to be complete. As I said, I can access most sites completely when I choose them from that location. It becomes problematic if the login doesn't completely fill in. I used to be able to drop down a box from the toolbar that had all of the login information. Now (and I mean since last week), No box drops down. There is no info there.

    I hope this clarifies...

  • Hi @JoBatz26,

    I was more meaning that knowing you are running Safari 6.1.6 I knew you weren't running the latest version of OS X but that I wasn't sure what version of OS X. Not that long ago I learned there was a version of OS X & Safari where Safari refused to load extensions as part of a security thing I believe. It was an old version so I hadn't realised.

    The following will attempt to reset Safari's extensions by starting from a clean slate. This works for Yosemite and Mavericks but it might be a little different as I don't know what version of OS X we're dealing with.

    Wiping Safari's extensions

    To start make sure Safari is not opened.

    Preference plist

    1. Open a Finder window and use the keyboard shortcut ⇧⌘G to open a Go to the folder window.
    2. Use the following location ~/Library/Preferences/com.apple.Safari.Extensions.plist and click the Go button.
    3. Drag the highlighted file to your Trash.

    Extension files

    1. Like above, open a Finder window and use the keyboard shortcut ⇧⌘G to open a Go to the folder window.
    2. Use the following location ~/Library/Safari/Extensions/ and click the Go button.
    3. Drag the highlighted folder to your Trash.

    Safari Extensions List

    I believe this bit might be in newer versions so if you struggle to complete step 3 don't worry, it might be it simply didn't exist at the time. I don't have access to anything older than Mavericks to easily verify this with.

    1. Launch Keychain Access which you can find in /Applications/Utilities/.
    2. Search on the word safari and you should have 3 entries in the results.
    3. You want to right click on Safari Extensions List and select the Delete "Safari Extensions List" option.

    After all of that reboot your Mac and you'll need to go through the steps of installing your extensions again. With a little luck whatever got messed up was in there and the 1Password extension will now properly load.

    If that isn't enough it might be also worth trying the following drop down menu option in 1Password. The option is located at Help > Troubleshooting > Restart Helper.

    Let us know how you get along.

  • I'm sorry, got confused there for a minute. I'm running OS X v. 10.7.5 and really can't update my operating system anymore due to space and RAM constraints. Trying not to buy a new Mac quite yet. Does this change any of the advice you gave above?

  • I tried following your instructions, and found that when I searched for safari extensions as you outlined, I found no files labelled "extensions" when I went through any of the procedures you gave. So I would assume that there are just no extensions on my computer at all?

  • Hi @JoBatz26,

    So just to confirm, there was no Extensions folder or extensions plist file?

    It seems they're only created once you add an extension. If I delete those files on my test machine I can launch Safari, view the Extensions tab and quit Safari all without the files being created. If I do view the Extensions tab though this is what I see, a nice normal, blank list.

    If I then install an extension the files and folders are created.

    So if those files don't exist can you confirm what you see if you try to view your Extensions tab in Safari's preferences and what happens if you try to install the 1Password 3 Safari Extension from https://agilebits.com/extensions/mac/index.html

    Hopefully this will either work or bring us at least one step closer to understanding what is happening.

  • Thank you! The program appears to be working correctly now. I can see my "vault" from the toolbar, as I have in the past. I appreciate your help in getting this resolved.

  • brentybrenty

    Team Member

    That's great! On behalf of lil bobby, you are most welcome. It sounds like you should be all set, but be sure to let us know if you need anything else. We are always here to help! :)

This discussion has been closed.