Login Failure - MBNA

The MBNA (Bank of America) credit card log-on process has recently changed. Previously there were 2 log-on screens; the first for username and the second for the Sitekey image and password. The Sitekey has been removed and the username and password are now entered on a single screen. Very straightforward. I have saved a new login but when I try to use it it's rejected with "This servlet does not support the GET method". Is there any way to get round this?


1Password Version: 5.3
Extension Version: 4.3.1
OS Version: 10.10.3
Sync Type: Dropbox

Comments

  • dancodanco Senior Member Community Moderator

    I'm not techy enough to know what's going on, but as a point of reference I can say that my old login still works.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @Oxon,

    It's possible your old Login item for that site may still work, but I'm surprised that your new Login item doesn't. When you saved the new Login, did you follow the steps in this knowledgebase article?

    If you're still having trouble, can you please let us know the exact URL you use to sign into that site? We can try testing that here to see if we're able to reproduce the problem. Thanks!

  • The new login works fine if I manually navigate to the new login page, select 1Password from the right-click context menu and then select the MBNA login from the next menu. When it doesn't work and I get the above error message is when I double click the MBNA record in the main 1password window.

    The URL is:

    https://www.bankcardservices.co.uk/NASApp/NetAccessXX/LoginProcess

  • brentybrenty

    Team Member

    @Oxon: The URL you provided brings me to a blank page in all browsers. However, by navigating directly to https://www.bankcardservices.co.uk I was redirected to this URL:

    https://www.bankcardservices.co.uk/NASApp/NetAccessXX/WelcomeScreen?country=uk&language=en&org=1

    And this seemed to work just fine. Go ahead and go to the main site https://www.bankcardservices.co.uk and manually save a new Login item there instead.

    Upon trying to submit a second time, however, I get the error you describe above. Have you tried disabling Autosubmit? And you can also press ⌘ \ to fill and submit the form, which may help if the site's Javascript is causing a delay which conflicts with 1Password logging you in immediately.

    Without having a valid login, it's difficult to test this thoroughly, so be sure to report this using our Synapse website issue tracker. I could not tell any difference between the stable and beta versions of the extension in my own testing, but it may be worth your while to try the beta option as well.

    Please let me know what you find. I look forward to hearing back from you! :)

  • brenty:

    I deleted the URL in the website field in the 1Password record and replaced it with the URL in your post . I double clicked It and the login screen was auto-filled and I was successfully logged on! I'm not sure what the problem was, but all is fine now.

    Many Thanks

    Ken

  • Glad to hear you found a resolution @Oxon :smile:

  • brentybrenty

    Team Member

    @Oxon: Indeed! It was strange to me as well that that page was coming up blank, but I'm glad that did the trick for you. Cheers! :)

This discussion has been closed.