1Password won't properly fill the login screen at boschprovantage.com

The login screen at boschprovantage.com requires two separate fields for the login name plus the password. 1Password will store one of the fields, and autofill it, but not both of them. Granted this is a bit of an unusual login process, but still, it would be nice if it were supported.


1Password Version: 5.3.2
Extension Version: 4.3.1.90
OS Version: 10.10.3
Sync Type: Dropbox

Comments

  • Stephen_CStephen_C
    edited June 2015

    The usual solution for problems like this is to re-create and save the login manually. See this knowledge base article:

    How to manually save a Login

    Have you tried that?

    Edit: I deleted your duplicate post.

    Stephen

  • Hi @JMcCorison,

    Please let us know how you get along with Stephen_C's suggestion. I've tried the site and it fills when I follow that procedure. Excluding any oddities you'll hopefully be reporting the same success :smile:

  • JMcCorisonJMcCorison Junior Member
    edited June 2015

    Thanks for the suggestion. Interestingly it mostly works. I didn't think it would work because when you look at the entry created by manually saving the login it only shows the second of the two username fields. Even the full 1Password program only shows the second field. But if you go ahead and use it anyway it fills in both of them correctly. I used the notes field to record the full sign in human readable form.

    The remaining problem is that the default action when Enter is pressed on the login page is the "Sign me up" button. Is there anyway to specify which button should be "pressed" by 1Password to proceed with the login attempt?

    (@littlebobbytables - Love the handle. Thanks for moving this post.)

  • Hi @JMcCorison,

    Our submit function doesn't actually attempt to programatically click a button in any way, we actually mimic the pressing of the enter key and what happens on most sites is if you press enter while the focus is on the password field (for example) the site will sign you in rather than assume otherwise. It sounds like unfortunately confusion reigns and it's being interpreted to signal the Sign me up button being activated. I seem to get the same behaviour if I type rubbish into the fields and press Enter too.

    In this case it would seem our best option is to disable automatically submit for just this Login.

    1. Launch 1Password and select the Login item.
    2. Click the Edit button in the bottom right hand corner.
    3. You will now see two new options not normally visible, change the submit option from Submit when enabled to Never submit.
    4. Click the Save button.

    Filling with this item should now fill all three fields but it won't attempt to submit. This should leave you free to click the Sign In button and hopefully this will successfully sign you in. Let us know how you get along! :smile:

  • JMcCorisonJMcCorison Junior Member

    Kewl! That did the trick. I always wondered what that field was for. I guess if I'd read the documentation.....

    Thanks for all the help. I've always been very impressed that 1Password is able to complete virtually all the login screens I encounter. Given the wide variations out there, that's no simple task.

  • MeganMegan 1Password Alumni

    HI @JMcCorison ,

    I'm so glad to hear that Little Bobby was able to help get things sorted out for you! You're right ... there is a lot of variety to web forms, and it's always a little bit magical to me that 1Password is able fill my details in all of these places.

    I hope that 1Password works perfectly for you from now on, but if you have any further questions or concerns, we're here to help!

This discussion has been closed.