1Password 3 extension is missing in Firefox 40

phxmrcphxmrc
edited August 2015 in 1Password 3 – 6 for Mac

The 1Password button is missing on Firefox. I can't find it on the Firefox menu and I have tried downloading the extension again. For what it's worth, Firefox says the extension can not be verified. Help!


1Password Version: Version 3.8.22
Extension Version: 3.9.20
OS Version: OS X 10.7.5
Sync Type: Not Provided

«1

Comments

  • Drew_AGDrew_AG 1Password Alumni

    Hi @phxmrc,

    I'm sorry you're having trouble with the 1Password extension! The latest stable Firefox release is currently version 39.0, so it sounds like you're using a beta. Together with your description of the error message you receive, it sounds like you might be having the issue described in this knowledgebase article: How to resolve “code signature could not be verified” (Mac)

    Does that article help at all? Please let us know how it goes, thanks!

  • It turns out the beta version of Firefox was the problem. After I finally figured out how get rid of it and replace with a stable version, it worked. thanks!

  • Glad to hear it's all working for you again @phxmrc :smile:

    Given betas eventually go stable we'll keep this thread open in case this is a fundamental change in Firefox and not a beta oddity that gets fixed before public release. Fingers crossed that isn't the case though and everything simply continues to run smoothly :smile:

  • Actually, I just clicked "update" on Firefox and it updated from 39.x.x to version 40.0. That BROKE the 1Password plug-in. I've uninstalled and reinstalled it several times, but the button won't show-up on the toolbar OR when you go to "customize" the toolbar, 1Password isn't shown as an add-in to add it manually. So, version 40.0 ISN'T a beta -- that's what got installed on the Firefox update. I've also closed and restarted Firefox several times, again without fixing 1Password plugin. Finally, in the Firefox add-ons section, it shows this message "1Password could not be verified for use in Firefox. Proceed with caution". Firefox didn't seem to disable it, but the 40.0 update is the first time this message has been displayed. Several other modules are showing the same type of message but they are working.

  • MeganMegan 1Password Alumni

    Hi @firefoxjim,

    Just to be sure that we're giving you the appropriate help, could you confirm you version numbers please? You've posted in the 1Password 3 Legacy forums - are you using 1Password 3?

  • @Megan
    I have the same issue as @firefoxjim. I just upgraded to Firefox 40.0 which is now general release and I am using 1Password 3.8.22 Build 32010 on OSX 10.9.5. The plugin isn't being disabled but it is not working and the icon is no longer available in the toolbar.

  • Yes, I have Version 3.8.22 (build 32010). I can't upgrade 1Password because I have a Mac that can't upgrade past OSX 10.6.8. It just broke today when Firefox updated to 40.0.

  • And at @edcwood said, 1Password isn't an option under Firefox "Tools" and the icon is missing from the toolbar. It's very hard to NOT use 1Password because I use complex, and different, passwords on every site. I could NOT function without 1Passwork helpfully remembering and inserting them on each web site. Thanks for the questions.

  • @firefoxjim I am guessing that Agile will be able to get it fixed or get Mozilla to fix it. There isn't anything all that different in Firefox 40 probably just some retooling of add-ins. This has happened before with new versions and Agile has always been able to find a fix fast.
    In the meantime I may just use my time machine backup to roll back to the previous version of Firefox if possible. And I agree, I cannot work without it as I have hundreds of different logons for work all with unique and complex passwords. It is one of the best apps I have ever purchased.

  • @firefoxjim. If you have a time machine or other backup with version 39 or even 38 you can go into your preferences on Firefox 40 and set update to manual then close it. You then only need to restore the firefox.app file and replace the newer version 40 one. As soon as I did and re-opened Firefox my 1Password icon is back and working in the browser. Then we just wait to update firefox until a fix is in
    worth a try

  • littlebobbytableslittlebobbytables

    Team Member
    edited August 2015

    Hi @edcwood, @firefoxjim & @phxmrc,

    So here is the bad news. As of Firefox 40, Mozilla have removed something called the widget module and this removal is known as Bug 1118364 - Remove widget module from SDK a conscious decision on the part of Mozilla. 1Password 3 for Mac is old enough that it relied on the widget module for the user interface and so it looks like it is now quite broken as of Firefox 40. I'm waiting on confirmation that this is indeed correct and that I haven't made a mistake with my analysis so far.

    The bad news gets worse. The 1Password 3 extension has not been updated since the very start of 2014, before the widget module was even moved to the deprecated status and given we're referring to a much older version of 1Password it is extremely unlikely that it will be receiving any updates at this point in time. While we do support our users still running 1Password 3, active development did cease quite some time ago. Of course your licence for 1Password 3 is still valid but the problem at hand is global to all software - if all software is not regularly updated together there will be a point in time where incompatibilities can creep in.

    1. Firefox 39 still works and if you stop it from updating you can continue using the 1Password 3 Firefox Extension. Firefox ESR (Extended Support Release) is also another option, at least until the next update to it which I believe is March 2016.
    2. Chrome and Safari are not affected by this.
    3. If you're running a version of OS X newer than OS X 10.7 (AKA Lion) you could also upgrade to a newer version of 1Password for Mac. The upgrade is not free I'm afraid but your licence key for 1Password 3 for Mac would entitle you to an upgrade price.

    Some may not find any of those solutions palatable but these look to be the options available at the moment.

    We will update this thread if we learn anything new.

  • @Megan @edcwood @phxmrc Megan, thanks for the update. I plan on using the latest 1Password as soon as I can replace my Mac with a current version. The version of Mac mini I have (2010) WON'T upgrade past OSX 10.6.8, so I'm stuck until I have new hardware. As @edcwood suggested, I restored from a Time Machine backup a few days earlier so I'm back to Firefox 39.0. I, naturally, won't update Firefox now that we know it breaks 1Password. I was able to copy/paste the login info into each web site but that's very cumbersome. Thanks Megan for your work on this issue.

  • Same problem here. Upgrading to Firefox 40 today broke the 1Password3 add-on. Other add-ons signaled a warning but continue to function: Ad Block Plus, HTTPS Everywhere. My 1P icon is gone and I have no way to log in to sites from the browser.

    This is a disaster. I just bought 1Password3 a few weeks ago. I’m only now getting to the point where I have everything set up correctly. Agilebit’s response is unacceptable. There must be a way to fix this. I’m not going to switch from Firefox; it’s the best browser. I’m certainly not going to buy a new computer just so I can use 1Password and Firefox 40.

    I hate when things like this happen in the computer world. They will surely one day drive me off the grid. I’m really getting tired and frustrated at being forced to stay on the upgrade treadmill. Hardware, operating system, program, peripheral, while the fat cats at Silicon Valley rake in billions, make us do their troubleshooting, and trade dollars for privacy and security. I’m still trying to find a reliable keyboard for a Mac I bought new 8 years ago, one with a working space bar. It’s all so fiddly and excessively complex. I’ve been down this road too many times.

  • I assume Agile was aware of this. Here's a post on Mozilla from two months ago regarding the new signing requirement for add-ons in Firefox 40. Why was there no heads-up from Agile before today?

    https://blog.mozilla.org/addons/2015/06/18/compatibility-for-firefox-40/

  • @countermoon As @edcwood suggested, just restore Firefox from a Time Machine backup. I had a BU from 8-3, so Firefox 39.0 is working again with the 1Password icon in the toolbar. If your Mac is running a version of OS higher than 10.7, I think you can get 1Password upgrades for free. If you're stuck on OS less than 10.7, like my Mac, then you need Firefox 39.0 or lower to make 1P plugin work again.

  • I reinstalled Firefox 38. I keep program installers. Up until last week, I had a long list of Firefox installers which I unfortunately deleted. But I still have FF38. Problem with staying on FF38 or 39 is I will miss out on security updates—usually the only reason I upgrade.

    I'm not going to upgrade to 10.7. I'm not sure if my Mac even can. I've been very happy with 10.6.7, which some call the last great Mac OS.

    I guess I'm the kind of person who likes things set up just so and fine-tuned, rather than having a system which is always in flux and breaking down like a bad car that needs to be babied. Some programs I don't mind updating over time because it's to be expected, or so I have been conditioned to believe. It's especially annoying when one program's update breaks some other program. I'm not at all happy with this latest bad news about 1Password3. And this so soon after I bought it. It isn't the money—it's a decent program worth its price. But this kind of thing is too much. I spent so much time on my passwords.

  • I don't use Time Machine. I use Super Duper.

  • Hi @countermoon,

    I'd just like to clarify that the issue here isn't the pending signing requirements in Firefox. That particular issue affects even our newer extension for 1Password 4/5 on Mac and Windows and we will be addressing it there. While there is a warning in Firefox 40 about signing, unsigned extensions are still allowed to run. Firefox 41 will have a hidden preference to allow unsigned extensions and Firefox 42 will ban their use completely. The issue here is the removal of libraries that our old extension relied on. With the removal of the widget module from Firefox the extension is broken at the code level.

    I would always strongly advocate keeping a system up to date. You're right, you should install the latest version of your favoured web browser for the security updates, for those that can that applies to operating system updates too. I believe OS X 10.7 (AKA Lion) has not received security updates in almost a year now (Snow Leopard a year longer) and that sadly includes some recently discovered and well publicised flaws. Sure it can be a pain and the UI changes may not be to everybody's taste but from a security standpoint your best chances lie with a fully updated OS and third party applications. Not everybody can as @firefoxjim has pointed out and we've all likely been there. I watched as applications I used supplied x86 only updates while I hung on to my PPC PowerBook and mini.

    On the Mac we have to keep up with the Apple because that's what our customers want and expect. However we're a fraction of the size of that giant (as well as not relying on hardware sales) and actively developing multiple versions of our software is sadly not viable. As I said, we still support our users running 1Password 3 and 4 but development on 1Password 3 ceased in 2014. Since the introduction of 1Password 4 we haven't technically sold a 1Password 3 licence, we include a key for those that may find need of it with their purchase of either a 1Password 4 or 5 licence. I look at the business decisions made by AgileBits and I don't see anything out of line with most other companies. We try to offer great support but we also have to be pragmatic.

    Given you made your purchase very recently we could offer you a refund for your 1Password 5 licence if you feel unhappy enough about this situation. If at any point we gave you the impression that 1Password 3 was still being developed I apologise as that wasn't our intent. We would never wish to mislead any of our customers - we want you all as happy with 1Password as we are.

    This situation sucks for those stuck on Lion or earlier. I don't think the options are great but sometimes these choices need to be made. I can understand why you're unhappy but the reality is computers are very different from other common appliances in your household. In that more general topic of discussion I don't have an answer for you.

  • Firefox 40.0 just killed my 1password extension. Are there any workarounds short of Upgrading the OS. I understand 1Pw v 3 is as far as i can go with 10.6.8.


    1Password Version: 3.8.22
    Extension Version: 3.9.20
    OS Version: 10.6.8
    Sync Type: Not Provided
    Referrer: kb-search:firefox 40.0

  • It as been pointed out to me that Firefox ESR (Extended Support Release) is also another option, at least until the next update to it which I believe is March 2016. At the moment Firefox ESR is based on Firefox 38 so should still work with the 1Password 3 Firefox Extension.

  • I have tried removing and reinstalling the extension and cold reboot but still not working.
    Installing the trial version 4 works but I was quite happy with what I had.
    Is version 3 not compatible with Firefox 40.0 or do I need to do something else?

  • khadkhad Social Choreographer

    Team Member

    Hi @Mushroo,

    Thanks for taking the time to contact us. I merged your post with the existing thread for this. Please see littlebobbytables's post above and let me know if you still have any additional questions. As he mentioned in his post directly above yours, Firefox ESR is an option.

  • Agilebits should update this broken 1 Password Extension (https://agilebits.com/extensions/mac/index.html) for 1 Password 3.8.22 (Build 32110) Extension.
    This is an inexcusable oversight, which has become indicative behavior of many Software developers.
    You need to update the extension, get it to Mozilla for signing and all will be well!
    Again this behavior of explaining away neglect of your paying customers, or blaming it away, is nonsense!
    GET IT FIXED! It's that simple AgileBits! I paid for a working product! NOT EXCUSES!
    The insult to injury, is that you've had plenty of time to address and fix this issue, before the release of Firefox 40.0.

  • cyborgsamcyborgsam Junior Member

    The latest Firefox 40 requires extension signing. Supposedly Firefox warns but allows unsigned extensions, but 1Password does not appear.

    I'm on Snow Leopard running 1Password 3.8.22, I tried extension 3.9.20 and 3.9.21b1.

    And chance Agile Bits can sign the older extension for those of us using older OS X versions?

    TIA


    1Password Version: 3.8.22
    Extension Version: 3.9.21b1
    OS Version: 10.6.8
    Sync Type: Dropbox

  • I have the same problem as off today
    OS X 10.7.5
    1Password 3.8.22
    Sync: Dropbox

  • khadkhad Social Choreographer

    Team Member

    @Whitebuck, the issue here is unrelated to Firefox extension signing. As littlebobbytables mentioned above:

    I'd just like to clarify that the issue here isn't the pending signing requirements in Firefox. That particular issue affects even our newer extension for 1Password 4/5 on Mac and Windows and we will be addressing it there. While there is a warning in Firefox 40 about signing, unsigned extensions are still allowed to run. Firefox 41 will have a hidden preference to allow unsigned extensions and Firefox 42 will ban their use completely. The issue here is the removal of libraries that our old extension relied on. With the removal of the widget module from Firefox the extension is broken at the code level.

    Firefox ESR is currently on version 38 and will thus work with the old 1Password 3 extension if you need an immediate workaround. ESR stands for Extended Support Release which you can think of as a "super stable" build. It's what large organizations who can't afford any downtime use.

    Again, it is not related in any way to signing, but I can say that the current version of the 1Password extension will definitely be ready when Firefox mandates the signing. Firefox doesn't mandate extension signing in version 40. We haven't announced any plans to sign the old 1Password 3 extension, but we really appreciate you letting us know you are still using the old version of 1Password. Note that anything newer than OS X Lion (which was first released over 4 years ago) can run a more recent version of 1Password (and thus the current version of the extension).

  • Drew_AGDrew_AG 1Password Alumni

    Hi @cyborgsam and @Use-a-bit,

    Since you're using version 3, I've moved your messages to our "1Password 3 for Mac" forum, and also merged them into this existing thread about the same issue.

    As you can see in Khad's reply (right above this one), the problem isn't actually due to Firefox extension signing, but rather is because of libraries used by our old extension (version 3) which have been removed from Firefox 40.0. For information about this issue and your options, please check out this post from littlebobbytables, earlier in this thread. He also provided some additional details in this post.

    I hope that helps explain the problem, but please let us know if you have more questions or need anything else. Thanks!

  • cyborgsamcyborgsam Junior Member

    @firefoxjim: according to Mactracker all Mac minis from 2009 on will update to the latest OS X (Yosemite).

  • Hi, Instead of installing an older (ESR) version of Firefox can one simply pull the relevant library files from the last working version (Firefox 39.03) and manually add them to Firefox 40.0...and future releases? If this would work, can you tell us which files are required and where they need to be put?

  • khadkhad Social Choreographer

    Team Member

    @Mushroo, that would not be something we could provide support or guidance for. We recommend Firefox ESR.

This discussion has been closed.