undesirably defaults to automatically submit logins

BettBeeBettBee Junior Member
edited July 2015 in 1Password 3 – 6 for Mac

Dear 1Password,

Every so often (and far too often) I'll click on a login entry, and it automatically submits it, despite the fact that I have repeatedly deselected this behavior in settings. I never know when this bug will strike. I really hate it when this happens, because most websites have this checkmark selected by default, that you must deselect not to be "remembered". So when the login is automatically submitted, I lose the opportunity to deselect this nefarious checkbox. I basically never want to be remembered by a website or otherwise do anything to prompt yet more cookies being set.

Please stop this random changing of my chosen settings without my permission. It's driving me nuts.

Thanks!


1Password Version: Version 3.8.22 (build 32010)
Extension Version: 3.9.20
OS Version: 10.8.5
Sync Type: wifi

Comments

  • If you resave your login manually, with those check boxes unchecked, 1Password will remember that state and keep it unchecked when ever you log in. The instructions for doing this are found at this link: Resaving a login Manually

    I don't know why you are unable to select the option to never submit a login. That should be possible within each record, or by default for all records if you change that in the 1Password preferences.

  • BettBeeBettBee Junior Member

    Hawkmoth, I'm not having problems saving logins. And I never said I'm unable to select the option to never submit a login.

    My problem is that the plugin is changing its own settings without my action or permission. So it'll work as it should until one day, for no reason, it automatically submits a login. When this happens I go into settings and find that checkbox is checked, so I uncheck it and continue on. But it's very irritating, as I never want my logins submitted automatically. I correctly set my own settings, but again, the plugin has, for some reason, altered them.

  • Vee_AGVee_AG 1Password Alumni
    edited July 2015

    Hi @BettBee,

    [Moderator note: I've moved your post to the 1Password 3 for Mac forum.]

    I'm so sorry for the frustration you're experiencing with automatically submitting. I think I might know what's happening here.

    There is actually another way to change this setting besides checking/unchecking the "Automatically submit logins" box, which you may be doing accidentally.

    If you click on the bar that says "fill login," it will change to say "fill and submit login," which does the same thing as checking the box. If you're careful not to click that bar, the setting should not change. I hope this helps! :)

  • BettBeeBettBee Junior Member

    Hi, Moderator! Thanks for putting it in the appropriate place.

    And thanks for your answer, but I can categorically state that I'm definitely not clicking that "fill login" bar - only ever on the entry for the website I'm on at the time, or the one I've searched for and want to go to.

    The problem is definitely the prefs changing on their own - when this happens to me, I open the prefs and find that box checked.

    And I actually do mean I NEVER check that fill login bar. I am precise about where I click, and I actually never even knew that was a functional bar. I just checked it out and have never seen it say "fill and submit login" before.

    So can you folks work out another reason why this might be happening to me? It's caused me some trouble in the past.

    In the rare case that I want a site to remember me for the sake of convenience, I use the browser's functionality to do that, not 1Password.

    Thanks again!

  • MeganMegan 1Password Alumni

    Hi @BettBee,

    Well, I know that when I was using 1Password 3, I accidentally clicked that menu bar more than once, so clearly you're a more cautious user than I am! ;)

    Could you please clarify your exact steps when filling a Login in 1Password? For example:

    • Are you viewing the page that you wish to visit before activating 1Password?
    • Do you click on the browser extension icon or use the ⌘\ ( Command- \ ) keyboard shortcut?

    The more detail you can provide, the better. I'd love to do some testing here and see if I can confirm what you're seeing. Honestly, I can't think of any reason for 1Password's preferences to change without some sort of user interaction, so I'll need to do some playing around in 1Password 3 to see if I can recreate what you're seeing.

  • BettBeeBettBee Junior Member
    edited August 2015

    Hi, Megan, thanks for responding!

    Apologies for the long time before answering your comment, its notification was buried in junk mail. Apple Mail has now decided that email from this forum is now spam. (Another blitheringly incomprehensible machine-made decision as I have received and read any number of emails from Agilebits and some even from this forum, in the past.) Aargh!

    Somewhat ironically, I discovered this email while searching for emails from Agilebits. I was doing so to confirm which email address I use with you guys, in order to submit it to the "find my license key" field so I could see what it was going to cost me to upgrade (grrrr.) (I went ahead and upgraded Firefox to v.40.0.2 and apparently am now entirely screwed. No 1Password button to push at all - correctly or not!!! But that is aside from the point . . . )

    I did check my procedure back in July when this first came up and the Moderator mentioned that little menu bar, and I really can verify that I've never clicked that bar. Now I'm as prone to mis-clicks as the next person, I'm always driving myself nuts bringing up the [expletive deleted] dashboard by swiping too far into the corner which activates it, and other such fumble-fingeredness, but this time I really am sure, and here's why:

    I learned long ago to pay attention to what happens when I click on things, being the "family and friends helpdesk" and spent innumerable hours trying to get people to read dialog boxes before clicking "yes" and I am morally certain that I would have noticed the text changing. Especially as this glitch has happened to me quite a few times. This last occasion that prompted me to write in about it was just that last straw on the poor camel.

    And to back that up, I tried it again and again just to make sure, and in addition to seeing it change back and forth as an entirely new phenomenon, I've only ever had to click once to fill in the username and password. I found that for what you describe to have happened, one had to click that bar, which changed the preference, then still click the name of the site to fill in the password and username fields. I definitely would have noticed the anomaly of having had to click twice and subsequently encounter the incorrect action of the information being submitted without my approving click.

    To answer your questions, firstly, I sometimes use 1Password to bring me to a page using the search function, but even then, it isn't supposed to automatically submit. Except for when it is misbehaving, it does not. I still have to click the "login" button. But usually I'll go to a page, and click on "login," then click the 1Password icon, then click on the name of the site within the 1Password dialog, then on the site's "submit" or "login" button. Secondly, I've never used the keyboard shortcut. (But once (or if) I manage to get 1Password back working in Firefox (grrr) I will start now you've told me about it.)

    Thanks again for looking into it,

    Bettina

  • brentybrenty

    Team Member

    @BettBee: Please see my separate post regarding your Firefox issue in the other thread you created.

    As for the Autosubmit issue you're (occasionally) having, there are a number of reasons the old extension could become disconnected from the Helper (including security software or firewall settings and glitches — this is part of the reason we designed a new extension to take advantage of browser advances to make it more reliable), so it's hard to say for certain what cold be going wrong in your case, preventing the Autosumbit setting from 'syncing' correctly between them, without more information.

    If the problem persists, the best thing to do would be to use the 1Password Troubleshooting tool to generate a diagnostic report and send it to support+forums at agilebits dot com so we can look at the logs to determine exactly what is happening. Just be sure to include a link to this forum thread and your username in the email so we can 'connect the dots'. We will get to the bottom of this! :)

This discussion has been closed.