Why is my license key not valid anymore?

I have a copy of 1Password, version 3.8.22 and my license for version 3 doesn't work.
The app gives me a warning: The license key you entered is for an older version of 1Password. Please upgrade your license to receive a new key.

The license is for version 3, and on the support page it says:
When you purchase 1Password, your license for the purchased version will never expire and you will receive all point updates for free.

So the license for version 3 should work for version 3.8.22 as well.

Any ideas?


1Password Version: 3.8.22
Extension Version: Not Provided
OS Version: OS X 10.10.4
Sync Type: Not Provided
KB Article: license-requirements

Comments

  • Hi @Fabio,

    You should have an email from us in your inbox with a regenerated key for 1Password 3. There was something odd about the record but I can't put my finger on it. Anyway, the regenerated key should get you up and running. Now we do have 1Password 5 out now but that isn't a free upgrade. Your licence key though would entitle you to a upgrade price though and your system is compatible with 1Password 5 given you're running Yosemite. I just mention it as we've made a lot of improvements and bug fixes since we last worked on 1Password 3 and we think there's a lot in there to tempt our users with :smile:

    Should you have any issues at please do post back :smile:

  • I am having the same problem as the original poster. What should I do?

  • littlebobbytableslittlebobbytables

    Team Member
    edited December 2015

    Hi @dpflair,

    The issues may be related but seem to be for very different reasons, it seems you're actually a 1Password 2 user and you need to upgrade to 1Password 3. I'm going to email shortly you with the details as I think it's just a form that needs filling and processed :smile:

    ref: ZRI-22129-245

  • dpflairdpflair
    edited December 2015

    -

  • dpflairdpflair
    edited December 2015

    I found my receipt for 1Password 3, but it was purchased through the Mac App Store. Is there a way that I can redownload that? All I can find in the App Store is 1PW5. My Mac is running 10.7 so I can only use 1PW3.

  • brentybrenty

    Team Member

    @dpflair: If you purchased 1Password from the Mac App Store, you can download it again at no charge using the same Apple ID. That last part is extremely important: if you use a different Apple ID, you will be charged again. As far as I know Apple does not allow purchases to be transferred from one Apple ID to another, although you can use Family Sharing to share the purchase with other Apple IDs.

    Since the App Store page for an app will show the current version though, you will need to download 1Password from the Purchased tab in the App Store. This definitely works, as I've had to do it a number of times on different OS X versions since I first purchased it there back in 2011. Please let me know how it turns out! :)

  • Nope, I still cannot find 1Password 3 on the Mac App store, even in my purchased tab on the correct account. It is probably because I also purchased 1Password 5 for one of my other computers. So only 1PW5 shows up. This is very frustrating!!!

  • Hi @dpflair,

    What happens if you try to download 1Password 5 on your Mac running OS X Lion? I know what happens if I do this on a Mavericks Mac, the Mac App Store informs me my Mac cannot run 1Password 5 and would I like to download the last compatible version which for Mavericks was 1Password 4. Does it simply refuse and offer you no solution or does it offer to download 1Password 3 for Mac?

    If not did you try the instructions I emailed you? I believe they would help.

  • The App Store will not allow me to download 1Password 5 on my Mac running OS X Lion. It says I need a newer operating system to run it, and it does not give any other options.

    Was there more to the instructions that you emailed? All I saw was a link to pay $25 to upgrade from 2 to 3. Since I already paid for that upgrade in the past I would rather not pay again.

  • brentybrenty

    Team Member

    @dpflair: You're absolutely right! I'm sorry for the confusion. Part of it is that you originally stated that you were in the same situation as the original poster...but of course you don't have a license for 1Password 3, which is why lil bobby initially suggested the upgrade.

    The reason I (and perhaps lil bobby as well) believed this would work for you is likely because we've done this successfully with 1Password 4. However, it seems that Apple added this feature in a later version. From their support page:

    You might want an earlier, compatible version of an app if you don't have the latest operating system on all of your devices. [...] Here's what you need to download an earlier version of an app:
    iOS 4.3.3 or later on your iPhone, iPad, or iPod touch
    OS X Mountain Lion or later on your Mac

    So this will work with 1Password 4 since it requires Mountain Lion or Mavericks, but the App Store does not support this 'latest compatible version' feature on Snow Leopard or Lion, I'm afraid. :(

    But that doesn't mean you're out of luck. The AgileBits Store version is otherwise identical, so we can give you a license for that to replace the Mac App Store version...and of course if and when you update OS X you'll be able to use the Mac App Store version again if you wish.

    Now, normally at this point I'd suggest that you send us a copy of your Mac App Store receipt at [email protected] so we can use it to generate an AgileBits Store license for you...but since we've already been in contact via email, I'll just followup with you there! :)

  • When AgileBits resent my license their email stated that it was for 1Password 3 when it was actually 1Password 2. That is why I thought I had the same problem as the original poster. Thankfully now we have cleared up the confusion and solved the problem.

  • brentybrenty

    Team Member

    Indeed, sorry for the mixup! You should be all set, but we're here if you need anything else. :chuffed:

This discussion has been closed.