Cannot copy TOTP from browser extension

When I try to copy the TOTP from the browser extension (by clicking on the "copy" button) nothing ends up in the cut buffer (nothing gets pasted on paste).

Copying from the 1Password application works just fine.

Chrome 43.0.2357.134 (64-bit)


1Password Version: 5.3.2
Extension Version: 4.4.1.90
OS Version: OS X 10.10.4
Sync Type: Dropbox

Comments

  • Hi @Kimmo,

    I confess, it's a pretty generic suggestion but it might be worth rebooting your Mac and seeing if what you're experiencing is a blip. I did test but haven't managed to replicate your issue so far. It might be the reboot doesn't solve anything but I think it might be worth a shot, at least as a first attempt. Let us know how you get along and of course if it doesn't help we'll continue working with you as to the cause of this puzzle.

  • Hi @littlebobbytables,

    I tried rebooting and it did not help.

    If I anchor the popup on the screen then I can copy the TOTP.

    Copying a password works fine without anchoring (although I normally use Cmd-).

  • Hi @Kimmo,

    I think I've discovered it and I wonder if you could confirm my findings for me please.

    1. Ensure Chrome is in focus, I'm using the window buttons as a point of reference.
    2. Navigate however you like to your item with the TOTP code and using your trackpad or mouse click on it to copy the code.
    3. Are the Chrome buttons now faded out like this?

    I'm not entirely sure what is happening but Chrome is still the active application and yet the window has lost focus in some way. If you're observing the same thing do you find the following works for you?

    1. After copying the TOTP code, if you click on field again the code should paste normally.
    2. If you use the arrow keys to navigate through 1Password mini and with focus on the TOTP code you can use the enter key to also copy the TOTP code to the clipboard. I find that doesn't shift focus.

    Once I hear back from you with confirmation that this is what you're also experiencing I'll write up the bug report with our findings. I can't exactly remember how I tested before so now I don't know if I simply wasn't experiencing it or if I was using the keyboard. The good news is I think I'm reproducing your trouble and that's a good thing in terms of the initial steps of creating a bug report :smile:

  • KimmoKimmo
    edited July 2015

    Hi @littlebobbytables,

    Yup, it is exactly as you describe:

    • clicking on the TOTP field copy button makes the focus go out of the Chrome window
    • clicking on the field before pasting makes the paste work normally
    • using the arrow keys + enter to copy the TOTP code retains the focus on the correct window

    Thanks for looking into this so carefully. I never noticed the loss of focus.

    But now that I think back, I realize the same thing has been happening with credit card numbers: I'd have to click on the field again to paste the card number. But then usually copying the CVV right after would work fine.

  • littlebobbytableslittlebobbytables

    Team Member
    edited July 2015

    Hi @Kimmo,

    I'll test some other fields then but the important part is I think we've nailed down the issue nicely for the developers (which makes their jobs easier) and as well, now that we understand what is happening we can adapt while it's an issue.

    Thank you for coming to the forums and reporting your issue :smile:

    ref: OPM-1519

This discussion has been closed.