Problem with open attachments.


When I want to open an attachment with the extension xls or xlsx (with and without a password), 1password reports that an error exists in the file.
Once this error message shown the program stops the xls or .xlsx file to a temporary folder you can open without any problem (again with and without password).
When the file you want to open a pdf, not on the list of programs to be selected, none supports pdf.

I suggest that these problems had been detected in previous versions of 1Password but for a while it worked well. Lately one password has been updated a couple of times and do not know if the problem is these updates.

As these problems be solved?.

Thank You.

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • Sorry
    Version 1Password PC Windows:
    Version 1Password Android: 4.5

  • periperi

    Team Member
    edited July 2015

    Hey @jordiben. Thanks for getting in touch with us!

    You should indeed be able to open .xlsx attachments from 1Password 4 for Android. Can you confirm that you have some sort of XLS viewer installed on your device? Google Sheets works well for me.

    If you have a spreadsheet viewer, simply click the attachment to open it. If you're given the option to open using the spreadsheet viewer, choose that. If not, choose to open with the browser, and you should then see the spreadsheet viewer option.

    I'd like to add that we do have an open issue with regards to 1Password not offering the correct app to open certain attachments, and that may be the case here. If so, please go with my latter suggestion.
    ref: OPA-591

    Please give that a shot and let us know if you're still having trouble viewing your attachments. Thanks!

This discussion has been closed.