1Password Extension clearing out form values

I am using an application that has many form fields and uses Javascript, when I have the 1Password for Chrome/Mac enabled it is clearing out form values and corrupting the app. Has anyone seen anything like this or can help me understand why this happens and how to prevent it?


1Password Version: 5.3.2
Extension Version: 4.4.2.90
OS Version: OS X 10.10.4
Sync Type: Not Provided
Referrer: kb:fix-website-login

Comments

  • brentybrenty

    Team Member

    @mcarr: I'm afraid I'm not sure what you mean by 'app'. 1Password for Mac does not have the ability to fill information into other apps, only the web browser (and even then this requires the extension be installed for it to work).

    The more information you can give, the better! For instance, if you can tell me the the exact steps you're taking and where, we'll see if we can narrow down the cause and come up with a solution for you. Thanks in advance! :)

  • I am running this https://github.com/ccrisan/motionpie on a raspberrypi, I access the web console with Chrome. As long as the 1Password Chrome extension is enabled, on a post to the server, the data gets corrupt. I am really not sure why this is happening.

    Here is the issue thread https://github.com/ccrisan/motionpie/issues/30#issuecomment-125752273

  • Hi @mcarr,

    So if I understand correctly this is Chrome specific, in that it works fine if you use Safari based on the thread you linked us to and I see you posted a payload there too. Could you help us out a bit here please, I'd be interested in seeing what the payload looks like with and without the 1Password Chrome Extension being enabled so we can understand what impact merely having the extension loaded seems to be having. Just to confirm as well, this happens when you click the apply button, is that correct? Your help will be invaluable as if I'm correct, testing this does require a Raspberry Pi.

This discussion has been closed.