Firefox 39.0.3: no right-click option for 1P4

4EverMaAT4EverMaAT Junior Member

It's also not in the main firefox browser windows either (right-click 1P context menu). But at least I have the icon in the toolbar to fill in passwords in the main browser tabs.

I could not customize the toolbar in the firefox popup window.

I tried to go to the firefox 'addons' window and see if additional settings can be set there for 1P extension. No luck there. (no settings option).

So with no right-click context, how was I supposed to fill in the password without access to the icon for that tab/window?

Firefox 39.0.3

edit:

Google chrome has the right-click menu option (44.0.2403.155 m (64-bit)):


1Password Version: 4.5.0.585 (12)
Extension Version: 4.4.2
OS Version: 6.1.7601 SP 1 (win7 x64)
Sync Type: dropbox

Comments

  • Greetings @4EverMaAT,

    Could you try uninstalling the 1Password Firefox Extension please, quitting Firefox and then installing the extension again. I'm unsure as to the exact cause so I'm hoping this will work around whatever is happening.

  • 4EverMaAT4EverMaAT Junior Member

    @littlebobbytables,
    I did exactly what you suggested. And I installed directly from: https://agilebits.com/onepassword/extensions/firefox?beta=false No luck. Other extensions work just fine. It is specifically the 1Password4 extension.

    I cannot explain it. Need the right-click menu for special circumstances as described in the OP. Can share the desktop with someone if needed via remote desktop ssoftware like AmmyyAdmin.

  • 4EverMaAT4EverMaAT Junior Member

    I now see it after removing, restarting, and reinstalling the 1p4 firefox extension again. What you must do is actually right-click on a textbox or textarea textbox in order to get the 1Password option to show up. It's an improvement. :)

    But the drama continues :'( ....

    I went back to the site in question: http://www.brookings.edu/blogs/brookings-now/posts/2015/08/renminbi-internationalization and then went to login to disqus in the discussion section.

    (if you are already logged into a social media, log out[, maybe reload the page], and then try to login with disqus). A popup window will show up (https://disqus.com/next/login/?forum=brookingsnow&redirect_secure=1 ; launch it from the brookings.edu webpage to simulate the bug as shown in screenshot above) . Right-click 1P4 is not available from either of the textboxes or anywhere on the page.

    One solution is to have an option in the 1Password4 extension options menu that 'forces' 1Password into all right-click menus. You can see from the screenshot that other extensions are in the right-click menu. So why can't 1P be there?

    _
    Just for thoroughness, I checked the Disqus popup login window in Chrome browser (44.0.2403.157 m (64-bit)). It shows up, but it does not auto-fill in.

    I must right-click on the stored disqus password to reveal the username/password and then copy the fields manually.. But at least you can do it from there, not having to switch to the main browser or main 1P app. Not perfect auto-fill, but a step up from not being there at all like in firefox.

    _
    I also checked the legacy 1P3 (or 1P1) extension. The right-click menu shows, but it redirects the user to the 1p1 icon on the main browser window; so still mostly useless unless I would then manually copy/paste the password from the main browser window back into the popup window.
    _
    A separate question: Is it possible to custom-position the 1P right-click context option? In other words, I want to move it up closer to the top of the right-click menu. Currently it is all the way at the bottom of the right-click list (as shown in all my screenshots where 1P appears).
    _
    Alright, I've done enough troubleshooting for today. I must really like you guys. I don't usually go too far like this. Had real work to do that got pushed aside.

  • Hello @4EverMaAT,

    So I have a couple of quick questions.

    1. Is there a reason why you're still on Firefox 39? The current version is Firefox 40.0.2 and I know we've had trouble in the past with Google Chrome if an update is pending (it interferes with the extension). Normally we hear this in relation to Google Chrome but maybe the same applies to Firefox.
    2. If there is specific site that this is required for, is this issue just with this site? For example if you visit somewhere as simple as Twitter, what works and what doesn't? If it turns out it's unique to this site and you were happy to post the URL we could test and see for ourselves.
  • 4EverMaAT4EverMaAT Junior Member
    edited August 2015

    @littlebobbytables

    Is there a reason why you're still on Firefox 39?

    1) I just went back to 39 after the 40.x issue. at the time I was still with 1P1/1P3. I understand that 1P4 may work with 40.x, but never went back. I'm one of those people that if it isn't broken, I don't fix it.

    Would going to 40.x fix this specific problem? I doubt it.

    If there is specific site that this is required for, is this issue just with this site?

    2) Not sure. This is the only site I have seen this happen. I would think it is a 2-fold problem
    a) bug with the way that 1P injects itself in the right-click menu
    b) bug in recognizing the textfields to autofill correctly.

    As Chrome still had a problem with auto-fill, but at least the right-click 1P4 menu appeared ok. Firefox I don't even get the right-click option to access 1P4 :(

    See the 2nd and 3rd screenshot in this post The brookings.edu url is there and you can attempt to reproduce the error entirely.

    I tried twitter and all worked ok. the disqus popup window seems to be the only website I've encountered with this dual problem (no right-click 1P option and/or no auto-fill ability). The no right-click 1P option is a larger bug IMO.

  • Hi @4EverMaAT,

    Sorry about that, I've been a bit sluggish today and I had your post loaded in a tab before your post going into more detail about the site in question. So my answer might make a bit more sense when you discover I was replying to the post about uninstalling and installing the 1Password Firefox Extension.

    With the URL I can now replicate the issue that you're experiencing. Unfortunately I don't know enough about the browser specific implementation details connected to the window.open function which is what is opening the new window. I think I will need to speak to a developer before I understand why behaviour differs here.

    I may have a workaround though. The keyboard shortcut ctrl + alt + \ opens the 1Password menu and I found that with this window in focus I could bring up the menu, 1Password recognise where I am and I could select a discus Login item and have it fill, even with all the odd behaviour you're experiencing. I would say it is worth trying to see if you find the same.

    Regarding Firefox. Personally I would recommend letting Firefox update as and when it wants to. You're quite right, there was an issue with the old 1Password 3 Firefox Extension and Firefox 40 but this was in part because the old extension was retired some time ago and compatibility has not been maintained. This isn't the case with the 1Password 4 branch as it's the current one and needs to work with all the stable browsers.

  • 4EverMaAT4EverMaAT Junior Member

    @littlebobbytables

    In Firefox, I tried short cut ctrl + alt + \ within the disqus popup window (with the cursor in either the username or password fields) and it does bring up the 1P4 context menu. But it does not recognize the site disqus. I have to 'search' for disqus and then when I click on it to autofill, it opens up a new tab with the 1p-stored url. So this means that 1p4 does not recognize anything in that popup window :(

    There should be either an icon in the toolbar, floating icon, right click, or all 3 in the firefox popup login of disqus.

    Chrome did not have this problem of not recognizing disqus. Only autofill problem.

    I likely won't be upgrading browsers. I never use auto-update in most software for 2 reasons: 1) broken functionality (not broke, don't fix it, and 2) bandwidth considerations. I upgrade as necessary. 1P4 should still be supporting v38.x of firefox until Mar2016 if I'm not mistaken. I'd probably roll back there.

    _
    speaking of right-click, have you considered other forms of injecting 1P4 into forms? Like lazarus has a translucent icon directly on the textbox/textarea itself. S3Translate will also have a floating icon whenever you highlight text on a webpage.
    _
    let me know when you have a real fix for testing.

  • Hi @4EverMaAT,

    Given the trouble you're having with both Firefox and Chrome it might be worth creating a new Login item from scratch by following our Saving a Login manually guide. If you create this Login item from the small pop-up window you'll want to adjust step 3. to use the alt + ctrl + \ keyboard shortcut. In my testing I had no issues filling in on this page once the issue of the missing toolbar was bypassed. That part by the way is set by the page opening the pop-up window as are many other aspects e.g. the URL bar can be removed as well.

    Other aspects will depend greatly on what support and quirks each browser has. I am no where near knowledgable enough on these differences to confidently comment on them so it will be up to the developers to investigate.

  • 4EverMaAT4EverMaAT Junior Member

    @littlebobbytables
    Didn't work on the popup disqus login window. I got to Settings > Save new login. Then nothing. (firefox) No Save New Login window.

    Chrome already works ok with right-click 1P option.

    I'll wait for a real fix.

  • Just as long as you realise that the issue of the Login item not filling or even being recognised as being applicable seems to be something specific to your setup. I can create a Login item that fills in Firefox for disqus (which does include ctrl + \ it seems). If you want to investigate why this isn't working on your machine let us know.

This discussion has been closed.