High CPU usage - 1Password and 1Password mini

I've been using 1Password5 for quite some time. The problem I have has been there since day 1. I save my vault to a directory on a local drive. This directory is synchronised with my private cloud (Synology Could Sync). Since I use 1Password on multiple devices some from Apple I use my Mac as a wifi server for other Apple devices. Every time I open 1Password (via browser's extension or using 1Password app itself) it start hitting my CPU severely - 200-400% on 1Password process and approx 100% on 1Password mini process.

How to solve that? I read other threads about similar issues but hints provided there did not help. I tried disabling Wifi server function, disabling my cloud sync service, creating new directory and moving all the data there. None of that worked :(


1Password Version: 5.3.2
Extension Version: 4.4.3
OS Version: OS X 10.10.5
Sync Type: Sinology could sync


  • Drew_AGDrew_AG 1Password Alumni

    Hi @scureq,

    I'm sorry you're having this problem with high CPU usage while syncing via Synology Cloud Station! It sounds like you searched our forums for information and/or a solution, but in case you didn't see it, here's a similar thread that I answered several days ago.

    To summarize what I said there, this problem can happen when Synology Cloud Station tries to resolve a sync conflict by creating separate conflict files in your .agilekeychain. 1Password is notified of the changes and tries to sync them to the local 1Password vault. This is normal behavior and the same thing can happen when using (for example) Dropbox sync. But the problem is that 1Password doesn't understand the way Synology Cloud Station creates the conflict files, so it isn't able to resolve the conflict. More conflict files are created, so the sync is constantly triggered in 1Password, and it all ends up as an endless sync loop (which causes the high CPU usage).

    One thing I suggested in the other thread was to check the time on each computer syncing with the .agilekeychain in Synology Cloud Station. If the time doesn't match for some reason, that can lead to the conflicts. It sounds like the customer in that thread was traveling through different timezones, and that may have been the cause.

    To solve this (at least temporarily) we suggest disabling sync in 1Password on each computer (your iOS devices that sync with 1Password via Wi-Fi sync should be ok), deleting the .agilekeychain from Cloud Station (which should remove it from each Mac), and then re-enabling Folder sync in 1Password on one of the Macs. That will create a new .agilekeychain, which should sync to Cloud Station and the other computers (you'll need to re-enable Folder sync in 1Password on the other Macs and choose that new keychain).

    If that's what you already tried, unfortunately there's no much else we can suggest. Because 1Password doesn't specifically support the way Synology Cloud Station handles conflicts, you can run into the same problem again. We have an open ticket with our developers about this, so it might be improved at some point, but I don't have any timeframe for that. I can add your comments to our internal tracker to let our developers know you're having the same problem.

    I'm sorry I don't have a better answer than that. If you have more questions, please let us know! :)

    ref: OPM-3074

  • Hi Drew,

    Somehow I missed that part about recreating the .agilekeychain file. That actually did the trick! Thanks for help! On a side note - do you have plans to officially support Synology? I assume lots of people use it.

    Thanks again!

  • Drew_AGDrew_AG 1Password Alumni

    That's great news @scureq, I'm glad that helped! :)

    On a side note - do you have plans to officially support Synology? I assume lots of people use it.

    We have an open ticket with our developers about this issue (and I added your comments to that), so they're aware this can happen and it's possible they'll be able to add official support for Synology Cloud Station in a future release. But I can't make any promises about if/when that will happen. We do receive a lot of requests to add support for other sync solutions, and I feel like we've been hearing from more customers about Synology recently, so it certainly seems like it would be helpful for a lot of users. I just don't have any definite information at this point (and we generally don't discuss future plans/features).

    We're here for you if you need anything else! :)

  • AlexHoffmannAlexHoffmann

    Team Member
    edited September 2015


    While investigating another issue with Synology Cloud Station, we were able to reporduce sync issues when the client and the server tought they were in different time zones or had different times set. Other customers reported high CPU usage when syncing via Cloud Station.

    This suggests that a workaround could mean checking that the time and date as well as timezone on the server and clients is identical (possibly by using the same network time server). Can you please compare the time and date on your server and your client devices?

  • MacMikeMacMike Junior Member

    I am also having the high cpu usage but I am using Connected Data's File Transporter. I also have a Synology NAS and use Cloud Station but with a different vault but am not currently seeing a problem with Cloud Station and syncing -- only the Transporter. The Transporter Sync keeps notifying me of new conflict files that are being synced so it sounds very similar.

    I'll try the similar steps to resolve as described here and see if that helps.

  • Keep us updated @MacMike :smile:

  • MacMikeMacMike Junior Member
    edited October 2015

    I decided to take what I consider a more conservative approach than deleting the entire DB although it's a bit more geeky. Although I did start by making sure all of my clocks on each Mac were synchronized as previously suggested.

    I used the Terminal and navigated to the 1Password folder and used the find command to search for files that had conflict in their filename:

    find 1Password.agilekeychain/ -name *conflict*

    What I discovered from that was that the continuous syncing loop was caused by just one entry in 1Password. So I used cat to display one of the conflict files so I could determine which entry it was:

    cat 1Password.agilekeychain/data/default/9A14D64110AF4597A0822AF2BD4666D4.conflict.99.1password

    It turns out that it was an entry that was in the 1Password Trash so I emptied the trash and deleted all of the conflict files for that entry:

    rm -f 1Password.agilekeychain/data/default/9A14D64110AF4597A0822AF2BD4666D4.conflict*.1password

    That's all it took and I've not had any recurrences since. I would caution anyone that you are own your own with this kind of solution and that you should have a good backup before attempting it -- but it didn't seem worse than deleting the DB and starting from scratch so I figured I didn't have much to lose if it corrupted the 1Password database and failed. I got lucky. Let's hope it holds out.

  • brentybrenty

    Team Member

    That is so awesome! Thanks for sharing your solution! :chuffed:

    Of course, recreating the vault is a much simpler solution, but so much less fun. I don't think this will make it into the next "series" of Sherlock, but that's a really cool example of digital detective work.

    Be sure to fill us in on the "epilogue" so we can find out how the story really ends. ;)

  • Thanks @MacMike for your response and it saves me a lot of time!

  • brentybrenty

    Team Member

    Indeed, that's neat tip. I'm glad it helped! :):+1:

  • MacMikeMacMike Junior Member

    You're welcome @saphirblanc I'm glad it was helpful and thanks for posting here to let others know. I have not experienced any problems since my original post so I think everything is likely to be okay.

    Just for the record I have over 2,200 items in my primary vault and I'm syncing with 4 computers i.e., 1 iMac, 1 MacBook, 1 MacBook Air, and 1 MacBook Pro. I also do a manual WiFi sync to my iPhone as needed.

  • Drew_AGDrew_AG 1Password Alumni

    Thanks again @MacMike! It looks like your solution is indeed helpful for other 1Password users. :)

This discussion has been closed.