Unable to enable iCloud sync after manually deleting data in iCloud

I seem to be experiencing exactly the same issue as @shellyb123 in the following post after inadvertently manually deleting my 1Password data from iCloud:


At the end of the linked thread @megan indicated that Andrew had emailed the OP with a possible fix for the problem. Would you mind please sharing the solution?

Much appreciated!

1Password Version: 5.3
Extension Version: 4.4.3
OS Version: 10.10.5
Sync Type: iCloud


  • Drew_AGDrew_AG 1Password Alumni

    Hi @ozpowell,

    I'm so sorry you're running into that problem with iCloud sync! We understand a bit more about this issue than we did a couple months ago, so it should be easier to solve it. We're more than happy to share the solution, but the steps will be a bit different depending on your exact setup, so we'll need to know a few more details first:

    • Are you trying to sync 1Password on any other Macs? If so, what exact version of the 1Password app is on the other Mac(s), and which OS X version?
    • Are you trying to sync 1Password on any iOS devices? If so, what exact version of 1Password is on each iOS device?
    • What device/computer has your most up-to-date 1Password information?
    • What exact error message(s) do you get on your Mac(s) when trying to enable iCloud sync?
    • What exact error message(s) do you get on your iOS device(s) when trying to enable iCloud sync?

    Once we know that information, we should be able to give you the correct steps to solve the problem. Thanks in advance!

  • Hi @Drew_AG and thank you for offering to help.

    I had 1Password installed and syncing my primary vault over iCloud on 2 Macs and 2 iDevices (note that I also have a secondary vault which is sync'ed over Dropbox, but I don't think that's relevant - let me know if you need more details on that).

    A Macbook Pro Retina running OSX 10.10.5 and 1Password 5.3 (530029)
    An iMac running OSX 10.10.4 and 1Password 5.3 (530029)
    An iPhone 6 and an iPad 4 both running iOS 8.4.1 and 1Password 5.5

    I have an up-to-date backup copy of my 1Password data.

    I have since uninstalled 1Password from all of my devices (including deleting the two onepassword related folders under ~/Libary/Containers).

    When trying to reinstall 1Password on my Macbook Pro (using my backup data) the iCloud syncing switch can't be turned on during the guided installation process - and I can't even enable the iCloud radio button when it asks me where my data is stored (see screenshot1 attached). If I then subsequently go into Preferences to enable iCloud syncing, I get the following error:

    "iCloud is not available. Please enable iCloud to continue." (see sceenshot2 attached)



    iCloud and iCloud Drive are definitely configured and enabled on my computer.

    Please let me know if you need any further information.


  • edited August 2015

    @ozpowell I got an email alert that I was mentioned in a post, so here I am.

    I was going to go back to my emails on how the problem was resolved and I could not find the emails, but as I remember I was running 1password on an iMac, iPad, and iPhone and in order to fix the problem I had to reinstalled 1password on my iPad first.

    I unistalled the 1password app on my iPad then did an reinstall of 1password and recovered my 1password data in the IOS format. Hopeful you have the 1password data backed up in the iPad format. I was then able to set up an iCloud sync. Then I installed 1password on my iMac and sent up a sync to iCloud, then did the same on my iPhone.

    The key was to install on the iPad or iPhone first, so basically because I deleted the 2 1password data files in ~/Libary/Containers) I was not able to initiate an iCloud sync in OS X after the 1password install, but I was able to install and sync on IOS 8.4.1 then install in OS X and sync to iCloud.

    Like @Drew_AG posted there is probably a better solution now but that is how Andrew had me do it back then and it worked great.

  • Thanks @shellyb123. Hopefully there's a solution where I can restore from a Mac format backup because that's all I've go to work with ;) .

  • pyro_x1pyro_x1
    edited September 2015

    I ran into a similar, combined iCloud sync problem on both my Mac and iOS versions of 1PW. The latest versions of the 1PW software are being used on iOS 8.4.1 and OS X 10.10.5.

    1). After changing a vault entry on Mac but noticing that it did not propagate to the iOS vault, I tried to fix it by turning sync off within the iOS app. However, after that I am prevented from re-enabling sync with the "Failed to fetch some record zones" error appearing every time.

    2). I followed by trying the same thing in the Mac (App Store) version of 1PW, turning off iCloud sync in the app Preferences, and trying to reactivate it. But subsequent attempts to turn it back on present me with the screen,

    even though both iCloud and iCloud Drive are already enabled and functional.

    iCloud sync seems to be broken on both of my platforms, and I don't know what to do from here.

  • Hey @pyro_x1 , that's exactly how I ended up in my predicament! I noticed that the latest version of 1Password for iOS wasn't propagating with my Mac version so I started trying to tinker with things to fix it. I also saw the "Failed to fetch some record zones" on my iOS devices after disabling and trying to re-enable iCloud sync.

    I also (stupidly) deleted the 1Password data from my iCloud storage from my Mac's iCloud Preferences panel, which probably made things worse in hindsight ;) .

  • Hi @pyro_x1 & @ozpowell. I've contacted both of you regarding this. We'll follow this up via email for now.

  • Also having this same issue now... Using 1Password 6 on iOS 9 on two devices, neither of which can sync to iCloud. Now my 1Password on OS X version 5.3 keeps telling me to "Enable iCloud" but iCloud Drive is enabled on both OS X systems (10.10.5)

  • Hi @fischmanr,

    Can I just confirm, did you delete the 1Password iCloud data from within the iCloud interface on either your Mac or on one of your iOS devices?

    I will happily contact you with the same details, I just want to make sure I'm not supplying the wrong advice at all. When you reply if you mention me by adding @littlebobbytables to your post the forums will notify me of your post :smile:

This discussion has been closed.