1Password 5 does not work with OS X 10.11 Golden Master Candidate anymore

edited September 2015 in 1Password 6 Beta

Hey guys,

still hungry? ;)

This time I really need some help please.

I made a clean install of the new El Capitan version today and tried at first 1Password 5.4.BETA40, then 5.3.2.

Both of them does not start. After a while and a spinning beach ball, I get a message that it is not able to connect to 1Password mini, which seems not to launch. :(

Tried Version 4.4.3 too and it's nearly the same. 3.8.22 is starting but crashes after several seconds, also I don't have an activation key for version 3. But I can see my saved logins stored in Dropbox until it crashes.

Does anyone has that issue too?

Would be nice if you can help me.

Kind regards

Edit: Sorry, there is already a thread about that. It wasn't there when I looked at first. Tried out some things and then I had to restore my password, because 1Password does not work. ;)
I also did not find it in 1Password on my iPhone, strange...

Edit 2: Now at least Version 3.8.22 seems to work. I only get an error message, when I start it. Perhaps I had to remove Version 5 completely before I should use this one. Sadly the trial time is up, because I once tested it on an old Mac.
Is it possible to get a key for version 3, if I have a Parallels bundle version I think I got Version 4 with Parallels Desktop sometime and the update to Version 5 I don't really know, where it came from... Or was it free? The e-mail address I first ordered with, does not exist anymore and I can't even exactly remember which one it was.


1Password Version: 5.4.BETA40
Extension Version: 4.4.4.b1
OS Version: OS X 10.11 (15A282b)
Sync Type: Dropbox

Comments

  • Gilles9Gilles9 Senior Member

    I had no rpoblems with 1P after the 10.11 GM update
    It continued working as it did before

    FYI

  • @Gilles9

    What Version of 1P do you use?

    I didn't update to the GM. It was a clean install on a different Mac.

  • Gilles9Gilles9 Senior Member
    edited September 2015

    Using 1P 5.4beta40
    Extension on Safari 4.4.4b1

    the GM (Mac os x 10.11) was a full installer
    I did not do a clean install ( erasing the HD (SSD))

    Have you tried reinstalling 1P and extension from scratch, after deleting 1P app (be carefull not to delete your 1P data file)

  • Tried it several times. Now i created a new user account and there it worked, switched back to mine and it finally works here too. :)

  • sjksjk oversoul

    Team Member

    Hi @ChocolateCheesecake,

    still hungry? ;)

    Might be a better question for @chrisdj and @Drew_AG? :lol:

    Starting with where you finally successfully reached:

    Now i created a new user account and there it worked, switched back to mine and it finally works here too. :)

    Interesting how that did the trick; I'm not sure why. Had you fully logged out of your original account before switching back to it?

    Here's my experience:

    Shortly after installing 10.11 GM Candidate (15A282a) on a Mac already running the Public Beta, a 1Password update notification appeared since 5.4.BETA-39 was still installed. When 5.4.BETA-40 first opened after 1Password Updater downloaded/installed it, I was greeted the same way as what you and @hwfitzjr both reported:

    Soon after quitting that, simply reopening the main app was enough to get it and the restarted mini to communicate and function normally.

    Sorry you had to jump through so many hoops to get 1Password 5 working after a clean 10.11 GM Candidate install. At least @Gilles9 has had smooth sailing. :)

    Now let's backtrack a bit into your original message:

    Tried Version 4.4.3 too …
    Now at least Version 3.8.22 seems to work.

    Do you still have those versions installed?

    Sorry, there is already a thread about that. It wasn't there when I looked at first.

    No worries!

    Perhaps I had to remove Version 5 completely before I should use this one. Sadly the trial time is up, because I once tested it on an old Mac.
    Is it possible to get a key for version 3, if I have a Parallels bundle version I think I got Version 4 with Parallels Desktop sometime and the update to Version 5 I don't really know, where it came from... Or was it free? The e-mail address I first ordered with, does not exist anymore and I can't even exactly remember which one it was.

    Not sure I follow all that, but we'll get this sorted out for you. :)

    Do you currently have a usable license for any version of 1Password for Mac or recall ever purchasing it from the Mac App Store? With a version 4/5 license or Mac App Store purchase you can get a version 3 license, but is it necessary if all your Macs can run version 5?

    Thanks in advance for that info!

  • edited September 2015

    Hi sjk,

    thank you, I don't need the lincense for version 3 anymore, everything is working fine now.

    Here is everything step by step I did (leaving the older versions out):

    • installed OS X 10.11 GM Candidate on a freshly formatted SSD

    • downloaded and installed the Dropbox application, where my license (seems to work with 4 and 5) and keychain is stored

    • downloaded 1Password 5.4.BETA-40 from your website and copied it into the application folder after unzipping

    • started 1Password, beach ball appears and nothing happened, the menu was there, but not accessible and 1P mini did not start.

    • after about one minute I forced it to quit and tried it again, same happened but I was waiting longer until the message appeared, that said to restart it and gave me a link to a help site too

    • then I deleted the application and everything I could find in the library and installed it again after a reboot, tried this several times (also with the latest 5.x non beta and the newest 4.x), but nothing helped

    • after that I deleted everything again, created a new admin account, fully logged out of mine and in there

    • then started it just where it was downloaded and unzipped without any problem, closed it before doing anything

    • switched back to my account deleted the other account, opened it from the download folder like in the other account, worked too, closed it, moved it from the download folder into the application folder and it is just working without any problems since then

    • somewhere in between that all I installed the Safari extension 4.4.4.b1

    I don't really know what the problem was. But it's working now and that's the main thing. :)

  • brentybrenty

    Team Member

    I don't really know what the problem was. But it's working now and that's the main thing. :)

    @ChocolateCheesecake: YESSS! I'm with you 100$! Thanks for the update. :lol:

    Indeed, I've seen a lot of issues with this GM candidate (kind of hoping for another), but hopefully everything works properly from here on! :pirate:

This discussion has been closed.