1P mini 4.5.0b1, opens its window when using keyboad shortcut even if only one entry possible

Gilles9Gilles9 Senior Member

Hello,

with th elatest beta, 1P mini opens its window
when i am on a site that has only one option for a password
it fills OK but the window ( dropdown from Finder's menu bar ) opens for nothing

disturbing and certainly not necessary

I reverted back to 4.4.3 and needed a restart to stop that behavior


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • sjksjk oversoul

    Team Member

    Hi @Gilles9,

    Which version of 1Password are you running and which web browser(s) is this happening with? Is this happening for every site/page you fill on? Can you give us specific steps for how to reproduce it?

    If I open http://appshopper.com/login in a single browser window, then press the ⌘\ shortcut while in the Demo vault, it fills that page normally without opening the 1Password mini window. Works that way in Safari, Chrome, and Firefox with 1Password 5.4.BETA-41 and version 4.5.0.BETA-1 of the extension. On OS X 10.10.5 and 10.11 GM Candidate (15A282a).

    Thanks in advance for the additional information!

  • Gilles9Gilles9 Senior Member

    The restart fixed it, I suppose

    seems OK now after, try again 4.5.0beta 1 extension

    If it happens again I get back to you folks
    Thanks

  • Gilles9Gilles9 Senior Member

    Well,

    it is back with 4.5.0 beta 1
    just did it with this very site https://discussions.agilebits.com

    it is the only site open ( no multiple tabs in safari )
    only one password possible,
    it fills but again the dropdown of 1P mini from the Finder's menu bar apperas for no reason

    this is with Mac Os 10.11.1 beta
    Safari 9.0.1
    1P app is 5.4 beta 41
    and 1P mini 4.5.0 beta 1

  • sjksjk oversoul

    Team Member

    Hi @Gilles9,

    Thanks for following up. Good news is that I've now been able to reproduce what you've reported:

    Only with Safari on 10.11 GM Candidate (15A282a) so far. And inconsistently, like it's been for you.

    The restart fixed it, I suppose

    What did you restart that temporarily fixed it?

    I'm doing some additional testing and filing a bug report. Thanks for catching this!

  • Gilles9Gilles9 Senior Member

    It was a restart/reboot of my Mac, but after reverting back to 4.4.3 ( as it was continuing )

    this time around reverting to 4.4.3 was enough to stop this behaviour

    thanks

    I'll wait for next 1P extension release, meanwhile I'll stick with 4.4.3 extension

  • sjksjk oversoul

    Team Member
    edited September 2015

    Not too surprising it would work okay again for awhile after a system restart. :)

    I've noticed that restarting 1Password mini doesn't stop it from happening. Restarting Safari stops it more often, but not always.

    Be sure to let us know if it does happen with 4.4.3 but at the moment it appears limited to 4.5.0.BETA-1, Safari, and 10.11.

    Cheers!

    ref: OPM-3291

  • Gilles9Gilles9 Senior Member

    It works OK now
    with 1P app 5.4.2 b2
    and Safari extension 4.5.0 b2
    under Mac os X El Capitan

  • sjksjk oversoul

    Team Member
This discussion has been closed.