Dropbox sync continue button does not do anything.

Hi,

When adding a dropbox folder the continue button becomes enabled but no action is done when clicking it.
I checked the mini log and I see the following errors when trying to press continue.

2015-09-21 11:57:51,891 XXXXXXXXXX.com.agilebits.onepassword4-helper[1996]: connection from pid 1994: Warning: Exception caught during invocation of received message, dropping incoming message and invalidating the connection.
Exception: *** -[__NSSetM addObject:]: object cannot be nil

2015-09-21 11:43:14,980 1Password 5[1994]: 540041 [XPC:(Secondary Thread XXXX):] E handleXPCError: | Problem talking to the helper: Error Domain=NSCocoaErrorDomain Code=4097 "Couldn’t communicate with a helper application." (connection to service named XXXXXXXXXX.com.agilebits.onepassword4-helper) UserInfo=XXXXXXXXXX {NSDebugDescription=connection to service named XXXXXXXXXX.com.agilebits.onepassword4-helper}

Thank you


1Password Version: 1Password 5 Version 5.4.BETA-41 (540041) Agile Bet
Extension Version: Not Provided
OS Version: 10.10.5 (14F27)
Sync Type: Dropbox

Comments

  • Hello @Jarro,

    So you're selecting an empty folder in Dropbox with the intention of having 1Password create a new Agile Keychain, is that correct?

    Even seeing the Continue button is wrong. The Continue button should only ever exist in a disabled state as if you select an empty folder and 1Password believes it needs to create a new Agile Keychain the button changes to Create New, if you point 1Password to an existing Agile Keychain it changes to Merge With Existing.

    Can you see if a reboot of the Mac cures this at all. It might sound silly but you'd be amazed what a reboot can sometimes resolve. Obviously if it doesn't have any impact we'll need to examine further including seeing if the stable version of 1Password for Mac has the same problem. Please do keep us updated.

  • Hello @littlebobbytables,

    The folder I am selecting is not empty, it contains a agilekeychain file.
    There are several people at my office using the same 1pwd setup as me, strangely this does not work for me.

    I have tried rebooting and re-installing 1password but it has no impact.
    If I would select an empty folder it seems to work as it should, displaying the Create New button.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @Jarro,

    Since you're using a beta version of 1Password for Mac, I've moved this discussion to our Mac Beta forum. I hope you don't mind!

    If I would select an empty folder it seems to work as it should, displaying the Create New button.

    When you do that, are you able to click the Create New button? If you haven't tried it, please see if that works (if it does, you can disable Dropbox sync and delete the new .agilekeychain file you just created).

    After doing that, try setting up Dropbox sync again. Click the Choose button, then choose the .agilekeychain file you're trying to sync with (double-click it, or select it and click Open). At that point, do you see the Merge with Existing button, or does it still show an (unresponsive) Continue button? If you see the Merge with Existing button, does it work?

    If it's still a problem, can you make sure you're using the latest beta? We just released 5.4.BETA-42 a day or two ago. Please let us know if that helps at all, thanks!

  • Hi @Drew_AG,

    I am using the latest beta since yesterday.
    So I have tried the following steps and I can create a new file.
    I'm also able to disable sync and (merge with existing) with the new file I have just created.

    But the problem still remains with the file I am supposed to sync with, still an unresponsive continue button.

  • sjksjk oversoul

    Team Member

    Hi @Jarro,

    Thanks for testing syncing with a new Agile Keychain and letting us know that worked okay. Sorry you're still having trouble with the one you really need to sync with.

    So we can better understand what's happening, please recreate the problem again and take a screenshot of where it's getting stuck, then remove or mask out any sensitive details from it. Next use the 1Password Troubleshooting tool to generate a Diagnostics Report:

    https://support.1password.com/diagnostics/mac.html

    Attach the report file and screenshot with an email to: [email protected]

    Please do not post your Diagnostics Report in the forums, and do include a link to this discussion and your forum username in the email.

    You'll receive an automated email reply with a support ticket ID. Please post that ticket ID here so we can track down your email more quickly. We'll look that over and get back with you to suggest what to do next to fix the problem.

    Thanks in advance!

This discussion has been closed.