Since updating to WatchOS2 / iOS 9, "requires Pro features" [reinstall the app]

edited September 2015 in Apple Watch

I have version 1Password 6, iOS 9 and Apple WatchOS2 and when opening the app on the Watch, I get a message that I need the Pro version features. I do have the Pro version and I have added items from the iPhone to the watch but I just get the same message and I am unable to access any of the items on the watch.

1Password Version: 6.0
Extension Version: 4.4.3
OS Version: 10.10.5
Sync Type: iCloud
Referrer: kb-search:Apple Watch, kb:pro-features-faq


  • brentybrenty

    Team Member

    @FrankM7885: Argh! Me too! Sorry for the trouble. iOS isn't validating the purchase correctly, unfortunately. In most cases, you can resolve this simply by uninstalling 1Password from your Apple Watch and then reinstalling it. But if the problem persists, backup your data, and then reinstall 1Password for iOS completely (I had to do this a few times myself). Please let me know how it turns out! :)

  • I tried uninstalling the 1Password from the watch a few times and uninstalled it from the iPhone but no luck. Same message still.

  • Me too

  • brentybrenty

    Team Member

    @FrankM7885: Indeed, as I mentioned in my previous post, you may have to uninstall 1Password for iOS completely if simply reinstalling it on your Watch did not coax iOS into validating your App Store purchase. Please try that and let me know if that helps!

  • User error in the end for me. I had uninstalled it from the watch and the iPhone but when I reinstalled it on the phone, I forgot to enable the watch. I had not noticed that the "Enable Apple Watch" was not turned on.
    I turned that on and the pin code and it worked again after that.
    So it seems that one needs to uninstall both and then reinstall them to both before it works again, along with the obvious thing as mentioned above.

  • chrisdjchrisdj AgileBits Support

    Team Member

    @FrankM7885 Great to hear it is resolved! And yes, there is a bit of setup to do on a fresh install to tell 1Password you want to send data over to the Apple Watch. I'm glad you're all good to go!

  • Hey guys . . . I, too, have previously posted about this. I specifically bought ProFeatures to use with my Watch. When it was under WatchiOS1, the response from AgileBits was "wait until WatchiOS2". Now, I have iOS2, and it is still not working. I have tried your aforementioned suggestions too many times to count. If you guys can't fix this, is a refund in order? Thank you.

  • chrisdjchrisdj AgileBits Support

    Team Member
    edited September 2015

    Hi @anbollin, I'm sorry this still isn't working for you. Let's dig into this again. Can you refresh my memory on whether or not you've tried reinstalling the iOS app itself?

    Also, if you do decide to seek a refund, you will have to do so via Apple. We have zero access to their purchasing system, therefore we have zero ability to issue refunds ourselves for purchases through the App Store, such as Pro Features.

  • After several cycles of uninstall/re install on my iphone and apple watch, I've given up trying for now. My iphone has recognized I have Pro Features, but my watch says no. I hope you can fix it soon.

  • brentybrenty

    Team Member

    @vickurc: Very frustrating. Believe me, I feel your pain!

    I actually went through a similar ordeal with a few other apps just last night (technically this morning...) after my last reply. It seems that every app I'd installed prior to the watchOS 2.0 update was broken in some way afterward. Freshly installed apps (so far) haven't seemed to suffer a similar fate. Stop yer grinning' and drop yer linen — and connect your Watch to power — because this may be an ordeal for the both of you! There may be a simpler approach, but I wasn't able to find it, so this is what I did to get my apps working again:

    1. Uninstall the app individually on your iPhone in the Watch app
    2. Wait for it to stop saying "Uninstalling..." (this may never happen, but give it at least 5 minutes, and then move onto the next step regardless) :unamused:
    3. View the apps on your actual Watch and verify that it is really gone! In my case, even those that completed "Uninstalling..." on my iPhone still showed up on the Watch. :(
    4. If it's still there, hold your finger on it until the (x) appears. Then try to tap it. Good luck! In many cases, even when I was able to tap that tiny (x), the app icon remained... :cry:
    5. Regardless of whether or not you're actually able to delete the app, hold the Side Button (the pill-shaped one, not the Digital Crown) and Power Off the Watch.
    6. Open 1Password on your iPhone and turn off Apple Watch (in Settings > Apple Watch > Enable Apple Watch)
    7. Hold the Lock Button on your iPhone and Slide to Power Off
    8. Power on both Apple Watch and iPhone
    9. Enable Apple Watch in 1Password on the iPhone
    10. Install the app in Watch on the iPhone
    11. Say a little prayer to science, or your deity of choice

    In my case this did the trick after every Apple Watch app either never finished "Uninstalling..." or still showed up on the Watch anyway. Based on my, er...experiences with Bluetooth on my Mac, I wonder if there's a deeper communication issue at fault here. Like I said, it isn't entirely clear what happened during the update process to mess things up, so some of these steps may be superfluous. But this was what worked for me finally after about an hour of fiddling with it in the wee hours of the morning. Ultimately, it may be necessary to go to more extreme measures like a factory reset (perhaps after contacting Apple to see if there's a simpler way to get App Store purchase receipts to transfer correctly to the Watch, of course), but in my case this was all I needed to do (ha!) to get all of my apps working again. ;)

    Please let me know how it turns out. I look forward to hearing back from you! :eh:

  • Thanks for the hard work.....but, no joy. Tried it 3 times with no success. By the way, on my phone The settings icon has a red "3" on it, but I cannot find any items it might refer to. Any ideas?

  • Kept on trying. I answered my question about the red 3 (new messages) and in the process I found the comment about _selecting the items I wanted at the bottom of the iphone entry with a new button "add to Apple Watch" on each item_.** I think you need to add this vital information somewhere in your instructions. I think several (all but the last) trys missed this key bit. Once I did it, passwords, etc appeared as promised.

  • brentybrenty

    Team Member

    @vickurc: Sorry for the confusion! Since this is a discussion about getting 1Password to work on Apple Watch in the first place, explaining how to add items to it wasn't something we had in mind...since this information won't do you any good if you can't get to that point to begin with! You can learn about 1Password for iOS and Apple Watch in more detail from our user guide:

    1Password for Apple Watch (Pro Feature)

    It sounds like it's working for you now, which is great; but be sure to let us know if you have any other questions! :)

This discussion has been closed.