Generic icons since upgrade to WatchOS2

golfsierragolfsierra Junior Member
edited September 2015 in Apple Watch

I use my OTP on my watch and since the upgrade to watchOS2 the login items only show the generic items. Prior the update the correct site icons were shown... e.g. Google, MailChimp, Outlook ...


1Password Version: 6.0.1
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @golfsierra: Do you mean you're only having this icon issue with TOTP items...or that you only have TOTP items on your Watch in the first place?

    The correct icons are showing for me, but then again none of the apps on my Watch worked initially after the update. Please try the following:

    1. Uninstall 1Password on your iPhone in the Watch app
    2. Open 1Password on your iPhone and turn off Apple Watch (in Settings > Apple Watch > Enable Apple Watch)
    3. Restart both Apple Watch and iPhone
    4. Enable Apple Watch in 1Password on the iPhone
    5. Install the app in Watch on the iPhone

    I hope this helps. Please let me know how it turns out! :)

  • golfsierragolfsierra Junior Member

    Hi @brenty,

    I did what you asked me to do but it did NOT solve the problem.
    To make it clearer: I have 6 items on the AppleWatch:

    • 1 Credit card
    • 4 logins WITH OTP in them
    • 1 login WITHOUT OTP item

    The credit card item and the one WITHOUT OTP show the correct icon.
    The 4 logins WITH OTP only show the generic "keyhole"-icon.
    When I open one of these 4 (to see the OTP) I SEE the correct icon and the OTP

  • brentybrenty

    Team Member

    @golfsierra: Ah, thank you for clarifying!

    When I open one of these 4 (to see the OTP) I SEE the correct icon and the OTP

    So it's just in the list view where you see the generic icons? The site-specific icons display correctly in the item details? If you open 1Password on your iPhone, are the icons for these particular items displayed correctly? I'm trying to determine if it's limited to the Watch, or if it's affecting 1Password for iOS in general.

    If the icons are being displayed correctly in 1Password on your iPhone, please remove one from Apple Watch, let this change sync, and then re-add it to see if that refreshes the data there. It sounds like something may have happened with the image cache in the update. On its face it's confusing that the credit card icon would persist...but of course that's not specific to that particular card. Please let me know what you find! :)

  • golfsierragolfsierra Junior Member

    Yes, that's only in the list view...
    It seems to be a WATCH RELATED problem because on the iPhone the icons show up correctly.

    I removed one and resynced it... No change

  • chrisdjchrisdj AgileBits Support 1Password Alumni

    Hi @golfsierra! I wonder if the Rich Icons need to be purged and re-downloaded. In 1Password for iPhone, please go to Settings > General, and toggle Show Rich Icons to Off. Now, toggle it back On and wait a moment for the Rich Icons to download.

    Now fire up 1Password for Apple Watch and see if it now has the Rich Icons back.

  • golfsierragolfsierra Junior Member
    edited September 2015

    Nope, no change...
    As mentioned before, all icons work EXCEPT logins which include a OTP ... I just duplicated one of them and deleted the OTP ... The icon is shown correctly then ...

  • chrisdjchrisdj AgileBits Support 1Password Alumni

    @golfsierra I think I have this one reproduced with OTP items. I'll run it past development.

  • brentybrenty

    Team Member
    edited September 2015

    @golfsierra: I just wanted to update the thread to let you know that the devs have identified the cause and are working on a resolution.

    Something that didn't occur to me initially but makes perfect sense is that these are separate TOTP items which we send to the watch — not a Login item, since we're not sending the whole thing over. So while it's displayed correctly in the Login item on the iPhone, a separate check for the custom icon needs to be done for the TOTP item which is sent to the Watch.

    Don't ask me why my TOTP items are still displaying correctly though. That may just be some of the watchOS weirdness that usually causes issues inadvertently being of benefit in this case. :lol:

    Thanks again for bringing this to our attention. We'll get this fixed for you! :chuffed:

    ref: OPI-3089

  • golfsierragolfsierra Junior Member

    6.0.2 doesn't solve the problem

  • brentybrenty

    Team Member

    @golfsierra: Indeed, I assumed it didn't since the release notes made no mention of icons for TOTP items, but I'll double check with the development team to be sure.

    I suspect it will show up in the betas first...and even then it is often necessary to reinstall the app on the Watch. They don't seem to always update. I'll get back to you on that! :)

  • I'm experiencing the same, and have photos if they'll help.

  • brentybrenty

    Team Member

    @finch106, @golfsierra: Hey! I'm back! As promised, I did double-check this, and the fix is currently in beta. So the release notes are correct: 6.0.2 doesn't have a fix for the icons for TOTP items, as I suggested in my previous post, since that version was in testing prior to the previous beta. Sorry for the confusion!

  • golfsierragolfsierra Junior Member

    Hi guys,
    Seems that 6.1.1 finally solved the problem... The icons of the OTP entries are finally back again...

    Greetings

  • brentybrenty

    Team Member

    Interesting. Thanks for confirming! It was fixed earlier, but it may be that iOS didn't update the app on the Watch sooner for some reason. Glad to hear you've got your icons back! :chuffed:

This discussion has been closed.