Opera extension failing -- code sig. verification [use 127.0.0.1 proxy bypass, for GlimmerBlocker]

cjbulowcjbulow Junior Member
edited September 2015 in 1Password 6 Beta

I'm seeing this

Diagnosis: If you see this error message, 1Password is letting you know that it failed to verify the authenticity of your web browser.

The various fixes suggested in the article here: https://support.1password.com/invalid-code-signature-osx/ have all been tried (barring turning off browser code signature validation which I'm loathe to do). Any other suggestions?

The sites fill successfully in Safari & Chrome. Removing the 1PW extension, re-starting Opera & re-installing also fails to resolve this.


1Password Version: 5.4 beta 42
Extension Version: Version 4.5.0.1
OS Version: OS X 10.11.1
Sync Type: Dropbox

Comments

  • cjbulowcjbulow Junior Member

    Forgot the Opera version number: 32.0.1948.25 -- the stable release stream, unusually for me.

  • sjksjk oversoul

    Team Member

    Hi @cjbulow,

    So far I'm stumped by this if indeed you've gone through everything you mentioned without success. Have you also tried reinstalling Opera?

    … (barring turning off browser code signature validation which I'm loathe to do).

    If there's no difference after reinstalling Opera, would you be able to temporarily disabling browser code signature verification and test filling with, say, a Demo vault or other meaningless item? And if that works, then re-enable browser code signature verification and retry the test.

    We'd like get a Diagnostics Report from you if you'd rather not disable browser code signature verification at all or if temporarily disabling, then re-enabling it, doesn't help.

    Thanks!

  • cjbulowcjbulow Junior Member
    edited September 2015

    Hi @shk.

    Thanks for the follow-up.

    Just re-checked the trouble-shooting tips and confirm that I undertook them all (where appropriate i.e. non-Chrome ones).

    Steps since taken:
    (1) re-installed Opera
    (2) disabled, tested, then re-enabled and tested

    Still seeing the code signature error.

    Have just sent email with the diagnostic reports results, referencing this thread Ref: [#ZJP-76448-966]

  • cjbulowcjbulow Junior Member

    Thanks to Greig in the support team, for the pointer -- it looks like Glimmer Blocker is the culprit; disable that and the Opera extension works OK again. Which is a real shame, as I like the functionality that the former brings but can't do without the latter...

  • cjbulowcjbulow Junior Member

    And more thanks to the team -- this time for reminding me of the proxy bypass setting. Add localhost (127.0.0.1) to that, and all is sweetness & light again and Glimmer Blocker and 1PW extensions start happily co-existing.

  • sjksjk oversoul

    Team Member

    You're most welcome, on behalf of Greig and Marshall who helped you with an optimal solution for this problem. :+1:

    Seems step 4 of the Troubleshooting checklist for how to resolve “code signature could not be verified” wasn't helpful enough?

    4. Do you use a firewall or a tool such as Sophos?

    Maybe we could add some other examples besides Sophos. A subitem does refer to the guide that Marshall suggested in email:

    • To learn how to configure your firewall, see this guide: Configuring a firewall or proxy server.

    I'd even forgotten about that one. :)

    … all is sweetness & light again and Glimmer Blocker and 1PW extensions start happily co-existing.

    Pleased to hear it, Chris!

    ref: ZJP-76448-966

  • cjbulowcjbulow Junior Member

    Yup; I knew it was an http proxy (it's even stated in the Glimmer Blocker setup screen for the hard of thinking such as I) -- but a complete brain fade and a speed read of that line 4. meant that I'd missed it.

  • AGMarshallAGMarshall 1Password Alumni

    @cjbulow Glad we could get things sorted out via email and all is good in the world. Or at least with GlimmerBlocker! ;)

This discussion has been closed.