Apple watch missing pro features

Hi - Your FAQ states: "Anyone who purchased 1Password 4 for iOS or unlocked Pro Features in 1Password 5 for iOS gets Pro Features in 1Password 6 for no charge. Simply upgrade to iOS 9 and update 1Password from the App Store, and the Pro Features will automatically be unlocked."

I have a licensed version of 1P on iPhone 6 and have upgraded to iOS9; apple watch also upgraded to OS2. Watch still says "requires pro features".

I searched knowledge base and don't see similar question. I tried removing the app from the watch and adding it back again and still have the same issue.

Bhavani


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:pro features

Comments

  • brentybrenty

    Team Member
    edited October 2015

    @bhavani55: I'm sorry to hear that. I've seen a lot of issues like this across the board after updating to watchOS 2.0. I've had to reinstall all the apps there completely at this point. It seems that something isn't carrying over properly after the update. :(

    To be clear, you'll need to have installed 1Password for iOS itself using the correct Apple ID for Pro Features to be able to restore the purchase there in the first place (1Password Settings > Pro Features > Restore). Double-check to verify that it's showing as purchased there in the first pace, as otherwise it simply won't work.

    Next, make sure that 1Password Settings > Apple Watch > Enable Apple Watch is on.

    Edit: Finally, you need to choose Add to Apple Watch for each item you want to show there.

    If you're still having trouble after confirming that those things are set up correctly, follow these steps to reset and reinstall it completely (but be sure to connect to power first, as this can be huge drain!):

    1. Uninstall the app individually on your iPhone in the Watch app
    2. Wait for it to stop saying "Uninstalling..." (this may never happen, but give it at least 5 minutes, and then move onto the next step regardless) :unamused:
    3. View the apps on your actual Watch and verify that it is really gone! In my case, even those that completed "Uninstalling..." on my iPhone still showed up on the Watch. :(
    4. If it's still there, hold your finger on it until the (x) appears. Then try to tap it. Good luck! In many cases, even when I was able to tap that tiny (x), the app icon remained... :cry:
    5. Regardless of whether or not you're actually able to delete the app, hold the Side Button (the pill-shaped one, not the Digital Crown) and Power Off the Watch.
    6. Open 1Password on your iPhone and turn off Apple Watch (in Settings > Apple Watch > Enable Apple Watch)
    7. Hold the Lock Button on your iPhone and Slide to Power Off
    8. Power on both Apple Watch and iPhone
    9. Enable Apple Watch in 1Password on the iPhone
    10. Install the app in Watch on the iPhone
    11. Say a little prayer to science, or your deity of choice. Hopefully it will install successfully and the purchase will have transferred correctly as well!

    Please let me know how it turns out! :)

  • Hi
    I finally got some time to go through the steps you provided.

    • Pro Features shows 'Purchased'!
    • 1Password Settings > Apple Watch > Enable Apple Watch was not enabled! So - I enabled it
    • I thought this would do it, but did not work; tried a few things by turning the phone, watch off and on again; the only change was that the iPassword app on the watch asked me to enter PIN code, but told me 'pro features' required
    • So - I followed steps 1 through 11; worse than before. Keeps spinning and the app does not come up and eventually times out!

    Lord Ganesha does not seem to care for 1Password!

    Bhavani

  • brentybrenty

    Team Member

    Keeps spinning and the app does not come up and eventually times out! Lord Ganesha does not seem to care for 1Password!

    @bhavani55: I'm sorry you're still having trouble! Unfortunately sometimes it simply takes a bit for apps to sync over completely. And there just isn't any way to really troubleshoot this. Essentially, watchOS is a bit of a black box. Apps can't install themselves or transfer their data. This is managed entirely by the OS. Eventually it should just load as expected.

    Sometimes simply using other apps will remove those previously loaded from memory, and upon opening again will launch fresh. Additionally, restarting the Watch can help as well. I've found that the initial launch of any given app often results in this 'spinning' behaviour, and then once it finishes loading completely, relaunching it later will be much smoother.

    But since you mentioned the "requires Pro Features" message previously, I thought I should ask this, just to be sure: have you edited any items to Add to Apple Watch? If not, you'll also see the "requires Pro Features" placeholder image, similar to the Yahoo! Weather app's default image, which is what I see most of the time when launching the app. If the Yahoo! Weather app doesn't have any data, it will show this:

    Likewise, if the 1Password app doesn't have any data, it will show this:

    This could mean that the OS hasn't transferred anything yet, or that no items have been added in the first place. Watch apps have no way of knowing why they don't have data, only that they don't; so be sure that you've added items to to it first, and let me know what you find. :)

  • Duh! That was it! I didn't know I had to add items individually to Apple Watch!

    Like you said it took a few tries of spinning and Finally I got the message about 'pro features'.

    All solved now! Works great!

  • brentybrenty

    Team Member

    @bhavani55: Ouch. That's my fault then! I'd accounted for literally everything but that in my original troubleshooting instructions. That should be step 1 (I'll edit it to reject that, for future generations). I'm really sorry about that. :(

    I am, however, glad to hear that that did the trick for you. We were running out of options there! Thanks so much for the update, and your patience working with me on this. I'm excited that it all worked out in the end. Be sure to reach out if you need anything else! :)

  • The 10 steps that brenty posted September 26 and edited October 31 worked for me.

    Thank you for posting this solution.

    I did not need step 11 this time :)

  • brentybrenty

    Team Member

    Haha that's great to hear! Thanks so much for letting me know that worked for you too! :lol:

This discussion has been closed.