Unable to effectively install 1Password Safari Extension under Yosemite

Dear support team,

I have a similar issue as the one experienced by user aramburo on Oct 2014.
I have 1 password on my macbook pro from more than one year and since 1 week Autofill suddenly does not work.
When I open1 password mini, I got an option "add Safari extension". I download and then click install....then there is no other window appearing. However at this poiint Autofill works. If I close Safari and then re enter I have the same issue.
Moreover 1password safari extension never shows in the Extensions panel under System prefrences.

Yosemite 10.10.5
1 password 5.3 MAcApp store

I tried to check the proxy Http settings but when I select Proxy Http under Preferences/Network/Proxy there is no host and/or domain that shows in the lower window.
I have Firewall disabled and do not have any anti virus.
I also followed the procedure to move the Folder "Extension" out of the system folder Library/Safari. After I re install the Safari extension (no windows shows after I double click install) the autofill functionality works until I get out of Safari. When I re enter Safari I have the same issue.

Thanks


1Password Version: 5.3 Mac App store
_Extension Version:
Not Available
OS Version: 10.10.5
Sync Type: iCloud

Comments

  • Hi @pass_store,

    You mention removing the Extensions folder from Safari but did you also remove entries in your OS X keychain?

    In the past I've found this has often helped. The exception is if permissions over your OS X user account are badly damaged but we don't want to go there just yet. If you follow all of this does it help?

    Wiping Safari's extensions

    To start make sure Safari is not opened.

    Preference plist

    1. Open a Finder window and use the keyboard shortcut ⇧⌘G to open a Go to the folder window.
    2. Use the following location ~/Library/Preferences/com.apple.Safari.Extensions.plist and click the Go button.
    3. Drag the highlighted file to your Trash.

    Extension files

    1. Like above, open a Finder window and use the keyboard shortcut ⇧⌘G to open a Go to the folder window.
    2. Use the following location ~/Library/Safari/Extensions/ and click the Go button.
    3. Drag the highlighted folder to your Trash.

    Safari Extensions List

    1. Launch Keychain Access which you can find in /Applications/Utilities/.
    2. Search on the word safari and you should have 3 entries in the results.
    3. You want to right click on Safari Extensions List and select the Delete "Safari Extensions List" option.

    After all of that reboot your Mac and you'll need to go through the steps of installing your extensions again. With a little luck whatever got messed up was in there and the 1Password extension will now properly load

    Let us know how you get along.

  • edited September 2015

    Thanks so much.

    I followed the instructions and now Autofill seems to work without any discontinuity.

    The only thing is that I cannot see the extension listed under System Preferences/Extension.
    This does not impact functionalities but does not allow to identify the version of the extension installed.

    I will keep on testing in next days and will revert in case the issue should occur again.
    Kind regards

  • Greetings @pass_store,

    Glad we managed to get it behaving. As for how to check what version of the extension is installed the place you want to look at is actually within Safari's preferences. In Safari use the menu option Safari > Preferences... and then switch to the Extensions tab, you should find what you're looking for :smile:

This discussion has been closed.