Having trouble restoring 1Password data from Time Machine

noblenoble
edited November 2015 in Mac

My Mac hard drive crashed and died. After when I tried to sync my 1password to my file on dropbox I was missing many items. It appears as if the dropbox file never synced up with the most recent 1password file. I have Time Machine backups. Do you think the old file could be there?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Please tell us what version of 1P for Mac you were using. The reason we need to know is that the 1P data files will be in different places depending on the version number,

    In the meantime, if you were using 1P4 or 1P5 this knowledge base article should help you find the data in your Time Machine backups:

    Where does 1Password store its data?

    Stephen

  • brentybrenty

    Team Member

    @noble: Indeed. While there's no guarantee, we can certainly at least point you in the right direction if we have some basic information about your setup. Thanks in advance! :)

  • Thank you. I was using the latest version of El Capitan for Mac. I believe it was the most updated version of 1password, but I cannot be certain.

  • brentybrenty

    Team Member

    @noble: On the Time Machine backup drive, you'll need to go to the following location:

    /(username)/Library/Application Support/

    and copy the 1Password 4 folder to your Desktop. Then copy and paste it to the equivalent location on your boot drive. Finally launch 1Password and it will find your vault in the support folder, and you'll be good to go! Please let me know how it turns out! :)

  • Thank you, but I could not find a folder in the Library of Application Support. Only had Applications and inside there, no Application Support.

  • The path you are looking for is /(your user name)/Library/Application Support. In other words, the Application Support folder isn't inside the Applications folder. Does that help?

    Stephen

  • brentybrenty

    Team Member

    @noble: Indeed. You can also do this in Finder by pressing ⌘ ⇧ G (Command Shift G) to navigate directly to the folder. I hope this helps! :)

  • Interestingly enough if I follow your exact instructions I do not have a Library Folder under my username. If I open the time machine backup and I get the Library folder first then inside has the Application Support Folder, but there is no 1password folder inside so I am still miffed.

  • brentybrenty

    Team Member

    @noble: Did you use the shortcut I suggested? By default, the Library folder is hidden on recent versions of OS X, so that may be the only way to get there in Finder. Let me know what you find! :)

  • I tried the shortcut and nothing happens, I just get an error sound from my Mac.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @noble,

    There are a couple things that I think might be causing some confusion here, and I apologize for that. The location of your 1Password backups will be a bit different depending on whether you were using the Mac App Store version or the AgileBits Store version of 1Password:

    Mac App Store version:

    ~/Library/Containers/2BUA8C4S2C.com.agilebits.onepassword-osx-helper/Data/Library/Backups/

    AgileBits Store version:

    ~/Library/Application Support/1Password 4/Backups/

    Please note the ~ indicates your Mac user folder, which is located here: Macintosh HD/Users/_[your Mac user folder]_/

    The reason you're having trouble finding your ~/Library/ folder (i.e. the one in your Mac user folder) is probably because Mac OS X hides that folder by default. That also makes it a little tricky to find it in Time Machine, but we can help you with that. You can follow these steps to find your 1Password backups in Time Machine:

    • In the Finder, click the Go menu and select Go to Folder
    • Copy and paste (or type) the following line into the Go to the folder field: ~/Library/
    • Click the Go button (this should open your username/Library folder)
    • Now click the Time Machine icon in your Mac's menu bar, and select Enter Time Machine
    • Using the up/down arrows next to the open window in Time Machine, go back to the date that should have the backups
    • In the Library folder (which should be open), navigate to one of the following locations:

    If you were using the Mac App Store version of 1Password:

    /Containers/2BUA8C4S2C.com.agilebits.onepassword-osx-helper/Data/Library/Backups/

    If you were using the AgileBits Store version of 1Password:

    /Application Support/1Password 4/Backups/

    You can restore one or more of those backup files, or the entire Backups folder. If you haven't setup 1Password again on your Mac yet, you'll have the option to restore from a backup when you go through the setup, as described in this section of the User Guide.

    On the other hand, if you already set up 1Password, you can open the 1Password app and go to File > Restore. If you don't see the backup files you restored from Time Machine, click Find Backup, then select a backup file.

    Please let us know how it goes. If you run into any trouble, just let us know exactly what happens, and we'll continue from there. Thanks!

  • I do not have a Time Machine icon in my menu bar so I cannot get past this step. I think if you offered some live help we could resolve this in a matter of minutes rather than months to get my password up and running again. This is becoming extremely frustrating and wasting a lot of time.

  • Well I figured out how to get the Time Machine Icon on my menu bar, but does not have a back up that shows up within Time Machine other than today although I can find the folder on my external HD

  • I should also mention I never actually did a restore from the Time Machine because I wanted to select the programs to restore

  • Hello @noble,

    Time Machine is incredibly useful given how easy it is to use as long as you use it as Apple expect you to. That's the key part. The make it easy to initialise a new Mac using a Time Machine backup from another Mac, they make it easy to selectively restore files from backups made on this Mac but they don't make it easy it selectively download files from a backup from another Mac - the very scenario you are in if I've read this thread correctly. If you're wondering OS X can tell thanks to Universally Unique IDs (UUIDs) and likely does it as multiple Macs can backup to a single disk. After all, the last thing you would want would be Time Machine on one Mac trashing the backup from another.

    It seems you've discovered how to get the Time Machine icon in your menu bar. If you open the menu and before selecting any option you hold down the alt key you will see two menu options change. The one you're interested in is Browse Other Backup Disks.... This will allow you to select another Time Machine backup and then hopefully recover the files you're interested in. Sadly the best guide I've ever found on this subject is inaccessible at the moment, I'm really hoping it's a temporary glitch as it's the guide that everybody refers to on discussions.apple.com. You may find you can't restore back to the original location and instead will find it easier to copy the entire 1Password support folder to your Desktop where we can assist in using that recovered data. From within the Time Machine interface you should find you can right click on the folder and there will be an option titled Restore "xxxx" to... which will allow you to copy an entire folder to wherever you want.

    At this point we're back in an area we're more comfortable with and as long as that restored folder has a vault or backup we can use that to get 1Password going again.

    When viewing your backup from the previous installation of OS X please note the following.

    There exists:

    • /System/Library/
    • /Library/
    • ~/Library

    The first two are red herrings and won't contain your data. The last is the important one but won't make sense unless you understand the significance of the tilde.

    Say my OS X user account is called LittleBobbyTables. When I tell OS X to go to ~/Library/ it translates that to /Users/LittleBobbyTables/Library/ and we use the ~ because we never know what somebody called their user account. OS X always correctly handles ~ so we don't have to. This breaks down when looking at what is essentially a copy of OS X from a different viewpoint. So let's assume your user account on your old hard drive was called noble. You would then need to look for Users/noble/Library/Application Support/1Password 4/ or Users/noble/Library/Containers/2BUA8C4S2C.com.agilebits.onepassword-osx-helper/. I hope that all makes at least some sense and we'll wait to hear back from you.

  • Thanks for the explanation, but I could not find these folders. I am about to give up as this is just too many steps for such a simple thing. How do I ensure it is properly syncing on both the desktop and android device so this mess doesn't happen again?

  • brentybrenty

    Team Member

    @noble: Understood. I suppose it would be simpler if you could find the folders in your backup, but that's easier said than done. To avoid sync mishaps going forward, just double check that 1Password on each device is pointing to the same vault in Dropbox. It's as simple as that.

    For example, my (main) vault is (Dropbox)/1Password/1Password.agilekeychain. I have all of my devices use this vault so changes sync between all of them. I hope this helps! :)

  • I just did a Migration from my external hard drive and got the file from there. That worked

  • brentybrenty

    Team Member

    Awesome! Thanks for the update. Indeed, Time Machine excels at full backups and restores, so that's an inventive way to get your data back. I'm glad to hear that all is well. Cheers! :)

This discussion has been closed.