Moving 1Password 3 to a new Mac.

I purchased 1Password 3 for Mac from AgileBits on January 2, 2012 with this same e-mail address and I have the license number. Now I bought a new Mac and want to transport the program to it. What do I do?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • @JonSchiller as your post relates to 1P3 for Mac I have moved the post from the 1Password for Mac forum to the 1P3 legacy forum where you will get more help.

    Stephen

  • Hi @JonSchiller,

    If you've purchased a new Mac it would seem likely that you'll be running OS X 10.11 AKA El Capitan now. As such you would want to read our thread 1Password 3: Modern browsers and OS X. The important part is that you copy your current Agile Keychain over. Now in 1Password 3 the Agile Keychain is your vault while in 1Password 5 it has been repurposed as a sync container. It is enough to set up 1Password 5 though and import the contents into the new vault format. If you happen to already use Dropbox then some of the work is done for you already. This page, Sync existing Dropbox data is for 1Password 5 for Mac but after reading the first thread I linked you to you'll understand why 1Password 3 for Mac isn't really viable any more and what options you have moving forward.

    Hopefully some of this helps but please do ask more questions if there is a particular aspect that you feel I haven't covered or if you have any follow-up questions.

  • So my version on my old Mac is 3.8.22. If I purchase the update to 1Password 5, shall I do that on my new computer or the old one? Will it then import the contents from this old version ok?

  • Hi @JonSchiller,

    It seems likely that your old Mac may not be able to run 1Password 5 and that you are best to download 1Password 5 directly onto the new Mac and we'll use the Agile Keychain from your other Mac to kick start 1Password 5.

    Do you synchronise your vault in 1Password 3 to Dropbox? If you do when you launch 1Password 5 for the first time on the new Mac it will look in Dropbox and should simply find your existing vault. You would type in your current Master Password and you should simply see the contents as you're used to.

    If you don't currently sync to Dropbox then we'll need to copy the Agile Keychain over to the new Mac.

    1. Open a Finder window on the old Mac.
    2. Use the keyboard shortcut ⇧⌘G to open a Go to Folder... windows.
    3. Paste in the following path, ~/Library/Application Support/1Password/ and click the Go button.
    4. You should see a 1Password.agilekeychain in this folder, copy it to a pen/flash drive or external drive, whatever you have so we can copy it to the new Mac.
    5. Launch 1Password 5 on the new Mac and use the steps detailed in Using existing 1Password data on a new computer: Elsewhere on your Mac to point 1Password to the Agile Keychain you've just copied across.

    Hopefully that clarifies matters a bit but as before, please do keep asking questions if you have any :smile:

  • Thank you, I bought the upgrade and copied the info to my new computer. Only problem is, though all the websites are there, when I double-click on one, it goes to the website but doesn't autofill andrecognize my username and password. Do I have to enter them all over again?

  • JacobJacob

    Team Member

    @JonSchiller It sounds like you just don't have the browser extension installed. Just head over to our extensions page and grab the appropriate one for your browser and you should be all set to open and fill, or just fill, or do whatever works best for you. :) Let us know how that goes.

  • For some reason my new Macbook running El Capitan 10.11.1 won't download the extension -- "Safari can't install this extension an error occurred while installing the extension "1Password." Tried multiple times and also tried downloading from the alternate location (AgileBits server, hosted on Amazon EC2)

  • Hello @JonSchiller,

    I would try restarting your Mac and then confirming that you don't have a copy of any 1Password 4.X Safari Extension already installed at all. I've seen that error before but only when somebody hasn't uninstalled an existing copy of the extension before trying to install the new copy. Just to clarify though, the 1Password 3 Safari Extension is completely separate from the 1Password 4 Safari Extension and those two can live side by side.

    If you're still experiencing issues after a reboot it might be worth us checking our a diagnostic report, this guide will assist.

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    When sending the diagnostic report to the address above it would help immensely if you could include a link to this thread and your forum handle so we can connect the two.

    Once you've sent the report a post here with the ticket ID will help us to keep an eye out for it. With access to the report we should be able to better assist you :smile:

  • I suspect you are correct on the Extension already installed. How do I find it? And how do I uninstall it?

  • Greetings @JonSchiller,

    If you open Safari's preferences and switch to the Extensions tab you will see a list of installed extensions on the left hand side. An extension can be installed but not enabled so it would appear as if it wasn't installed at all. If you're unsure at all you could post a screenshot of the list and we can tell you what we see although the entire list will also be in a diagnostic report too, part of the reason I offered it as a way to progress in the troubleshooting. As I say, seeing an entry for the 1Password 3 for Mac is fine as Safari should be viewing it as a completely separate extension, not connected to the newer 1Password 4 Safari Extension (which also works with 1Password 5). So if you have any queries before proceeding please do ask.

  • Getting closer. In the extensions tab 1 Password is listed on the left. Right side lists 1 Password 4.4.4. Now the program will autofill some of my sites, not all. Do you think I also need to load 1Password 3 extensions, and if so, How?

  • Greetings @JonSchiller,

    I have to agree, it does sound like we're making progress!

    Now it will sound pedantic but can we clarify what you mean by autofill please. The reason is we do see a couple of very distinct definitions used. Technically 1Password doesn't do auto-fill and we explain why on our page Why doesn’t 1Password automatically fill forms when the page loads? Instead we always wait to be instructed by the user. When some people contact us they mean that kind of autofill but some people are also just referring to 1Password filling when instructed as autofill.

    So if you can use the keyboard shortcut ⌘\ or 1Password fills when you select a Login item from 1Password mini then it does sound good. For this to work at all the current 1Password extension must be installed and working in your browser, 1Password mini must be active and able to communicate with the extension and if this is working we've got the fundamentals in place. You won't need the older 1Password 3 Browser Extension and in fact 1Password would only remind you on a regular basis that having both isn't a good idea. It's trying to be helpful but I find it annoying, probably because I know I have both and I'm trying to troubleshoot something.

    If it's a few sites that don't seem to fill now it might be these ones need updated, or to be more precise, their Login item replaced with a new one that is created by 1Password 5. Let's say it's just a few display thing particular behaviour. If you follow our How to manually save a Login guide to create a new Login does it work?

    If it seems to be a lot of sites we can try investigating but hopefully this isn't the case and it's mostly about the transition to a new way of 1Password doing things. We'll wait to hear back from you :smile:

  • OK, got it with a few manual saves, thanks so much. Incidentally, now the sites do autofill, automatically fill forms when the page loads, which is fine with me. Appreciate your prompt help.

  • Hi @JonSchiller,

    When you use your Login items do you by any chance click on the website field in the Login item? If you do that would be what we call open and fill and that would fill after the page is loaded and it would seem everything is working as expected :smile:

  • Got it, thanks.

This discussion has been closed.