Safari 5.1 troubleshooting

Why is Safari asking me to log into 1P when I am already logged in? When I log in in Safari it talls me to unlock 1P. I have tried locking and unlocking 1P, but Safari does not seem to notice.

Thanks.

cornelius

Comments

  • Have you tried doing what it actually says?
    • Quit Safari
    • Open 1Password
    • Check for updates just in case
    • (Re)install the extension > Preferences > Browsers > Install Safari Extension
  • corneliuscornelius Junior Member
    Daenney wrote:

    Have you tried doing what it actually says?
    • Quit Safari
    • Open 1Password
    • Check for updates just in case
    • (Re)install the extension > Preferences > Browsers > Install Safari Extension



    I have done all of those things. The only difference is that the 1P icon in the toolbar does not respond at all. No action, no messages.

    I have shut down and restarted, run Repair Disk in DU etc. Still no response.
  • thightowerthightower T-Dog Agile's Mascot Community Moderator
    edited June 2011
    cornelius wrote:

    Why is Safari asking me to log into 1P when I am already logged in? When I log in in Safari it talls me to unlock 1P. I have tried locking and unlocking 1P, but Safari does not seem to notice.

    Thanks.

    cornelius


    cornelius

    The data between the app and the extension mush be synced just open the 1Password app enter your password to unlock and then lock it back. The extension will now function as normal. Usually this only needs to be done once after an update.


    By your post.... have you just tried doing this from the extension or from the app in the applications folder the unlock must be from the full app in the applications folder.

    Lastly if you are still having issues make sure you have the latest version of the extension. Do this by going to the Safari Pref and Extension and look for the 1P the current version is 3.6.5 beta 23 (extension)

    Latest stable build of 1P 3.6.1
  • khadkhad Social Choreographer

    Team Member
    edited July 2011
    This issue should have been resolve in 1Password 3.6.1. Can you confirm that you are running 1Password 3.6.1 and not 1Password 3.6.0?

    If you are running 3.6.1 and still having the problem, could you please email us your Diagnostics Report? To generate the report from 1Password on your Mac, open 1Password and select Help > Troubleshooting > Diagnostics Report. Then attach the entire file to an email to [email protected]

    Please include a link to this thread in order that we might more quickly "connect the dots" when we see your Diagnostics Report in our inbox.

    Please do not post your Diagnostics Report in the forums, though.

    I would love to get this resolved for you.

    Thanks!
  • corneliuscornelius Junior Member
    khad wrote:

    This issue should have been resolve in 1Password 3.6.1. Can you confirm that you are running 1Password 3.6.1 and not 1Password 3.6.0?

    If you are running 3.6.1 and still having the problem, could you please email us your Diagnostics Report? To generate the report from 1Password on your Mac, open 1Password and select Help > Troubleshooting > Diagnostics Report. Then attach the entire file to an email to [email protected]

    Please include a link to this thread in order that we might more quickly "connect the dots" when we see your Diagnostics Report in our inbox.

    Please do not post your Diagnostics Report in the forums, though.

    I would love to get this resolved for you.

    Thanks!


    Thanks, for your response. I can, indeed, confirm that I am running the current version 1Password 3.6.1. I have attached a screen shot of the About 1 P. Thanks for the invitation to email you. I will do so.

    cornelius
  • corneliuscornelius Junior Member
    Update:

    Without having done anything else after yesterday's post today a new development. When I click the 1P icon in the Safari Menubar a !P box drops down, like the one in Chrome. However, it requires me to unlock 1P again, although I unlocked it directly in the app. So, whatever happened, I am now able to access 1P in Safari. Any guess as to what happened?

    cornelius
  • khadkhad Social Choreographer

    Team Member
    It sounds like there are two separate issues. First, autounlock is not currently supported in Safari 5.1, unfortunately. Second, without having looked at your Diagnostics Report, I couldn't really guess as to what was happening previously.

    It sounds like everything is working well now, though (factoring in the aforelinked known autounlock issue). If there is anything else I can help with, please let me know!

    Cheers,
  • corneliuscornelius Junior Member
    khad wrote:

    Second, without having looked at your Diagnostics Report, I couldn't really guess as to what was happening previously.

    Cheers,

    Thanks. I did email my Diagnostic Report. If there is anything of note, please do let me know.

    cornelius
  • khadkhad Social Choreographer

    Team Member
    edited July 2011
    It looks like Mike and Stu had already fielded your email while I was off. Unfortunately, there was nothing conclusive in the report. If it happens again, please generate a Diagnostics Report immediately. The closer the report is generated to the time of the occurrence, the more it is likely to help.

    It should just keep working well, though. :-)

    Cheers,
  • khadkhad Social Choreographer

    Team Member
    I just reread this thread and am wondering if you were using Private Browsing, cornelius. There is a known issue in which 1Password cannot be unlocked after restarting Safari 5.1 from Private Browsing mode. Just a hunch, for what it's worth.
This discussion has been closed.