Firefox Compatibility Mode

extensions.checkCompatibility should be set to "true"
Hi,

I had troubles with the new firefox 5 (I followed the steps described in the troubleshooting), until I discovered the reason: I am using the "Compatibility reporter" add-on for firefox, that keeps activated the 1password extension for firefox 4 (the purpose of the extension is to allow extensions to be run even if the version does not match, which is useful for some of the extensions that I use).

The solution is easy: just remove the 1password for firefox 4 extension manually from firefox 5 list of add-ons.

Benjamin

Comments

  • bswinsbswins Agile Customer Care
    Hello Benjamin and welcome to the Forums!

    Thanks for troubleshooting the issue down to a specific add-on. :)

    I was unable to replicate the behavior using FF 5 and Lion. What OS X are you running? Perhaps that is the difference?

    Regardless, thank you again for reporting your experience.

    Cheers!

    Brandt
  • MikeTMikeT Agile Samurai

    Team Member
    Hi Ben, thanks for sharing your research with us.

    This is also true for other add-ons related to the compatibility check, such as Nightly Tester Tools. If they are set to override the compatibility check to disabled, both of our extensions for Firefox 4 and 5 will be loaded. There isn’t much we can do about this because we follow the standard way for our extension to be compatible with the browser.
  • khadkhad Social Choreographer

    Team Member
    Mike is absolutely correct. As outlined in the Firefox section of 1Password's User Guide:

    For a few technical reasons, 1Password has to install two extensions in Firefox: one for Firefox 4, and one for Firefox 5. But if you disabled Firefox’s Compatibility Mode feature Firefox will load both extensions and cause problems.

    To reenable Compatibility Mode, follow these steps:

    1. Visit the URL “about:config”
    2. Search for extensions.checkCompatibility
    3. Ensure the value is true
    4. Restart Firefox


    Once Compatibility Mode is enabled, restarting Firefox should allow 1Password to appear in the toolbar.
This discussion has been closed.