Apple Watch issues: "Requires Pro Features"

johnforryjohnforry
edited December 2015 in Apple Watch

App will not work with watch says pro needs to be installed when in fact it is on my phone also deleted app reinstalled still not working

Comments

  • brentybrenty

    Team Member

    @johnforry: It sounds like this is what you're seeing:

    Is that correct? It's important to note that (as indicated by the main message), "You can add items in the 1Password app on your phone". Unless you add an item, none will appear on the Watch:

    1Password Apple Watch setup

    I hope this helps. Please let me know if you have any other questions! :)

  • I am having the exact same issue, the app worked on my apple watch previously, but I noticed today that I get the same error message as above. I have reinstalled the watch app. Added and removed several items and I get the same screen as shown above.

  • brentybrenty

    Team Member

    @dougee: Sorry for the trouble! I feel your pain, as I've had trouble with this after nearly every watchOS and 1Password update. For some reason iOS doesn't always send over the app to the Watch correctly. :(

    But first, you'll need to have installed 1Password for iOS itself using the correct Apple ID for Pro Features to be able to restore the purchase there (1Password Settings > Pro Features > Restore). Double-check to verify that it's showing as purchased there in the first pace, as otherwise it simply won't work.

    Next, make sure that 1Password Settings > Apple Watch > Enable Apple Watch is on.

    Then, you need to choose Add to Apple Watch for each item you want to show there.

    Finally, if you're still having trouble, please do the following:

    1. Connect both the Apple Watch and iPhone to power
    2. Open the Watch app on your iPhone, scroll down to 1Password, and set Show on Apple Watch to the off position
    3. Open 1Password on your iPhone and go to Settings > Apple Watch and set Enable Apple Watch to the off position
    4. Wait for it to stop saying "Uninstalling..." (this may never happen, but give it 5 minutes and then move on)
    5. View the apps on your actual Watch and if it is gone (in some cases, even those that completed "Uninstalling..." still show up)
    6. If it's still shown there, hold your finger on it and then tap the (x) (this may not work either)
    7. Regardless, hold the pill-shaped Side Button on the Watch and Power Off (you'll need to disconnect the power temporarily to do this)
    8. Then hold the Lock Button on your iPhone and Slide to Power Off (you'll need to disconnect the Watch from power temporarily)
    9. Power on both the Apple Watch and iPhone
    10. Verify that 1Password is not shown on the Apple Watch and that this is reflected in the Watch app on the iPhone as well (if not, go back to the beginning)
    11. In 1Password on the iPhone, set Enable Apple Watch to on
    12. In Watch on the iPhone, go to 1Password and set Show on Apple Watch to on
    13. Wait for the app to finish Installing...

    I hope this helps. Please let me know how it turns out! :)

  • That fixed the issue, thank you so much for your assistance back to my 1Password Watch goodness now.

  • chrisdjchrisdj AgileBits Support

    Team Member

    @dougee I'm glad to hear @brenty's advice helped out! Have a fantastic Christmas!

  • Yes! Thank you! I'd uninstalled a few times, but had never powered off my phone & watch. Thanks for these steps!

  • brentybrenty

    Team Member

    Excellent! You're welcome. I'm glad that helped. It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. We're always here to help! :)

This discussion has been closed.