American Airlines website completes all 3 fields but won't log in on auto-submit


I can get the American Airlines to correctly fill out all 3 fields (username, last name, password) but when I have the web form details "submit" field set to "Submit when enabled" the website does not accept my information. If I change just that one field to "Never Submit" and leave everything else the same and then manually click the "Login" button after having 1Password fill out the username, last name, and password, I successfully get into the site. Do you have any suggestions on how to get the 'submit when enabled' function to work properly?

Thank you,


1Password Version: 5.4
Extension Version: 4.4.3
OS Version: OS X Yosemite 10.10.5
Sync Type: Not Provided


  • brentybrenty

    Team Member

    @cpjhayes: It seems to take a few seconds for the form to load the site, but I was able to fill and submit at — just save the login manually to make sure it has the correct information:

    1. Navigate to the website
    2. Enter your login credentials
    3. Click the 'keyhole' icon to bring up the extension
    4. Click the 'gear' icon for Settings
    5. Click Save New Login
    6. Give it a name and Save
    7. Close the webpage and select your new login from the extension to have 1Password Go & Fill

    I hope this helps. Please let me know if you have any other questions! :)

  • @brenty: Thank you for your reply. I never had any issues with the login info being filled in correctly. My entire issue stems from 1Password's automated click of the 'login' button. When I set 1Password to do it automatically, I do not get an error for having entered missing or incorrect information, I get redirected to where I am still not logged in. If I set 1Password to not click the login button, and then click 'login' myself after 1Password has entered the data, I get logged in successfully.

    I hope this clarifies a bit. Thank you!

  • brentybrenty

    Team Member

    @cpjhayes: I understand that, but did you try my suggestion? This has worked for me with my own account, and I thought it might help you as well. Please let me know! :)

  • @brenty Sorry, I had meant to mention that I did try your suggestion yesterday but got the same results.

  • Hello @cpjhayes,

    I don't have an account with them like brenty does but what I did was I visit the homepage via the link you posted and created a test Login item using our How to manually save a Login guide. After doing so I reloaded the page and tried to fill using the new Login item. I was then sent to a We're Sorry page with a dedicated login form suggesting that there was an attempt to submit.

    So can you try something for us please. Can you try creating a test item with fake data and see if this happens to you. If it doesn't I wonder if it's browser related at all and I'd like to ask you what your preferred browser and it's current version is to make sure we're testing a similar environment here. I was testing with Safari but I think you're using a different browser.

  • Hi @littlebobbytables,

    I think there may be a misunderstanding. The link that I posted above is where I'm redirected after I try to use 1Password with the following link:
    I have also tried using: as suggested by @brenty.

    After letting 1Password (correctly) auto-populate the fields and letting it select "Login" I get redirected to:

    If I set 1Password to not automatically select "Login" and then click "Login" manually, I am properly logged into my account.
    I am currently using Safari Version 9.0.2 (11601.3.9) although I have the same problem when I try it using Firefox Version 42.0.

    Does this help clarify?

  • Hi @cpjhayes,

    Yes and no. I'm still quite confused as to why you seem to get such different behaviour from us. Now I'm muddying the waters a bit by not having a real account to test with but when I let 1Password submit after filling the error page I'm getting back would definitely indicate that a real attempt at logging in has happened and of course brenty can successfully log in.

    I have no idea if it's applicable at all or not here but can you check something for us please. Can you enter 1Password's preferences and switch to the Browser tab. Is Automatically submit logins after filling enabled or disabled? We know submitting is occurring for you but please still check just to satisfy my curiosity as I notice you're likely running the Mac App Store version of 1Password.

  • Hi @littlebobbytables,

    I am running the Mac App Store version of 1Password... specifically Version 5.4 (540046)

    The the preferences browser tab field "Automatically submit logins after filling" box is not checked.

    The web form details are set at:
    website =

    countryselector = en_US (text)
    languageselector = url= (Text)
    localPrefernceSaved = 'unchecked'
    loginid = (Text) (Personimage)
    lastName = (Text)
    password = (Password) (Key Image)
    rememberMe = 'unchecked' (Checkbox)

    display = Always
    submit = Submit when enabled (when I leave this as is I'm redirected [without an error message] to the home site. If change this field to "never submit" and click submit on my own I get logged in.)

  • Hi @cpjhayes,

    Okay, lets see if my hunch is correct.

    I suspect if you were to toggle the Automatically submit logins after filling option enabled and then disabled that you should receive a message with the title Autosubmit Script Installation is Required and it will look a bit like this.

    If the window that opens says it's in a folder titled then all you need to do is click the Open button. Open in this situation really means create and everything will be done. The only requirement is you have to be in the correct folder for this to work.

    If for any reason the window is looking elsewhere then there are some steps you can follow to get this resolved. Now the steps in this post were aimed at a slightly different issue but would also help you get this resolved. I believe all you would need to do is ignore step 3. to have the steps better tailored for your situation.

    After this if you leave the option in the enabled state does the Login item behave differently now? I don't know for certain but I think it might change something here.

  • Hi @littlebobbytables,

    Yes! That was it! Thank you so much for your help. I'm very impressed by the support that I received to help resolve this problem.

    Thanks for your help.

  • Hi @cpjhayes,

    I confess I celebrated this win as it wasn't obvious to start. I'm glad to hear it's behaving now and long may it stay that way!

    Should you ever any other troublesome sites though or just questions on 1Password please do reach out to us here in the forums :smile:

  • How do you modify an EXISTING login for American Airlines to support the LAST NAME field?
    Since they've implemented the LAST NAME field 1Password consistently puts my AAdvantage number in the LAST NAME field.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @pureetofu Right now, using the update login feature updates only the username and password of the login rather than the entire collected details of the page. We have an issue tracked for this. In the meantime, you'll need to save a whole new login and delete the existing one.

    I hope that helps!

    ref: OPM-2708

This discussion has been closed.