Online bank login issues

I have a problem on saving and filling logins on two different online bank sites. I'm using Google Chrome. The first site is https://www4.saastopankki.fi/pankki/. There is username field which is the upper field called Käyttäjätunnus / Användarkod and password field which is the other field called Salasana / Lösenord. No matter how I create the login item, from extension or from main 1Password app, it seems to only fill the username field, not the password.

The second bank site is https://www.s-pankki.fi/. There is orange button in the upper right corner of the screen called Verkkopankkiin. It opens the login fields, upper field is username and lower is password. Similarly, it seems to only fill the username field. Once I got it to fill both fields by saving login from extension, but I messed the login up by editing it manually ending it only filling username. Deleting login and saving it again by the same way resulted it again only filling username field.

I apologize that these pages are in Finnish only. But I think it is quite simple to find login fields. On these sites both the username and password fields are treated like password fields (typing is not displayd), is this the key for the problem or is it something else?


1Password Version: 5.4.1
Extension Version: 4.5.0.90
OS Version: 10.11.1
Sync Type: Not Provided

Comments

  • Hi @finadeon,

    So I've taken a look at the first site, https://www4.saastopankki.fi/pankki/ and I have bad news I'm afraid :(

    The site uses two password fields, one for your username and the other for your actual password. That by itself would be fine but every reload of the page results in a new ID for the username field. If the ID attribute for an input field constantly changes we can't use our default filling behaviour which we call "fill by HTML attribute". Now that doesn't complete stop things, what it means is we default to what we call "fill by HTML designation". The problem is this works on the assumption that a username will be filled into a text box and your password will be filled into a password field. This page though has two password fields and no easy way for us to reliably identify which is which.

    So we could have coped with the two password fields if the ID didn't change and we could cope with the ID changing if it didn't use two password fields. The combination though kills us.

    I haven't looked into the second one just yet but I will return to your query :smile: I only wish I could have brought better news for your first bank - sorry about that.

  • finadeonfinadeon
    edited December 2015

    Thank you @littlebobbytables for investigating this issue. It might be same thing for the second site because it too seems to have two "password" fields. I don't know though why I once got it to fill both fields on s-pankki.fi, but at that time I didn't verify that it really filled correct values on both fields.

    Lastpass does both of these sites fine, so maybe you could check out how they do this and copy little if it is not too kludgy solution. ;)

    It isn't a serious problem though if I have to manually enter bank account details, I can live with it and it helps me to remember those details for mobile use where it is not so convenient to look these details from password manager.

  • Hi @finadeon,

    The second site slipped my mind so thank's for the nudge. While s-pankki.fi does indeed use two password fields the HTML IDs seem to be fixed meaning that the test item I created by using our How to manually save a Login worked. It filled in both fields and both seemed to contain the correct value.

    I know you say you've tried to delete the broken Login item and create a new one but could I ask you to try again please. The only reason I ask is because it seemed like the test Login item I just created was okay. Do you find your new attempt behaves exactly as the old one?

  • @littlebobbytables

    I'm sorry, filling seems to work correctly when I manually type the username and the password when saving the login. I have been transferring logins from Lastpass manually one by one (at the same time verifying that they indeed work correctly) so I was autofilling them with Lastpass. Lastpass autofill -> save login to 1Password -> filling doesn't work, but manually type -> save login works.

  • brentybrenty

    Team Member

    @finadeon: Ah, thanks for clarifying. I'm sorry for the trouble. Without knowing for certain what LastPass is doing, but it's likely similar to 1Password in some ways.

    Significantly, browser extensions are based on Javascript, and sometimes the scripting on a website can interfere with the browser extension...so I can only imagine that the LastPass extension's script is causing this interaction for 1Password, which is running afterward. I know that simply having certain extensions installed can cause issues like this as well.

    And unless you're almost finished manually migrating data, you may want to check out @MrC 's converter, as it could potentially save you a lot of time and effort.

This discussion has been closed.