Credit card autofill info not working at Delta.com. RoboForm is working fine there.

Hi,

1Password filled in the card info (it may have missed the card expiration month), and then filled the "cardholder's first name" with both my first and last name. It left all other fields blank, including address fields.

I added labels in 1pass, such as cardholder's last name, last, etc., with no success.
Roboform worked fine, as usual - I have a few quibbles with the UI, which is why I'm considering a shift to 1pass, but have never had any form filling issues like this.

Any suggestions are welcome! Is this a known issue in general, and not restricted to specific websites?

Thanks,
Robert


1Password Version: 5.4.1
Extension Version: 4.5.1.90
OS Version: OSX 10.11.2
Sync Type: dropbox

Comments

  • Hi @rmilton,

    If the payment page you're wanting 1Password to fill includes not just details specific to the actual card but more general like first and last name and address then you might want to see if 1Password does a better job by filling with an Identity item first and then a Credit Card item. The way our filling works is we use certain mandatory fields in the categories that we use for filling. With a Credit Card item it is a single field for the full name as it appears on the card and the various numbers on the card itself. While you can add a custom section with a custom field of the address type we don't attempt to fill in using arbitrary data contained in the item. One of the other types you can fill with though is the Identity type which has a number of different fields to those found in a Credit Card item. It breaks the name up into first and last and it has an address field that is used for filling.

    We'd love to hear if this improves your experience of 1Password with the delta,com payment page.

This discussion has been closed.