Firefox 43 does not accept 1Password [need permission to both download an install the extension]

Firefox 43 does not accept 1Password, even if code verification has been set off in the 1Password program. The only suggestion Firefox gives is to disable all signatures, but that is not advisable and not acceptable for me.

What to do?

1Password Version:
Extension Version: Not Provided
OS Version: windows 10
Sync Type: Not Provided


  • Same here. Is everyone in the same case or is this a bug only a few people go through?

  • brentybrenty

    Team Member

    Firefox 43 does not accept 1Password

    @pir2: Can you tell me what you mean? Are you receiving some sort of error? It sounds like you may have a very different issue from code verification, which is usually caused by other software preventing 1Password from connecting to the browser:

    Invalid Code Signature (Windows)

    All of the cases I've seen where people had trouble installing the extension in Firefox was either due to 'security' software settings actively preventing the installation, or a problem actually connecting to the site to download it in the first place (which can be caused by other software, SSL settings in Firefox, or a networking issue).

    Same here. Is everyone in the same case or is this a bug only a few people go through?

    @pir2: Likewise, without some basic information it's hard to say what might be going wrong and how we might right it! Please tell me the OS, 1Password, and device versions you're using, the exact steps you're taking, and what is (or is not) happening the way you expect so we can figure out the best plan of action.

    The more information you can give, the better. Thanks in advance! :)

  • The extension Version number can not be seen anymore, because firefox disabled (in Dutch: uitgeschakeld) 1Password. I see this message when going in Firofox to add-ons and extensions. It says: "1Password could not be verified for use in Firefox and has been disabled". For more information there is an URL to add-ons in: special add-on-undersigning. It says that I have to contact 1Password to ask if they verify the 1Password extension with Firefox.

    Kind regards

    Jan Lichtenbelt

  • brentybrenty

    Team Member

    For more information there is an URL to add-ons in: special add-on-undersigning. It says that I have to contact 1Password to ask if they verify the 1Password extension with Firefox.

    @JanLichtenbelt: Indeed. We've supported extension signing for a few months now — since Firefox 40.

    It sounds like you simply have an outdated (and unsigned) version of the 1Password extension installed then. Please remove it from Firefox completely and install a fresh copy from our website:

    1password browser extensions

    To be clear, code verification is only an issue with 1Password attempting to verify the browser's signature, and only applies if the extension is installed and functioning. If not, 1Password can't even try to connect to the extension, and won't bother trying to verify the browser itself. This is a 1Password security measure to prevent 1Password from sending your sensitive information to an imposter browser.

    Extension signing, on the other hand, is a Firefox security measure, so that extensions need to be submitted to Mozilla for vetting, to cut down on spyware/malware extensions in their browser.

    If you're still having any issues, be sure to clarify what you're seeing. If it's simpler, take a screenshot of this. To include it in your reply, simply click the document button in the top of the comment field, and select the file you wish to share:

    And let me know any errors you encounter as well. We'll get to the bottom of this! :)

  • Thank you Brenty worked just fine. I was getting pretty cross about this. Happy Christmas!

  • MikeTMikeT Agile Samurai

    Team Member

    On behalf of Brenty, you're welcome and on behalf of the team here, Happy Holidays!

  • Dear Brenty,

    Thanks for help. I was not able to answer you the last (Chistmas) days.

    I delete 1Password from Firefox. Now I cannot see it anymore in Firefox under add-ons/extentions. But 1Password shows it is still installed, see attachment. What to do now?

    Kind regards

    Jan Lichtenbelt

    Ps. I heard from my son that he has the same problem since the newest version of Firefox. Perhaps a more general problem.

    1.jpg 60.7K
  • Hi, JanLichtenbelt

    I had a similar problem recently. You can simply click the button again, even though it shows the green check mark that says it is already installed. Clicking the button should launch your Firefox and show the 1Password plugin download page. If it does not install properly, use the alternate link given in blue text in "Your download will begin automatically within a few seconds. If not, please download the extension from its alternate location (AgileBits server, hosted on Amazon EC2)." I recommend to right-click this link, and use "save link as..." to download the installer file, which for me currently is and save that .xpi file onto your local disk. Then in Firefox use File > Open to open that .xpi file which should complete the installation with no problem.

  • brentybrenty

    Team Member

    @bkh: Excellent point! Thanks for bringing that up.

    @JanLichtenbelt: Since the buttons in 1Password are wired to open each individual browser, if they cannot be found or there's some issue with their settings (Firefox profiles becoming corrupt is unfortunately not uncommon) it won't work as expected.

    Another option apart from the workaround above is to go directly to our extensions page and download it:

    1Password browser extensions

    And if you're having trouble with Firefox in particular, you can also download its extension in another browser, and then drag the file to Firefox to install it. I hope this helps! :)

  • Dear bkh and Brenty,

    Although Firefox was closed, it say it is still open. I restarted the computer and now the Agilebits ahs been installed correctly into Firefox.

    Thanks for helping

    Kind regards

    Jan Lichtenbelt

  • brentybrenty

    Team Member

    Crazy! Thanks for the update. I'm glad to hear that all is well. It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. We're always here to help! :)

This discussion has been closed.